Maslow Home Maslow Community Garden Newsletter

M2 z axis runs forever issue. Anyone else solve this one already?

X and Y seem to be fine, but the z motor goes and doesn’t stop. The same motor works just fine on the mega. I was using maslowdue v20200811 or the one before that. They all do it. I can stop the z axis by pressing the sleep button, but as soon as the system reset button (upper right corner of makerverse) and the z axis goes on and on again. Do I have a bum shield or is it something obvious. The cables are in correctly and seated all the way. I tried the same motor and cable with the mega and it works fine.

The encoder is good and the wires should be correct… maybe A and B are swapped? it will run forever because it is going the wrong direction? That is the only thing I can think of unless the pins are not connected all the way on the shield…

currently using makerverse beta
maslowdue v 20200811

put it in tuning mode to tune z PID and look at zCMD. it runs until it gets to + or - 2147396608 or so and then jump to oscillating + and -

It appears the encoder is reading.

Any thoughts on how to approach a fix for this?

Z: Kp = 20480 Ki = 17408 Kd = 18432 Imax = 5000
err=-104327 i=-5000 iT=-87040000 d=-4 V=0 xCMD=0 yCMD=0 zCMD=2147396608
>
Z: Kp = 20480 Ki = 17408 Kd = 18432 Imax = 5000
err=-104321 i=-5000 iT=-87040000 d=4 V=0 xCMD=0 yCMD=0 zCMD=-2147300352
>

turns out there are 2 makermade board versions and V1 and V2 that differ only in the Z axis encoder pins being swapped places.

1 Like

hi Orob, I have experienced the same, does this problem have a solution?

in the firmware, you comment out one line with // and remove the // in front of the other line. When I did that though I started to get this other message about it being unable to find its position…

In the maslowDue.h file it is line # 29 and 30

V1 is the non silk screened board without the green plug on the end and V2 is the one currently being sold I believe with the side plugs.

The only difference between the 2 I can see is that the z axis encoder pins are flip-flopped

I am having the same issue. Anyone have a fix yet? Maker Made stopped responding to my emails on the issue.

I think the issue is the highlighted pic above. You need to flash with the firmware commented for the correct version you are using. The first part you need line 29 with the “V2” to be uncommented and line 30 to be commented by removing and adding the double slashes.

Thanks for your assistance and patience. I am very new to this. Can you please post a before and after pic of the code so I can assure I am editing it correctly.

Thanks!

Can you verify what motor shield version you have? A pic perhaps? Is there any reporting of the shield version from the software?

Before flashing the firmware to the Arduino, in the arduino IDE, look at the maslowDue.h


The 2 // (slashes) uncomment a line so this code is not executed.
Removing the // makes it accessible to the program.
Only have 1 line here without //.
Only do this if you are confident in what you are doing.

Edit: So removing the 2 // from line 29 would tune for board version V2, but 2 // would need to be added infront of line 30 to make that invisible for the program.

Kind regards, Gero

Gero,

Thanks for clarifying the steps with pictures and a cleaner description. The mega identifies the board number with a series of pins, but the due does not, so you have to know which one you have. If you have a makermade M2 version, chances are you have a V2. Makermade V. 1.2 is silk screened in white the one i have. I assume they are all 1.2, and I don’t recall the software default so that may need to be looked at.

1 Like

I think I have a V2. I just ordered it like 3 maybe 4 weeks ago! If you can confirm from this pic, I’ll try the work around.

Thank you both!

20200904_174456|666x500

That looks like a V2 comparing it with this picture

Where can I find that firmware version? I was under the impression that I did not need to upload any firmware with the new M2, so i just now pulled it off the flashdrive and it only shows one tab.

you wont need to flash it if you keep using the version of makerverse that is stable for now. If you have the problem I have, then you may need to either reflash or swap a couple wires in your motor plug, but I think flashing is easier. If you have the latest and greatest M2, Your problem may simply be it is plugged in to the wrong ports. Does your sled move up/down, left/right correctly and just the z is messed up?

Start by erasing the flash by typing in $RST=* in the command prompt window once you get connected to makerverse. You do not need to have the motor shield power on for this. Then go back and try setting up the system again. I would try that before doing any flashing. Post a screen shot of your maslow version number that shows up in the about tab in makerverse so we know what firmware version you are running.

yes just z is not working. Where exactly do I type this prompt?

here:

So once I do this, then I start the calibration over? Or do i then need to flash the Arduino?

Now I see you already answered this. Sorry.

Thanks for all your help

it is ok. happy to help. Did that fix the problem?

Z axis still won’t stop.

Does this look correct?