All motors fail test (2)

Welcome to the club! (We are more than you think :slight_smile: )

2 Likes

I am having this same issue. I test the motors and nothing happens. no noise, or green light changing on the board, and I still get a motor fail on all motors? I tried running a extension cord direct and even trying different outlets, uninstalled all the software and reinstalled all the latest versions. It worked fine a month ago when I last used it. What am I missing? I have really enjoyed the machine and would really like to continue to.

This issue with all of the motors failing is almost always an issue with the power connection. Do you see a blue light on the power supply and a green light on the Arduino shield which goes on and off as you plug and unplug the power supply?

Hi all

I’m also having the same issue with the fail test.

The motors seem to work when they feel like it. Have all the latest drivers etc and was at the last stage of calibrating it…

When I disconnect the unit the lights stay on for a long time?

What do I do?
Thanks

We’ll need a little more information to help you troubleshoot. Start with the “All motors fail” section in the wiki and let us know that you have checked and give us all those results.

1 Like

@Ryan_Carlson, your picture of your controller with the green light and the plug in the right port was so pretty I added it to the troubleshooting wiki. Thanks for posting it!

2 Likes

Hi

My one is from maker made so the green light is on the other side but it is on solid green.

Tried 're booting and disconnecting the unit but it still not working.

Thanks in advance.

Amin

@Commissionit Did you go through each of the four steps that jwolter linked for you from the wiki?

Hi

Yes, and on the 5th is talks about the green light that is on :frowning:

You unplugged USB from arduino and power from the shield?

In Groundcontrol, does it show “connected”? Has it ever worked before?

Have you disconnected cables at motors and plugged back in?

Some pictures of you groundcontrol screen and arduino/shield would help communicate the issue.

Hi, followed your instructions and also did a complete 're start. The motors have worked in allowing me to do most of the calibrating,.moving adjusting the chain but did not always respond when even doing that initially.

This is how it starts

1 Like

Am now also getting the https://github.com/MaslowCNC/Firmware/wiki/Keeping-Up sled is not keeping up warning.

Can’t see.position error limit under advanced to try changing the parameters either?

Thanks

There is a log.txt in the GC folder, but that gets really big if not deleted once in a while, making it difficult to check.
If you delete it (GC closed) and restart GC it is created fresh.
If you could upload a fresh log.txt after doing your steps including the errors, that could help to narrow it down.
Until you do not get pass the motor/encoder test, don’t bother with

Edit:

It should be at the bottom, but should only be changed if the other sources of the message are excluded!

Kind regards, Gero

@Commissionit I’m a bit confused as to where things stand looking at the first picture that shows position location updates, then a motor test of all motors failed but you also said:

Did the motors work during calibration but before completing calibration you stopped and did a motor test?

If you begin calibration and don’t complete it, you can expect some odd behaviour. Make sure to use the “How To: Get Calibrated” wiki page.

I would start over with calibration while using the wiki. Read the wiki step, then perform the action in GC. It helped me a lot.

1 Like

This may be unrelated, but in another thread there was an issue with commands not being able to finish properly and hitting the stop button in GC a few times helped that.

Just a suggestion from the peanut gallery.

1 Like

Thanks, have tried clicking the stop button, did not seem to do anything.

Into a the motor test as the calibration stopped working when towards the end when setting up the z.

Have not get everything working yet just managed to get the x and y motors to work and move in the calibration process.

Do you mean start again from How To: Get Calibrated! ? Is there a way to 're format or reboot the hardware software ?

Thanks

Yes and yes. In GC, actions, advanced, there is a “wipe eeprom”. After that shut down ground control and unplug the arduino, plug back in, open ground control.

1 Like

Thanks, the reset method does work, thanks but when I follow the same calibrate setup, after entering the distance between motors and top work area non of the motors . Can’t help thinking my maker made hardware is faulty? No one else seems to be having this issue.

Very frustrated…

Amin

are you using commas or decimal points when entering the distance?

1 Like