Maslow Home Maslow Community Garden Newsletter

New setup - motors don't pass tests

#1

Hello,

I bought different Maslow CNC parts from multiple places and finally found time to start assembling everything.

For Maslow CNC controller, I got The Blue Smoke Herder Shield - AKA the New Maslow Shield (TLE5206). I installed GroudControl on Mac, I successfully upgraded the firmware on the controller. I attached a couple of motors, and then I try “Actions => Test Motors / Encoders”, I hear some sound from the motors, they vibrate a bit, but the motor shaft doesn’t turn on both motors. I’ll continue digging deeper into this problem but decided to post this issue here in case somebody already faced something similar.

#2


#3

Sounds like it might be the encoders. can you show where you got your motors from and their pinouts?

The other common reason for this is that you have the power plugged into the arduino, and not into the shield. The power supply should only be plugged into the shield. The shield back-powers the arduino.

1 Like
#4

2 Likes
#5

@Jatt, thanks for a quick response! The power goes directly into the Maslow Shield.

1 Like
#6

Right motor and Z are plugged in in the pic. Where is left motor?

#7

Ah! I thought it could be the motors aren’t correctly connected. These are both main motors and Z-Axis motor is not yet attached. I have Z-axis motor too, let me connect all three motors (and correctly) and see if it helps.

Just to be sure, is this how it should be:
MR1 - Z-xis motor
MR2 - Left motor
MR3 - Right motor

#8

Hmm, I would try unplugging and replugging in both motors, at the shield and at the motor.

The only possible thing I see that could be a problem on your image is that resistor right below the red power led doesn’t look to have the proper amount solder in the holes. I don’t know if that would effect anything though, it might have plenty of solder on the bottom of the board.

screenshot1556225158%401X

#9

Z is the middle one. In the pic right motor and z connected.
MR1 - Right motor
MR2 - Z-xis motor
MR3 - Left motor

1 Like
#10

Interesting! Also, I connected it like his now:

Then I did a test and at the 1st attempt, I got one PASS and at the 2nd attempt all FAIL.
I’ll check all the wires and the resistor!

55

#11

Also check this area from the side, that there is no shorting from the shield to the Arduino USB casing.
image

#12

I actually bought two Maslow Shields (just in case I have issues) and just tried the other one. Works all good. Z-Axis motor is not attached yet, but the main motors turn and passed the tests. The second one still had the original firmware version installed at the time it was shipped.

#13

I’ll attach Z-Axis motor just to see if all three motors work fine.

#14

All motors rotate without the problem, however, the tests show FAIL in some cases…
I’ll upgrade firmware to the latest version.

19

#15

I upgraded to the latest firmware : 1.26 and now all three motors fail in the same way as they were on the first Maslow Shield. So this could be the firmware issue… Let me see if I can downgrade it back to 1.23 version …

#16

You might need to clear the eeprom if you downgrade the firmware, not sure.

Is anyone else out there with the TLE5206 board having issues with the v1.26 Firmware?
Maybe one of the people who have worked on the firmware or the TLE5206 board can spot the issue?
@madgrizzle @bar @blurfl @c0depr1sm @Bee

#17

These are my latest findings:

  1. 1.23, 1.24, 1.25, 1.26 work all fine (motors spin) if I download the specific version from the releases section.
  2. 1.26 fails (all three motors just buzz) if I take the latest source code.

In all 1.23 - 1.26 cases when motors spin, I don’t get consistent PASS / FAIL results. Sometime it’s a PASS, sometimes it’s a FAIL, but motors seem to work fine.

#18

I have FW/GC 1.26 from the releases running on the TLE.
Will test the source in the morning.

#19

Are you sure it’s 1.26 and not 1.27 you downloaded the source code for?

#20

When I upload firmware from the master branch, GC still detects firmware as 1.26, but as far as I remember there 26 changes in the master branch since 1.26 release.