Anyone able to load WebControl on Pi 4 using "buster lite"?

This question is an off shoot of another thread I started where I asked for help loading WebControl on my Raspberry Pi 4. I got some fantastic assistance but I’m starting to wonder if it has something to do with the fact I have the relatively new version 4 of the Raspberry Pi?

What I’ve tried: Downloaded the 2020 version of Webcontrol buster lite onto my laptop and unzipped it. (I actually downloaded it 3 times thinking it may have not downloaded correctly). I then used the Raspberry imager and selected “use other” for operating system, then selected the buster lite file (3 different unzipped copies were tried as I stated above), Selected my sd drive, Went into the hidden menu and selected all the items I was instructed to by Orob (ssh, password, wifi setup and password, etc). I did this procedure multiple times, switching out sd cards, etc.

What happens?
During the flashing of the buster image to my sd card(s), about 50% of the time I get an error message on my laptop and a blue screen comes up saying there is an error and it must restart my computer. When this happens, I have simply restarted the entire process as stated above and usually it “works” or at least imager says that the buster lite file is now on the sd card. I then insert the sd card into my raspberry pi 4 and plug it in. What shows on the screen is never exactly the same but generally I will momentarily get a box with primary colors in the corners, followed by but not always a blue box saying something (never stays on long enough to read it) followed by a black screen with 4 raspberry images in upper left and lines of commands or whatever you call it scrolling on the screen, then black, then some more scrolling for a few seconds, then black, then it freezes. I have done this entire procedure over and over probably 15 times and I swear it freezes at a different line each time. Of course it is impossible to “shut down” the pi to eject the sd card so I unplug it. I believe doing that destroyed an sd card because my laptop no longer sees it when I insert it in the drive.

Like the title says, has anyone been able to load WebControl on a raspberry pi 4 using the buster lite image? If you could not, how did you get WebControl loaded? I’m not a computer geek so if it requires much more than the procedure I described above I’ll probably screw my Raspberry Pi to my wall of shame in the garage, along with all the bent connecting rods, stripped gears and twisted driveshafts.

Thanks for your feedback, I appreciate all of you.

for what its worth, i load buster light on the pi4 first then install WC on top of it. the combination of the two seems to work fine. i have never installed the pre built image though.

OK so like I said, I’m computer illiterate…

Isn’t the sd card the entire memory system for the Pi? And since there is only one sd slot on the pi4, how do you do what you just said? My tone is completely humble, please understand. I’m trying my best to understand this stuff since I’m not an IT wizard.

Second question I have is that I thought the buster lite file was the webcontrol program? When I would go to add it to my sd card with the OS on it (yes, I had my Raspberrry pi4 running prior to all this) the imager program would say “you will loose all files if you do this” ( OS), or something to that effect. I questioned this and was told the buster lite file had BOTH the OS and webcontrol on it. Obviously I’m missing something… probably my fault but hey, ACME refers to my ficticious garage name which is “ACME Speed Shop”. I’m a motorhead (a pretty high tech motorhead but a motorhead nonetheless)…enough said probably.
Do you remember how you did it? If it involved an elaborate list of steps where you are cutting and pasting computer code, you can just say that and I’ll screw my pi to my wall of shame, but if its relatively simple, please share.
Thanks so much, Jerry

I just read the other post that you are engaged in with @Orob and others regarding your issues. Asside from my input below, I would encourage you to keep working through that thread and not continuing on this one. Trying to split yourself between two seperate posts will prove confusing to you and difficult for you to keep up with. Besides, the advice they are giving you is pretty solid and I don’t want to derail what they are trying to do. I’ll chime in on the other post if I can add anything of value.

Yes it is. It is the main “hard drive” of the Pi. It contains the operating system and all installed applications and user files.

Buster - Light is the command line version of the Raspberry Pi OS (formerly called Raspian). It does not contain a GUI (Graphical User Environment) so there won’t be a linux desktop when you boot the Pi. All you will get is the Command Line Interface (CLI). This is good from a processor resources perspective, but if you don’t have any command line experience, it can be a bit of a learning curve to get used to.

WebControl (WC) is an application that gets installed like any other software application on Linux or Windows machines. Although the installation on a RasPi is Linux specific. Specificaly, Web Control is a web server application. It’s main functionality is to serve web pages that allow you to interact and control the Maslow.

When I mentioned how I usualy install and run WC, I was referring to the approach I outlined above. It’s the typical approach but not the only approach (see below).

There are two ways to install WC. The first is the approach I outlined above where you first install the operating system image to the SD card and THEN install Web Control. The other option is to burn a pre-configured RaspiOS image that contains both the Buster - Light OS AND the Web Control Application to the SD card.

I’m guessing here but I think that you had previously loaded RaspiOS Buster - Light onto the SD card and had a functioning PI. You then tried to re-image the SD card with the pre-configured version of Buster - Light containing Web Control. When you were told that the “Buster - Light file had BOTH the OS and WebControl on it”, this is the version of which they were speaking.

Let’s start here. Is this where you got the version of Buster that you were told contained both the OS and WebControl?

Thanks, I agree it is best to keep following one thread but it was starting to feel like the very definition of insanity…doing the same thing over and over for several days expecting a different outcome. Not to mention feeling like a moron for nothing working as I was instructed. I started this discussion because I was thinking it might be a problem with the rasberry pi 4 but it was a long shot on my part. The fact you have got it to work answers my question.

Honestly, to answer your question, I am not sure where I got the buster version but it is: 2020-02-13-webcontrolcnc-buster-lite-0.1.1

Hey… I switched to Linux in the mid-90s. I’ve been doing it professionally for A LONG time. I say this… because getting WebControl to work was VERY FRUSTRATING. So… here are my recommendations:

  1. use the Raspberry Pi Imager

  2. If you have a Linux box, use that. OSX works, too. Windows most likely also works.

  3. If you know how to verify checksums… do that. My first image (thing you burn to the SDCARD) didn’t work. Rather, the OS booted but the webcontrol service did not. I was quite frustrated. Out of desperation, I changed Pis (I have a pile) and did a new download of the image. This worked. In retrospect, I should have compared the checksums. Etc.

  4. if the previous step was incomprehensible… try to do a git clone from github. This is a worthwhile thing to learn. If you continue playing with OSS projects… it’s absolutely worth learning (surely there are videos and tons of web articles). If in-doubt… clone again to a second directory and compare checksums (again, there are a lot of tutorials/etc about this).

  5. asking questions is great. People want to help. It’s always best, of course, to search the forums for your issue (people often post similar problems) and to do web searches. You will likely always find jerks (and I’m not trying to be one, currently).

  6. A self-deprecating an humble stance gets you far. It’s not required… but it’s better than being a jerk. We don’t walk out of the womb knowing this stuff. My suggestions (above) might be over your head… but I hope that there’s enough there for you (or the next person) to know “key words” to search for on the web (seriously – I write code for supercomputers and have built a career off of web searches).

  7. Perseverance will generally work. There’s also value in knowing when to walk away and do something less stressful/more fun.

  8. Everything breaks. Downloads frequently introduce minor errors (annoying that github doesn’t publish checksums). If in-doubt… try to verify that you’ve gotten a reliable/good download.

  9. There are so many things to learn about. I’m excited for you. Use every problem as a learning opportunity… and plan for these things to take WAY longer than you expected and probably a bit longer than you’d like. For me… at this point… it’s usually quite easy… but that’s certainly not always the case. Welcome to life!


Thank you. I am not afraid to tackle anything but for me the hardest part of the computer part of this is the language barrier between a complete novice such as myself and the super-geniuses on here. I ALWAYS search the forums first but probably don’t know the correct words to use in my searches. For example, “verify the checksums”…say what???

I worked a long career training power plant operations and maintenance personnel on just about everything. Once I was tasked with training the operations crew on how to start up a gas turbine (they were totally controlled remotely with a push of 1 button on a computer screen from 50 miles away) . These gas turbines were in a fenced in area outside of the coal plant they operated. At one site they were actually 10 miles down the road. In the event, the remote start would not work, they needed to start the units manually in 10 minutes or so. They would NEVER remember how to do it because the frequency was extremely LOW but the importance was extremely HIGH. So I created a procedure. Each step had a corresponding photo of a control panel, valve, pressure gauge, whatever, with a corresponding numbered arrow. The procedure was not used by anyone until about 10 years later when some sorry sap got the call. He called me the next day to thank me and said it worked flawlessly. I think learning to program or verify checksums is the same. I’ll never remember it, but there are lots of great resources out here to help. The key is to keep it simple.

1 Like


Most of the people on here aren’t abnormally clever. With your “process-driven” background… you could do well with computer programming. Well, if that interests you.

I’ve run Python (a computer language) Hackathons for a massive company that you know. However, I remember a time when writing a web page (HTML) was voodoo. None of this stuff is really that difficult. It’s FRUSTRATING at times… and, ultimately, not knowing the right questions to ask is one of the hardest parts. Just last week, a friend couldn’t figure out how to do a background check on a prospective employee. I google’d “how to perform pre-employment background check.” I found a mountain of results. Based on my background, he thought that I’d “know something” special. Nope. I just phrased the search differently.

I mentioned checksums and git clones for a specific reason: they’re a good place for you to start. Even better, use that Raspberry Pi to control your lights – or your Pandora stream (I did this when Pis were a new thing). Given your background, make a sensing system using a Pi. Want to predict pump failure? Monitor the pipes for changes in vibration (bearing about to fail). Want to predict when the pressure is about to rise? That involves ML (machine learning)… but there are far simpler proxies for that.

Ditch your Windows machine for most things. Get a Pi or a Linux box for surfing, music, etc. You will learn very quickly. If you want to. Everything you described in your example can be done with a script with speed and accuracy exceeding what humans can do. And logic is simple – it is or it ain’t. Really. Now, you can combine a set of yes/no questions to make a more capable system… but at the end of the day, it’s nothing mind-blowing. 0 or 1. True or False. Evolution moves at a pace that makes a snail look like a FTL (faster than light) spaceship. Human thought… well… yeah… snail snot on a good day. Keep at it, man! This isn’t that difficult. The vast majority of people doing this stuff are just running code/etc that other people wrote. It’s… just… not… hard. Good luck!

1 Like