Web Control Raspberry Pi Model 3b

I’m a router and computer away from getting my new Maslow up and running (read, I’m not close :slight_smile:)

I can’t find a Raspberry Pi 3b+ anywhere right now, but I do have access to a model 3b. Would that work alright with webcontrol?

Should be no problem. I ran it on a pi zero and didn’t see any issues (was a tad slower, but that was all)

How is webcontrol running on a pi4b these days? Seems a shame to pay as much for a moldy old pi when there’s a tasty faster new version

“They” claim the heating problem has been addressed in firmware

No matter what they say you need a cooling system! Mine is stable but my Money is n the older pi ATM. Why the PI 4 Sucks? NO OS Boot over USB, NO mainline support for a desktop other than Pi Foundation. If you are going to run a Sever build you can defiantly wade in. Docker is not supported but can be hacked. Still too much not working.

My 2 Cents

Thank you

1 Like

I’ve been running webcontrol on a headless pi4 with buster-lite for five or six weeks. Seems to do fine, though webcontrol and ssh are the only things active. Same for a pi-zerow and pi-3B+, all seem capable of running webcontrol as their principle task.


I found a pi3b to test. Using it to run webcontrol using the buster-lite headless configuration on a moderately complex gcode file, the CPU percent value in webcontrol hovers between 30% and 40% on the pi3b. :+1:

For comparison, a pi4 running the same setup reads between 20% and 30%, and on a pi2 (using a USB wireless network adapter) I see between 30% and 65%.

I think that if all the pi is doing is running webcontrol, any of the models are up to the task. Note that none of these are running a camera or a desktop version of the operating system. I think those could add to the load on the CPU, but I’m not in a position to test. I use ssh to start webcontrol on the pi.

It is a feature of the recent Raspbian versions that one can move the SD card from one pi version to another when upgrading to a new model of the pi. That makes the prospect of a hardware upgrade simpler :grin:


So maybe it’s not too hard to make a prebuilt image then…

1 Like

I thought there was some architectural changes that prevented booting the same images, but haven’t been following Pi’s that close lately. Could be some interesting startup files.

I’d pick one up but the to-it pile is already way to large. Currently toped by an Ender 3 pro (the bendy mag thing is a flop), just not enough play time these days :worried:

Can’t remember where I read it, and it seems to work. I’ve been using the same SD card on all those Rpis. Boot up, ssh in, start webcontrol, browse in from a tablet and run the cut file.

1 Like

Found a Raspberry Pi Model B Rev 1 to try ‘for science’ - it runs webcontrol, but shows ~97% CPU use. Still same SD card, no camera or desktop. At 97%, probably not the best board for the job, but if that’s what’s on hand it could get you up and cutting…


Thanks for the info, everyone! I’ve been lurking on these boards for a while in anticipation of someday getting a kit and it’s nice to see such generous support!

1 Like

The new boards won’t boot the old images, but new images will run on the old

David Lang

I have seen the same on my setup using an old rPi B r1. I have to do some more testing, but I think that it has essentially removed the ability of my using the maslow for cutting curves. Seemed to send gcode commands once per second, literally. I need to test it with some other gcode with curves I ran before to make sure it is not something in the specific code I was trying, but it was painful to watch the machine lurch .05 inches then pause and wait for another gcode command.

I am not sure if it makes a difference that I have a monitor connected to the rPi. I am running buster Lite and have no desktop, just the basic text on the connected monitor (connected using hdmi to vga adapter, in case that is relevant). No camera, but I do have a power switch that monitors a couple pins, but I can’t see that as causing 99% CPU utilization.

If my testing reveals that it is the rPi that is the bottleneck, then I likely have a trip to Microcenter in my future

I was running buster lite headless with nothing else. I decided that my Pi B r1 is a good old dog, but maybe better for some milder use. I’ve put it to monitoring a UPS as it’s only task. That seems a good job for the aging friend.


I’m following this with interest.
im running a headless Rpi 3B, and it runs at 95%-100% all the time when webcontrol is on.

when i shut down webcontrol, usage CPU usage drops to about 15%.

Htop shows it’s mostly webcontrol.

any hints on making this less cpu intensive?


Perhaps take a look at this post. Still in testing, but promising.

I’ve not experienced that high of a level of CPU usage. How many web clients (remote browser windows) do you have open and connected to the webcontrol server? Is it running high usage when idle and you have no gcode loaded?

No offence intended @ mad grizzly :rofl:

none taken… I would love to see everyone use the new hotness.

1 Like

I typically only have one web browser at a time open
I went around and closed any tabs on any other computer in my house, but none of those computers were “in use”. They were all laptops or tablets that were closed or asleep.

No gcode loaded.

How would I tell if there were a lot of open connections to webcontrol?