Maslow Home Maslow Community Garden Newsletter

Arduino not starting

Arduino opens says it is initializing then closes. Running win 10 on an older laptop with an ssd hard drive.

Follow up I also tried this on a near new desk top with same results.

Are you trying to flash the firmware by using the Arduino IDE?
Try downloading webcontrol, Unzip the folder and double click on webcontrol.exe. Selecting the proper port (maslow settings) and then upgrade standard firmware (Actions menu)

No, I’m just downloading and installing the Arduino IDE software. I get the icon on my desktop and when I click on it the I get an opening screen with the word “initializing packages” in the lower-left corner then it all goes away. IMG_17871|666x500

Check/post at the arduino forum.

https://forum.arduino.cc/index.php#c2

And specifically this post…

https://forum.arduino.cc/index.php?topic=689624.0

Ok thank you, got past that hurdle now after loading firmware and clicking upload tab I get the follw error:
Arduino: 1.8.12 (Windows 10), Board: “Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)”

cnc_ctrl_v1:36:10: fatal error: Maslow.h: No such file or directory

#include “Maslow.h”

      ^~~~~~~~~~

compilation terminated.

exit status 1
Maslow.h: No such file or directory

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

I went back and reloaded everthing again same error.

99 out of 100 times, that error message comes up because the user accidentally loaded the file from the compressed directory. Make certain you are loading from the directory where you uncompressed the files.

Ok this is getting old! Ground Control would not download a zip file from the web source so I located it on the USB drive that came from MakerMade CNC. I unzipped it into its own folder and started it with Launch Control Center, and got the following error:
image
I’ll be the first to admit I’m not a computer person and just maybe I’m in over my head but I can follow instructions and when the results don’t match the instructions what is a guy suppose to do?

do yourself a favor and don’t use groundcontrol. Use Webcontrol. Works in windows 10. see link in my previous post. since you got arduino working, you should be able to just set the serial port and then calibrate. There are instructions here on how to calibrate with webcontrol.

Thanks to both of you for your assistance, Web Controller is up and running. Tomorrow I’ll will cintinue watching vidoes and move back to the garage and starting mounting hadware.

2 Likes