Maslow Home Maslow Community Garden

Arduino Problem


#1

I’m having a major issue with the Arduino. I got the Maslow 10 days ago, spent the first weekend building the frame, sled, etc. Everything was working wonderfully, having made several cuts.
I engaged in a project this evening. The Maslow went to make the first cut and began traveling the cut path with no z axis adjustment. I immediately stopped the cut and told the Maslow to return to center. It did. I opened the z axis controls in ground control and attempted to remedy the situation with no response from the computer to the motor.
Within seconds I received a “timeout error” on ground control. I checked my cables and it looks like everything is clear. I checked the port on ground control. It’s correct.
I checked the lights on the arduino and everything is on (yellow on L light, green on arduino, green on the Maslow).
I unplugged the Maslow and reset the Arduino. Lights came right back on as good.
I quit ground control and opened up arduino. It read out “timeout”.
I then disconnected the usb cable and tried again. The message read, “timeout communicating with programmer”, “an error occurred while uploading the sketch”.
I then proceeded to delete the arduino software and firmware, completely removed it and all residual files from my computer and reinstalled from scratch. The same error message appeared.
Lastly, I got another computer (Mac) and installed the software and received the same message.

I’m at a loss. Please help.


#2

This could be caused by RF interference. I haven’t seen it happen quite like that, but the first thing I would try would be to move to a different room and use a different (preferably shorter) USB cable if you can.


#3

Hi bar, I was just speaking with a rep from Maker Made. The USB cable isn’t touching any wires. It ran for a week with no issues. Why would it just now pick up some interference? It seems to be a boot loader issue.


#4

@SilasB

Try uploading the Blink example from the Arduino IDE. EMI is and environmental issue. The playing field changes minute by minute. A working light bulb worked the moment before it stopped. Unless you have some expensive and complicated equipment you can’t see it. I’ll give you an example. How likely is it the same temperature to 1 degree as the same time yesterday?

First try what Bar said. The try what I said.

Let me know what happens with Blink.

Hope that helps.

Thank you


#5

SilasB, it may be other wires or interference. My suggestions; I would separate all the cables an inch or two including the motor/encoder cables if they are close (they are not twisted pair or shielded lines), Place chokes on all power and usb cable (or use a USB with a choke built in), My router was electronically the nosiest and got worse with a few hours of run time. So you may have been almost interfering when new, but over the limit with some router age. Don’t secure any cables close to any motor such as the router or Zaxis motor as they are noisy. See what other electronic devices are also on the same circuit and turn off to try, vacuum, lights, etc. I also had these timeouts and sled not keeping up errors at the beginning of my “shake down” runs but fortunately that is now a thing of the past. Only after trying these solutions would I suspect the Arduino as they are “mostly” stable. Jon


Ground Control message continually toggles from "Connected" to "Not Connected"