Maslow Home Maslow Community Garden Newsletter

Bore action doesn't bore

I was making the top mount part of the Bosch kits out of wood.

I think i made some mistakes in the cam part because the holes weren’t drilled all the way trough. On the back part you can see where it made 5 loops (which is the amount of helixes it should have made) and then just went down in one spot and came back up.

The holes the bolts go trough it didn’t even do the drilling action, just the loops. I used the bore function in fusion.

I’ll include the files when i get home.

2 Likes

Was this with the Maslow post processor in fusion? I believe that there are some boring specific gcode commands which we don’t yet support

Aah, is there a maslow post processor? I was thinking i’d try a pocket operation tomorrow when i have the time.
I was surprised that as a first project the measurements were pretty much spot on after the first try, i was expecting more touble calibrating. Guess that is the result of a year worth of forum reading.

5 Likes

Have you also been using the GRBL post for Fusion? I’ve had a fair amount of success with it. I haven’t tried the “bore” operation though, I just use the drill one:

image

The G-Code just looks like this:

(Drill1)
M9
T1 M6
S10000 M3
G54
M9
G0 X80 Y-219
Z5
G1 Z-3 F100
G0 Z5

So it’s merely telling the Maslow to interpolate to the correct Z depth, then retract back to the safe height. Maybe the bore operation uses G81 or G82, which I don’t believe the firmware supports.

1 Like

In my experience the helical boring doesn’t work with grbl post processing on fusion 360. As I recall the Maslow does not yet support moving x y and z axis simultaneously. Maybe I am out of date though.

You’re right on this with respect to arcs G2, G3). :+1:t2: Straight lines (G0, G1) can handle all three.

2 Likes

I’m pretty sure a Pocket operation will take care of the situations where you want to clear more than the Tool Diameter worth of material.

2 Likes

I should have said that i’m completely new to cam, i just used the actions that seemed most logical to me.
Drilling works fine for the 3mm holes, but for the 5mm holes i tried boring, i’ll try pockets when i get home again.

It does tell me that the ramping diameter is too big or something when i try pocketing a 5mm hole with a 3mm bit. but i’m not sure what ramping is :slight_smile:

Does anyone have a link to a good, complete cnc course? I feel like i got a lot of learning to do before i teach myself the wrong things.

I’ve learned the most about Fusion360 CAM by searching operations by name in youtube… also the channel NYCCNC. Remember that with regards to Fusion360 CAM, the examples could be for metals machining, as long as its a 3 axis machine it’ll work the same for Maslow (>95% of the time).

As far as CAD in Fusion360, this course: https://mikeandlauren.thinkific.com/courses/fusion-360-for-hobbyist-and-woodworkers (recommended by someone here in the forum a few months back) was a huge help in making sure I was beginning parts from the proper perspective and taking full advantage of Fusion’s capabilities when making a project from scratch. (mostly that there are some ‘component and part nesting’ techniques that you’ll want to start out with to maintain the most flexibility down the line.)

2 Likes

My understanding of helical ramping is cutting a circle while plunging at the same time. If you were to stop a cut in mid process I believe you would see something like a spiral ramp left in the material. However the Maslow cannot do this as stated by burfl. A pocket operation will work however make sure and set multiple depths option on and I recommend setting the maximum depth per pass to 1/2 the tool diameter or less. Also turn lead in and lead out off. In Fusion 360 if you hover your mouse over a setting there is often a visual description of what that setting does.

the maslow can do 3D coordinated movement, what’s probably happening is that the
g-code that’s being generated isn’t supported by the maslow.

3 Likes

I think that @dlang is right and that the generated Gcode uses boring specific Gcode commands we don’t support yet. My guess is that the boring operation will work when used with the Maslow post processor because Fusion will model the same process using supported commands

3 Likes

Ahem, sorry about this, I was using the wrong post when I ran my initial analysis. I hadn’t set up the Maslow Post on this computer yet and glossed over the detail. I’ve left the text of my original reply just for context.

So I decided to test the difference between Fusion’s drill operation and bore operation. They definitely produce different results. Based on @blurfl’s input that 3D arc interpolations aren’t supported by the firmware, I would say the bore operation isn’t going to work on the Maslow. It carves a 3D arc in a helix to form the hole. You can see the helix in the Fusion interface.

What I said here about the spiral form still kinda applies, but the Maslow post is smart enough to break the spiral down into a series of G1 straight cuts, so it should work. It is a good idea to use the operation if you do not want to change bits while also making profile cuts and the like.

I would still prefer using the drill operation I spoke of earlier. You will need to chuck up a bit in your router, but it works quite well. The only issue is the Z feed rate for the stock sled, but I have just been using it to peck a dimple into the surface and I just drill the through-hole myself.

2 Likes

Somewhere in a file on the forum I think I saw helical boring done as many tiny straight lines in XYZ. That would work, but I don’t remember where I saw it…

1 Like

The nc file I made is here:

MaslowPost_BoreTest.nc (118.9 KB)

I’m not near my machine, so I haven’t tested it. But I don’t see why it wouldn’t work.

1 Like

I thought so, i’ve been talking about 3d carving a while back, and i’d assume someone would have mentioned that it can’t work if that was the case.
This weekend i’m gone, but i’ll give it a test next tuesday.

I do seem to be liking fusion so far, no more tricking sketchup into helping me, fusion is designed from the ground up for what i need.

Your .nc file works just as desired, the bit follows a helical path (clockwise?). That’s what I remember seeing in an earlier file. :+1:

1 Like

In fake servo GC has some issues rendering and the lines without Y seem to teleport the sled to new destinations within the bore.

G1 X73.4160
G1 X73.3460 Z-17.992
G1 X73.2780 Z-17.969
G1 X73.2180 Z-17.931
G1 X73.1680 Z-17.88
G1 X73.130 Z-17.82
G1 X73.1070 Z-17.753
G1 X73.0990 Z-17.683

Other then that Z is constantly feeding out.

Edit: Teleportation at ~1:27

Edit 2:
The full fake cut (no entertainment value but kind of Matrix meditation :slight_smile: , need to make the terminal fonts green)
The fake servo Maslow sled challenging the time space continuum.
At: 1:47 / 4:03 / 6:20 / 8:36
GC with terminal and tail on the log.

What bothers me a bit, is that I don’t see errors in either terminal or log indicting the jumps. On an actual system the jumps would hopefully trigger a 'sled can’t keep up. What happens with the knowledge of position?

2 Likes

Well that was boring… sorry, couldn’t help myself! :upside_down_face:

I actually really like watching the G-code getting “sent” to the Maslow. The rendering issues are definitely weird. Maybe we could simply modify to post so that it always gives us values for the X, Y, and Z variables? That might help if for no other reason but to make the rendering in GC better.

I can see the weird behavior you were talking about, it looks like it’s getting really sped up at the bottom of the hole. The odd thing is that GC isn’t saying the velocity is increasing for that portion of the cut. @blurfl, you tested this program on your machine, right? Did you notice any weirdnesses?

We set out to make a cool, low-cost CNC router and may have just discovered teleportation. :smiley: We’ll have to do some more testing before we trying teleporting things we care about (like people).

3 Likes

I didn’t zero in as closely as @Gero, so I missed the trick. I’m on a tiny screen, so can’t really see any unusual movement. Looking at the gcode, is it possible that the helix made of tiny straight cuts finishes with a ‘cleanup’ short series of arcs? See lines beginning at 1185 for instance.

1 Like