Bottom-feed chain settings?


I have built our Maslow frame and sled, but am having trouble with the software portions.

Where is the setting for “bottom feed” chain?

Does using bottom feed chain mean that the automatic chain length measurement is off? I conducted that and then simply attached the “upper” portion of the chain to it’s fixed point. Is that wrong? And will it affect calibration? I think it might, since I told it to center the sled after the chain measurement step, and it centered it horizontally except higher in the workpiece than the vertical center.

I don’t want to attempt calibration until I am sure I set things up properly.

Thanks in advance, I’m sure there will be more questions soon. I’m using GC version 1.10 currently.

EDIT: I do think this is going to be a problem, because when I tell it to move up/down/left/right manually with the GC arrows, it moves the opposite direction from what I tell it. I’m reasonably certain the motors know they are left and right, since I swapped ports after doing the auto chain measurement and manually rotating the “left” motor moved the right.


The good news is that the calibration process will take care of this for you! As you go through the calibration process it will ask you if your chains are in the top or bottom configuration.

Keep in mind that as you are doing the process it will ask you to put your chains on what seems like backwards while the distance between the motors is measured.

If you would like change just that setting manually click on Settings, then click on Maslow Settings and choose Advanced Settings from the drop down


Would it be ok to name that top/bottom chain feed?


Thanks guys! I found that simultaneously to your replies.

Here’s another though: I selected bottom feed. Went through the next couple steps, of zeroing the sprockets with a tooth in the 12 oclock position. I put the first link of the left chain on the 12 oclock as instructed, and the third link of the right chain at 12 oclock.

When I hit tighten to begin taking up tension between the motors to measure their distance… the left motor dumps the chain immediately! I tried putting the first link on the top (as if using a top feed) and went through the process and it gave me a ~ -329mm result. I’m not sure what I’m doing wrong.

Appreciate the help!

EDIT again: I honestly did not know that top settings menu was clickable. I tried clicking the one right below and to the left of it (the greyed out words telling you what submenu you are in) a bunch of times. I assumed top center was just an overall title, but now that you point it out, I see it looks like the other clickable buttons in GC. Thanks! Still have the motor-measurement question though…


You are not the first to run into this, it’s a little confusing. Let me know if you can think of how to word it better.

What you need to do is put the first link of the left chain on the left sprocket, then use the “extend” button to extend the chain until it can be hooked on the right sprocket:


GAH that makes a lotttttt more sense. Stand by, trying THAT. Thank you!


Worked, thanks!

When I’m not busy trying to calibrate I’ll offer some suggestions. I came across another semi-confusing (to me) area, when doing the part to “adjust chains to known length”, I wasn’t sure if I should follow the picture and start the chain over the inner portion of the sprocket, or start it from the outside because I wasn’t sure what the machine wanted. I ended up starting from the inner which was the correct choice.


Hey one more question.

I got through measuring the distance between motors step. On the step where it measures the proper chain amount and then you connect the sled…

The left motor paid out maybe 1/4 of the chain and stopped. The right motor paid out what appeared to be close to 1/2 the chain and stopped. So obviously the sled couldn’t connect, so I manually extended the left chain enough to connect it. The sled is not close to center, it’s about 4" toward the left side.

What would cause the left motor to not pay out the proper amount of chain? Also, is it normal to have the motors sound differently? The right motor has a higher pitched and louder whine, left motor doesn’t.

Just confused, I stopped for the night rather than try to measure the chain out again to see if I got the same result. Is the ideal amount of chain supposed to be 1/2 of it from sled to sprocket and 1/2 slack from spocket when centered?

I would try to run the Actions -> Test Motors/Encoders and check that all of the cables are fully seated. My first guess as to what could cause that is a loose connection somewhere

If you are using the older ‘top feed’ mode, at this point the motor is adjusting
the chain from the length that it was at to reach the other motor, to the length
it needs to be at for the sled to be in the middle, then feeds out enough from
the other motor to make both the chains the same length.

If you are using the new ‘bottom feed’ mode, you should be moving the sprocket
to 12 oclock, reattaching the chains in the new starting point, and then feeding
the same amount from both sides.

Bar - I did that and both motors and the z axis appeared to work fine and no errors popped up.

Dlang - I’m using bottom feed, so yeah after auto-measuring the distance between the two motors with the chain, it had me remove chain completely and re-zero with a 12 o’clock sprocket tooth, and put the chain back on with the first link. I’ll have to try again and see if the same result happens.

1 Like