Calibration: Incorrect home position

I feel like i’m getting close to having my maslow up and running but running into calibration issues! When going through the calibration process i’m not able to get the home position calculated properly. Specifically
right after you complete this step and hit home position:


Here is a picture of the calculated home position (clicked home position after i completed the screen above:

I’m using GroundControl 1.10 (release bar discussed in another thread)


  1. Anyone else run into this issue?
  2. Any advice on resolving my home position issues?
    • I would assume I’m messing up on some measurements prior to this but fairly confident I did them correctly.
  3. Should I not worry about this?

Thanks for taking the time to read my question. Any help is appreciated!

Have you been through the calibration steps where cuts are made to fine-tune the settings? Until that is done, one can wind up with a situation like that.
If you have been through the full calibration, do you remember the measurement you found from the upper right cut to the top of the workarea sheet? That value is used to triangulate the Y distance of the motor shaft centers above the workarea. That value is stored in ‘Settings’ and you can edit it. Measure up from the top of the sheet.
Finally, is the location of the sled the result of ‘Actions/ReturnTCenter’? If not, try that and see if the sled moves down to where you expect it to go. Stand by the red ‘Stop’ button in case the sled heads in an unexpected direction, though :open_mouth:

1 Like

Thanks for the info and quick response blurfl! I didn’t do the cuts because I was worried about the sled positioning. That is exactly where I stopped.

Not 100% sure what you mean by “Measure up from the top of the sheet.” Do you mean from the center of the sled to the top of the plywood sheet?

I’m going to try and do the cuts first thing tomorrow. I think I may still be on the correct path. Really appreciate the help and will follow up with what I find tomorrow!

Reading through another post it looks like someone had a similar problem and adjusted “vertical motor offset variable” to drop the sled down to the center. Could this be the same problem?


It is. Thar measurement is from the top of your plywood sheet to the height of center of the motor shaft. If I remember correctly, the center of the motor shaft is 30mm above the surface the motor mounts on. So if you measure from the top of the plywood to the level of the top beam and add 30mm you will have a good approximation.

When you look at that value in the settings, make a note of it before changing it. The default value is shown, as well. If the present value is very different (much larger) than the default then using the default value would be a reasonable starting point if your frame uses the standard measurements, and making that change will lower the sled when you ‘Return to Center’.

Finally, if the chain length calibration step is executed before the step that does the cuts then the sled position and the uncalibrated vertical motor offset variable don’t matter. The cuts are made by feeding out carefully measured amounts of chain, and followed by a series of calculations using your careful measurements of the distances of those cuts. Pay attention to the instructions, and feel free to bring up any questions or suggestions for clarification of the process.
Good luck, let us know how it goes.

When you enter your vertical distance, make sure you are entering it as mm and not cm. I think mine was 390 mm. you should be something near that.

During the initial steps of calibration, it asks you to measure the distance between the motors and the top of the sheet. That value may be off (too low) and result in the sled being where you have it. Calibration routine is designed to place feed out chain to place the sled in the center of the 4x8 plywood, so if you entered 0 for the distance between the motors and the top of the sheet, it should be about 2-feet down from the motors (half the height of a 4x8 sheet of plywood). If you measured the distance as 39 cm and entered it as such (rather than 390 mm) maslow would would drop it another 15 inches or so…

1 Like

Note: That measurement is a vertical measurement from the top of the cutting area to the center of the motor shaft

1 Like

I would double check that setting before doing the test cuts. @blurfl is right that cutting the test pattern will really dial in the center position, but from the picture it looks like you are pretty far away from the center and I’m worried that test pattern may run off the top of the sheet.

1 Like

Hey guys!
I got everything honed in and got my test cuts completed. I think I messed up some measurements but everything is squared up now.

Now i’m running into issues with generating the gcode for the sled. I’ve tried using maker cam (following the tutorial) and I tried using easel.

When using Makercam I can successfully generate the Gcode but the Object in not cenetered once I load it into GroundControl. It’s loaded way way below the print space. This would be the easiest fix if I knew how to center the object / fix the gcode.

When loading “New Sleg.svg” into Easel I get:

“Due to variations in fonts, Easel does not currently support importing SVG text elements”

Thanks for all your help so far!

Here is my Gcode that is loading in the bottom of GroundControl. Generated with MakerCam. (91.9 KB)


The key to getting your project to show up in the right place is something called the machine’s “home position”.

The home position is set by clicking the “Define Home” button in Ground Control which will set the sled’s current position to be home.

Within MakerCAM the home position is indicated by these two darker lines:

To make your project show up in the right place it’s best to move your designs close to the home position in MakerCAM (or any CAM program you use)

Edit: In makercam you can move your parts around by selecting them all and then clicking and dragging them


Thanks Bar!
I believe clicking “Define Home” fixed my alignment issues. Let the cutting begin!


Thank you all for your help! I’ve successfully cutout my sled!


Woooooooooooooooooooooo congratulations!

Great to hear. Many happy wood chips to you!

1 Like