Machine went silent during calibration

We’ve been thrashing around on the calibration sequence for a few days now. We got through to Step 8 and pressed “Cut Test Pattern.” Nothing happened.

We went back to Step 1 to see if we could turn either sprocket at all. No dice.

We reinstalled the latest Arduino and Ground Control packages and went to restart the calibration sequence with Step 1. We can’t move either the left or right sprocket at all. All other calibration steps are equally unresponsive.

Everything is plugged in. Two green lights are lit on the shield. Amber light is lit on the Arduino.

Suggestions on how to troubleshoot this?

Having both green lights lit on the shield means that the 12V is properly plugged into the shield instead of the Mega, good. In GC, the “Actions -Test Motors/Encoders’ button should wiggle each motor in turn and report ‘Direction 1 pass’ etc. for each motor and direction. Do you find it so?

@blurfl, thanks for the quick response. I tried that previously and got no response. I just tried it again and same thing – nothin. Fwiw, when I go from Ground Control main screen >> Actions >> Test Motors/Encoders it takes me back to the main screen, rather than returning any sort of message – i.e., “Direction 1 pass” – like you indicated I’d see. Hrm…


  • Is the serial port connection proper?
  • Are you using the most recent releases (0.82) of GC and the Firmware?
  • The Arduino program can block the serial port; make sure that is not running. If it was running, you may need to leave GC and start that again.
    If no joy with all that, quit GC and go back into the Arduino program, call up the Serial Monitor and set the baud to 57600. You should see lines flying by like:
    [PEk:-54.25, -47.17,0] etc. etc. etc. You can uncheck Autoscroll at the bottom to help inspect the communication.
    Those lines indicate that the Mega board is alive and sending. Next, at the top of the Serial Monitor, send B05 and watch for a response ‘Firmware Version 0.82’ among the lines. That proves that we can send a command to the Mega and receive the expected response.

A ‘Hail-Mary’ trick, unplug the USB cable…

1 Like

I was able to duplicate this by moving my serial connection to a different USB port. GC posts a ‘Connection Timed Out’ message and the Test Motors/Encoders does nothing. Redoing the serial port selection makes it work again.
I wonder if the problem is the USB connection. Can you try without the USB extension cable, or in a different port of the computer?

I wonder if the problem is the USB connection. Can you try without the USB extension cable, or in a different port of the computer?

USB connections do not have consistant addresses, each time a device is
detected it’s given the next available address. If you unplug and plug the USB
cable, the system still has the old address in use, so it creates a new one.

So checking that you are talking to the address the arduino currently has (and
that you don’t have other software, like the arduino IDE connected to that
port) is the first step you need to do in troubleshooting

That’s right, we’re saying the same thing in different ways :slight_smile:.

Thank you both so much! We got it back up and running. Test pattern cut!!!