Maslow Home Maslow Community Garden Newsletter

Calibration moving one motor wrong direction in Ground Control V1.08

#26

The stop command shouldn’t cause the serial connection to drop. You were right to doThat, but it should have just stopped the machine and then it would wait for the next one command.

There may be a bug out there causing this. 1.09 doesn’t come out until next Wednesday, but my plan is to release it in the forums later today and then spend the whole week testing it to make sure it is rock solid and this is one of the things I will investigate

3 Likes
#27

I’m having the same issue with my right motor feeding incorrectly. What was the final diagnosis?

#28

What version of Ground Control are you on?

We have moved to v1.20 - 1.08 is pretty old if that is what you are using. Have you run the motor test yet?

Thank you

#29

v1.19…run the motor test as in measuring chain length and extending/retracting? Yes I did that. I was falling step by step in GC until I got to the “adjust the chains to a known length” part and started noticed the right hand motor feeding the wrong direction.

#30

The motor test as in open Ground Control -> Actions-> Test motors/encoders.

Thank you

1 Like
#31

Two questions:

  1. Are you doing a top feed where the slack of the chain drops downward toward the ground or a bottom feed where the slack of the chain is taken up horizontally along the top beam.

  2. When you say it’s turning the wrong way, is it turning clockwise or counterclockwise?

I posted a long wiki article regarding calibration. Maybe read through it to make sure everyone is talking the same language.

1 Like
#32

So the end result with me was just that I was expecting the left motor to want to extend after calibration, so I was positioning the left chain back to the top tooth of the sprocket and clicking “extend chain”. However, the extend in this case really means “retract”, because the software is expecting that I’ve left the chain extended all the way to the right motor for the previous measurement. Once I realized that, I’ve been able to calibrate correctly by just remembering that the extend in this case means retract

4 Likes
Calibration moving one motor wrong direction in Ground Control V1.20
#33

The words, at least now, read “Adjust Left Chain” and “Adjust Right Chain”.

3 Likes
#34

I have the same problem. I just built my frame and am calibrating. The left motor fed from the top, as defined in ground control, but the right motor went in the other direction. I can’t figure out what the resolution for this problem was from this post through today. I am running 1.20 with the latest firmware (I just built this today).

#35

Hi marlon61- Have had some very busy days and will be getting back to the project this week hopefully. Similar to your approach, I also installed rev 1.20 (deleted 1.18) and ill give that try as well. I also have had to rebuild some of my frame because it wasn’t high enough above the working area, so that’s another issue i’m contending with.

#36

I got mine working today. There is a bug in 1.20 that is not running the motors correctly when feeding out left and right chain in the calibration setting. I downloaded 1.18 and that fixed my setup problem.

2 Likes
#37

Hi marlon- I installed version 1.18 on for the firmware and Groundcontrol and it still doesn’t work. It is still turning the wrong direction,e.g. both turning the same direction.
Can I just skip this step? I am so frustrated with this entire thing…is there a manual workaround or something to change in the software?

#38

I believe that this bug has been fixed in the latest versions. Are you using top or bottom feed configuration? In top feed the chain will retract automatically when you press adjust. You do not need to remove the left chain from the sprocket. My hunch is that is the issue

3 Likes
#39

I’m having the same issue. Trying the calibration steps and the left motor turns correctly (counter-clockwise) and the right motor doesn’t (also counter-clockwise). I just downloaded (and installed) the Ground Control and Firmware yesterday. I’m on GC 1.24. Not sure on the firmware. Whatever the latest was yesterday.

#40

Could you be seeing the issue with removing the chains mentioned above?

#41

I am having the same issue with the right motor. Is there a work around/patch for this. Thank you!

Going through the test described above, the left chain pays out correctly, but the right motor turns the same direction of the left one, where it should be the opposite, so the right chain just falls off.

#42

Yes, the right sprocket turns the wrong way. Also, I hooked up the sled and everything is backwards, i.e. Up is Down, Left is Right, etc.

#43

Are you set for top feed or bottom feed?

Thank you

#44

Top feed.

#45

I think this is normal. The software is expecting the chain to remain on the left sprocket and so it should be retracting the chain at that point instead of extending it