Calibration: Not centered on work

I have just finished my calibration of my maslow - I was part of the March order. Well…I’ve ran through all of the configuration steps, and it seems that my router is not vertically center. Horizontally it seems okay.

I assume this has to do with the measurement from the center of motor spindles to top of work. I’ve checked over and over again and the number I entered seems to be correct.

I’ve also went as far as clearing eeprom and recalibrating (a few times now)

Any ideas?

Which step are you on when you are seeing this? Is this at the very end of the calibration process?

Well, first - when I finish the calibration and I hit the “finish” button, nothing happens so I have to just close and then it give me the apocalypse warning lol.

The situation I’m referring to is after all calibration. The machine works also. Moves left, moves right, and is perfectly horizontally centered.

It’s just about 2.5 inches off vertically. When GC is set to (x0, y0) - my router bit is at about (x0, y-2.5) based on measurements I’ve made with a pencil in the router.

I still have the temp sled, so maybe this is the issue…it’s possible the ring is not entirely concentric, though I still would expect the margin of error to be less than 2.5 inches. It seems to be something about the measurement from motor spindles to top of work area.

Also, I am running GC on macOS - I am using the triangulation style, chain bottom to sled.

What is the number you are entering?

In the Calibration, make sure you entered mm from the center of the motor to the work area instead of inches.

1 Like

Yes, the number is 444.5mm which is about 17.5 inches. I’ve built the newest ‘standard’ frame. I’ve measured this multiple times. It’s possible I’m off, but not by 2.5 inches unless I’m really that bad at math

What was your measurement for the distance from the top of the work area to cut 5?

I’m not familiar - is there a cutting process in calibration that I did not do? It hasn’t ever popped up for me during calibration. Where is that option located?

When doing the calibration at the end, there are five cuts that are made. four verticals and one horizontal (the horizontal one is in the top right of the board… that’s Cut 5. You are to measure from the top of the work area to the top of that Cut, iirc). If you aren’t reaching this step, then you aren’t getting all the way through the calibration.

With the triangular linkages, there is a place in the calibration that asks you to measure from the cut to the top of the workarea. I don’t think the quadrilateral calibration has that, it asks you to measure from the top of the workarea to the level of the motor shafts. Are you using one of the triangular linkages like the ring?

Yes, I am using the ring - Here is how calibration works for me:

  • Press “Actions>Calibration”
  • Choose wether chains are “off-top” or “off-bottom” (off-bottom)
  • Choose linkage (Triangular)
  • Measure distance from center of motor shafts to top of workpiece (444.5mm)
  • Sprockets at 12 o’clock, measure distance between motors using chain (something like 3002.45mm)
  • “Generating proper calibration procedure for your machine…”
  • This process begins over in a loop. I’ve gone through it multiple times to see if it changed so I end up having to press ‘quit’.
  • Then I press “Measure Chain Lengths - Automatic”
  • Sprockets at 12 o’clock
  • Adjust left chain, it feeds out some known length
  • Adjust right chain, it feeds out some known length
  • Attach sled, click “Move to center”, then “Next”
  • It says "Congratulations you’ve configured your chain lengths and there is the “Finish” button
  • Clicking finish does nothing so I have to click “Quit”
1 Like

Yeah, you’re missing steps in calibration. The “This process begins over in a loop…” part is a problem. There’s steps after that that actually calibrate the machine. So the question is why can you not get beyond this point.

I know that the code is adding the proper calibration steps to the “stack” of steps and it might take a while to do so depending on your computer. How long are you giving it before you hit quit? What version of GC and FW are you using, what OS, and what are the general specs of the computer?

1 Like

I ran through the loops of steps 3 times in a row before calling it quits - because the measuring distance between motors with the chains takes quite some time. I am on version 1.10 of both the firmware and GC on macOS as I mentioned above, and my specs are:

Processor: 1.6 Ghz Intel Core i5
RAM: 8 GB 1600 MHz DDR3
Graphics: Intel HD Graphics 6000 1536 MB

Oh, so the process starts back to step 1 after it says it’s generating the steps you need to take?

Also a quick note to mention that I have run gcode in the machine with a pencil in the router collet with success.

The machine is perfectly in the center on the X axis. It’s just a tad low on the Y

1 Like

That is correct - the process starts back at step 1 after saying it is generating the steps

That sounds like a bug, but so far you are the only person that I am aware of that reported it. I’m not sure what could cause this problem… I’ll tag @bar, maybe he has insight.

1 Like

It should come out horizontally correct because that’s based upon your distance between motors measurement. The vertical calibration (the hard part) are the next steps that for some reason you can’t reach.

Does it seem like it waits 5 seconds after saying that its generating the next steps before it loops back to the beginning? @bar added a change to the code a few days ago that wipes out the calibration stack at the beginning of the calibration process. I don’t think its been released, yet. Have you tried exiting GC and starting the program over?

1 Like

I’d have to run through it again and specifically watch for that to be sure - I’m not positive. I’m taking a look through ground control source right now to see if I can identify the issue. I am a developer, but I’ve never used Python or kivy so following it is taking me a bit lol

edit: This is a response to below, but apparently I have reached my maximum number of replies for today… @madgrizzle

Ah - I can try to compile the latest master branch and see if that fixes my issue. As far as restarting, you mean going through the calibration until I get to the loop, closing the program, and going back into calibration?

1 Like