Calibration Struggles

I’ve had the system for a while, it’s a bit of a mix, comprising of the Arudino Mega and then the Maker Made Z-Axis and sled etc. I completed some basic projects and am getting into some more precise work. I cut a piece about 80mm wide by 25mm high and the y-axis was off by about 8mm and the x axis was off by about 5mm, so I figured I’d start from scratch. Using Ground Control, my first stumbling block is the measurement between the motors. I know it’s 3025mm, but using the chain measurement, it always thinks it’s 10-15mm longer or shorter. The height of the motors is also calculated incorrectly. If I ignore what it says and just accept it, the y-axis seems to be pretty accurate, but the x-axis is 2mm off for every 40mm of travel. I’ve tried using MakerVerse, but no mater what firmware I use, the software won’t move the motors correctly although it sees the Arudino Mega board. I don’t really want to use MakerVerse or Webcontrol as I like the Ground Control look and feel and I don’t like the idea of running a webserver on the CNC system.

I’ve also utilized the calibration method here and it went further awry:

Looking for suggestions. It doesn’t need to be perfect at the edges, but I need close to perfect in the center 4-5ft.

1 Like

The errors on the maslow tend to be curves, not X vs Y errors

the calibration mode you are describing is similar to the holey calibration mode
that webcontrol offers. Try doing the calibration with the points as far apart
as you can make them.

with webcontrol, you are not running a webserver on the CNC itself, you are
running it on a separate computer (just like you run groundcontrol on a separate
system), it just uses a webserver and browser instead of running the GUI

David Lang

So I took another crack at MakerVerse. I was getting stuck at the Z-Axis calibration, so I just skipped that and was able to finish the calibration with 3.5mm of accuracy using edge calibration once. I ran some tests moving 500mm to the left and right and then 200mm up and down as a test, and was within 1mm of tolerance, which seemed like progress. Then I went back to do the Z-Axis calibration again… I’m not getting an error now, but the z-axis refuses to move. I get the motor hum from the XY axis motors, but nothing from the Z-Axis. It works fine in Ground Control… Any thoughts?

1 Like

So found this solution, which worked for me.

The problem is that “z axis Kp Pos” is set to 0 by default. It should be 1300

Going to give MakeVerse a full run through calibration to see how things look now.