Chain length calibration issue

Hello all,
first couple of attemps at calibrating an m2, standard 10’ frame, everything standard as far as I know. I’ve been following @2Tankards calibration videos from youtube. I put in a crosshair dead center as he describes and manually move the sled so that my bit is dead on that crosshair. However, when I get to the chain length step, I disconnect the sled, move the chains up and center them and then back down. When I reconnect the sled the bit is now waaaay off my crosshair - sitting more than an inch above it and 1/2 to the left. It’s the second time through the calibration, same result.

I’m not sure if this is an issue with motor movement or if it’s an issue with my frame, that it’s way out of plumb or square or something? I spent quite a bit of time levelling and shimming and trying to get everything into the same plane. I really don’t understand the makermade easel design in this regard, it seems like a nightmare to try and get that design level and flat and plumb.
am I missing something here?

forgot to mention running Makerverse 1.1.3

You might get a better answer on makermade’s facebook group, but I’ll throw this out:

Mark them both. I’d run the precision calibration from the dot you know is the center and see if you can get a reasonable calibration response from it. If not, then try the spot it puts you at. The pinning-the-chains-together and running the pin up and down never really made sense to me though I also made a video on how to do it. I just drilled a hole at the center point and drove the sled there, reset chains to home there and then calibrated and it worked.

thanks, @Orob . I tried to do just that, tried to just take the center as it believed the center to be and move to the next step, which gave me an accuracy of 25mm which is obviously unacceptable.

Then, on the Edge step, it tried to drive the sled up and over the skirt and off the frame. Luckily I cut the power before it could manage to damage itself. I have no idea why, its a standard 4’x8’ workspace.
Have to say I am an extremely unhappy customer at this moment, but unfortunately I ate a lot of import cost to get this machine so I’ll have to figure it out.

I have restarted the calibration process 7 or 8 times now and I just can’t get anywhere. Seems to start to fall apart at the Measure Chains step, it can’t seem to find it’s way back to center so clearly there is a big discrepancy between where I think the center is and where the machine does. I have spent a ton of time already measuring and shimming and finagling to get it to what I believed was level / plumb but apparently not. I suppose I can take the whole easel / frame apart and start over. If there is another design to the frame/easel I am all for it. Absolutley not sold on this "standard’ one.


Don’t take your frame apart just yet. Revalidate all your measurements are entered correctly. I.e. motor height, motor distance.

If your top beam is centered over your waste board then it’s probably the measurements.

ok, thank you, @TimS . Any idea why the Edge step went so completely off kilter?

If your motor height was off, it could cause this.

Sometimes the maslow does some weird stuff. I had mine go straight up after pushing play to start a cut. And then it would work fine.

Sorry man. This sounds super frustrating. Hang in there. It will work. It just needs you to become one with it and learn how to Maslow Whisper.

For the Due systems, if it doesn’t accept the calibration numbers and it doesn’t know where it is located, it may just go randomly when told to move any of the axis. I’ve seen the sled go straight up when the z axis was told to move. This typically happens with the Due (M2 controllers included) typically the very first time a user tries to move the sled and it won’t stop without intervention like pulling the usb or the power to the motor shield. If I had my choice, I’d pull the shield power. The first thing is to reset chains after firmware upgrade or a controller setting reset (special command that the calibration will issue if you press the button). If you “reset chains” regardless of where you are after that, it shouldn’t wander like that. It is always good to have access to the motor power cord to the controller. I leave my system on for days at a time, but I always pull the motor power when I’m not in the room… (this is a reasonable practice to unplug the motor shield for the Due or the Mega - Just something I have found useful). It might make sense to wire up a switch so in the future I don’t have to reach for it. It makes it so the raspberry pi and the controller still talk, but the motors will not move.

The edge calibration method is simpler in some respects to holey calibration and more precise than triangular calibration, but it really requires everything to be perfectly square and aligned. There might be a couple reasons your measured center and your chain center are off:

  • your beam is off camber and not parallel to the top of your workpiece backing board or offset to the left or the right, so measuring the backing board center doesn’t match with identical lengths from each motor. Have you tape measured from each motor sprocket to the board? You can measure 5’ and 6’ arcs from each motor sprocket… with the chain on and see where they cross, this will allow you to draw a vertical line on the board between the two points. Your sled center should sit on that line. Does it line up with your measured board center? (based on your comments it sounds like these match… and they should)
  • did you account for the last link of the chain? If the last link of the chain does not have a pin in it and you are not using it, when you put out the chain from the motor, did you account for that and when you pinned the chain together, did you use that same roller that holds the sled? Probably you did… I’m just asking. Here’s my video from when I did it.
  • you can also check the box for prerelease software testing and use version 1.1.5 for Makerverse I don’t recall the last update notes, so I don’t know if this was part of the update patch, but 1.1.5 is the latest.

Hopefully some of this is useful. The system has a couple fine points that must be carefully worked through, but once you get it, it will be worth it. Keep at it! Best of luck to you.

thanks very much, very helpful.
I’m definitely planning on putting in an emergency cut off switch - when you say " motor shield" is that the main power into the Due?

I am thinking that my issue is maybe that the spoilboard itself is somehow not centered and not quite square to the beam. My top beam is level and the lower beam is as well but perhaps the spoilboard itself isn’t. It’s a little confusing, I’ve been following 2Tankards videos and he does not have any skirt or anything on the spoilboard. My understanding is that the skirt creates the edges of the workspace. So when you measure motor height, should you be measuring to the edge of the skirt? This would make sense to me because you would never be cutting anything beyond this, but maybe I have it wrong. The edge of the sled certainly passes beyond the edge of the skirt.

As to the chain, I’m not sure I follow completely. I pinned the chains together in the the very last link of the chain - I believe that’s what he does in the video. But it sounds like you are saying to pin together the same links that you use to attach the chain to the roller?

Thanbks a million, truly appreciated.

couple things:

  • motor shield power is the 12V and plugs into the upper board, the shield. The Due (brain) controller is the lower board and is powered from the USB.

  • I think your spoil board is very likely the issue. The assumption is that your spoil border is perfectly straight and absolutely correct for alignment with the motors. it may not be. It will likely not be perfect. Yes, your edge would be the inside edge of the skirt border. Motor height or Y offset or beam height is what you need to be correct and is the plane of the motor from the inside edge of the top of the skirt… shown below it is the top edge of the spoil board for a frame with no skirt. (top left label)
    this comes from the “manual” that we put together to help new users.

  • I mean typically you don’t use the last roller because the pin is missing and nobody wants a pendulum. So pinning the rollers that are used to hold the sled to the ring bearings is what I was referring to, but thinking about it more, if you are off by more than 1/2", it likely isn’t the chain roller used in the centering operation. 1/4" per link off 2 links max is 1/2" if linear, but in the chain triangle, it would be less offset, so that avenue of inquiry is more of a bunny trail off in a random direction. Sorry to waste your time. I think the spoil board or the height measurement may be a more effective solution to fix your problem.

  • one last thing: in the makerverse precision calibration, you can set the target distance that the system will punch the hole from the edge. I’m not sure how you are doing this with the edge calibration, but the sled should stay inside the border for the measurement or the value should be negative that you report… unless I’m totally missing what you are saying. When I built “Fred,” the Due system I had to test this out, I didn’t have a good sheet of ply to use for spoil board (as seen in the video) and ended up using one without a good top border, so I drew one where it should have been and measured from that. If your motors are level and the beam is on right, you might use them as reference and draw your work area out and see if it matches up with how it is placed. This is not likely going to be painless, so just an idea.

Thank you, this is very useful.
My current issue is that the Edge calibration step is totally bananas.
At top center, it pulled the sled 95 mm above the edge of the workspace.
At top right, it was 56mm above and 36mm short of the edge.
When I moved it to the top left, I had to pull the plug in the position you see in the photos, because it was still going and would have damaged the machine.
Makerverse did the exact same thing to me yesterday. Whatever small imperfections I may have in my frame, they cannot possibly account for this. I have remeasured everything and double checked the measurements that I have entered. I just think Makerverse is absolutely out of it’s mind.
Earlier when I told it to go to center for a previous step in the Chains tab, it sent the sled to maybe 10mm off the bottom edge and 10mm to the left. Just crazy numbers. So I uninstalled and reinstalled but here we are.
Extremely, extremely frustrated because I can’t get past this step not because of my mistakes but because the software is ridiculous. Is there a workaround?
Thanks much for your time.

Check to see if you have the numbers in the wrong spots. Maybe the work area dimensions are flipped so it thinks you are vertical with your ply and not horizontal or some other misplaced numbers?

Is it set up with Due and not Mega with the correct firmware?

I’m not to keen with Makerverse, so I’m running out of ideas fast. @MakerMadeCNC can you help?

Thanks @TimS , i thought of that. and i double checked. it seems if i had done it backwards, it would actually have driven the sled much , much further on the top center step to try and find the edge. and on the top corners it would have had no reason to go nearly so far. at least, that what it seems to me.

i keep thinking of some place where i could have entered a number wrong or added / missed a zero and i can’t find anything. i am very hopeful that @MakerMadeCNC has something useful to say because as it is i have a useless machine

Are there default settings in Makerverse? If you built a default frame, maybe try to switch all to default settings and run it.

What’s your chain pitch, chain length, and gear teeth Settings? If these are off it could cause it to move too much.

Thanks @TimS
There are default settings and every time I try to run the calibration, I wipe whatever is there and restore defaults. This includes standard chain length. If there is a setting for gear pitch or chain pitch I wouldn’t know where that is and I don’t think it’s something you can change because they all use the same type of chain, same sprocket , etc. Even so they would have to be absurdly off to create what I am getting.

@Orob for these chain arcs, are you saying just pay out enough chain that you can measure out 5’ or 6’ from the center of the sprocket to the last link of the chain, put a pencil tip in the last link and draw an arc, then repeat on the other side? Just clarifying. Willing to try anything here.

for the arcs, I was thinking use a string from the motor and draw on your board with a pencil just so you have a visual reference of where center should be.

your sled is waaay out of range there:

I’ve labelled where I would measure from the top of the board to the motor plane for the measurement.

Can you send your numbers? What measurements are you getting for each position last time you ran it? I might be able to measure from your photo if you can share your sled diameter. I usually write these on the spoil board with a sharpie marker so I don’t forget…

Clearly out of range, this photo is illustrating where Makerverse keeps trying to drive the sled during Edge calibration. This is where I pulled the power.

My motor height is 475 mm measuring the way 2Tankards says.
Motor width is 3026.
Standard 4’x8’ setup.

The sled is a standard sled which I think is 18"
I am unable to complete Edge calibration so I don’t have any numbers to report there but it was way off in the first two spots, 90+mm above the edge of the skirt.

I did the arcs more or less as you describe, it gave me a good center on the vertical axis.

how does the pencil line match up with your measured center of the spoil board?

it was good, within 1mm