Maslow Home Maslow Community Garden Newsletter

Cant get past set chain error


#1

Hi

I moved pc and then reconnected. I opened ground control and the full 2440 by 1220 came up . i thought this odd cause I am working with 48 by 48.
The sled was not on center when I unplugged pc. Now I get the set chain length error. here is what i have tried:

  1. shut down all and restarted, include unplug arduino.
  2. tried different parameters all including 1219.2 1220, 2440, all variations.
  3. re uploaded version (holey version) firmware .
    4 tried other ground controls, the holey, the standard.
  4. wiped eeprom
  5. reset chains and immediately get error message.

I re read the message about lost sled position and tried all.
At one point the ground control after hitting stop to reset just goes dead.

I have tried all i know and still can not get running.

Please help,

JR
ps i am under on chain triangular and using the holey ground and firm.


#2

Hi Jimr,
When you need help like that, there are some valuable information you can share:

  1. What is the set of events between the last time it worked, and the first time you noted it was not working anymore? Can you see something more than just moving a pc from one place to another?
  2. can you set one ground control macro button to $$ then activate it to get the Firmware list the settings?
  3. Then get and share the log.txt file of GroundControl.

#3

pls tell me how the macro is set and where log file resides.

i was running great, did the 6 hole config and sled centered and went right to top of board. cuttting fine. using 1220, 1220 parameters. I shut down pc. disconnected. I left the sled in a down left corner position.

I started ground control again. this time it opened with the full sheet parameter and zero in center while sled was stil bottom left corner.


#4

The log.txt file lies in the GroundControl folder on my Linux version.
Hopefully the same for windows.

About Macros:
Open Maslow Settings and locate “Macro 1” and click on it to edit it.
Type in: $$
then close
close the settings panel

then when you click on the upper right corner “Macro 1” button, Croundcontrol will send the $$ command to the Arduino.

This will make the firmware send the list of EEPROM settings to Ground Control and dumped to log.txt


#5

gotit


#6

@Jimr, is this the same problem you were having earlier, when you couldn’t set the 12 O’Clock position?

Here is another question. Before you started having problems, could you hear a difference between the two motors? It would be like one ran consistently, whereas the other one galloped, sounded quieter/louder as it spun.


#7

I put new gear in left.not on rite. All gud till I moved pc and moved back. I got running today but optimized, holey, config, would not go to top again.
U suggest I put steel gear I rite?

What I mean is the holey optimization had me.to top o board. Now after the stoppage I’m back to low center and no move to center top of board.

I did move ini. But put holey numbers in. To get to center I had to change vertical distance to 350 from 398.2. real vert is 430.


#8

Joshua,
can u please run the calibration for me? I cant seem to run it here.

  1. 39 3/16

2 39 1/8

  1. 39 5/16

  2. 39 7/8

  3. 27 1/16

  4. 26 1/8

  5. 27

  6. 46 5/8

  7. 47 7/8

  8. 47 13/16

  9. 46 5/8

  10. 12 1/4

current settings:

triangle

feed is under

vertical offset 360 (actual offset is 444.5, im trying to center up.

distance between motors 3027.9

sled weight is 22.2

i set chain tolerances to zero for this new maslow.

Thank you, JR


#9

Just checking. Is this the setting that was in GC and the FW when the cut was ran?


#10

yes it was, i got the final sled cut with maslow, however, after calibration the sled was 8 inches to low of center. so I went back to an old config on my other maslow to get sled higher