Maslow Home Maslow Community Garden Newsletter

Carbide Create z axis setup

Hello-

Brand new to Maslow. I was able to cut my permanent sled, but now that I’m trying to cut my first project I’m not able to set up the z-axis properly. I designed my piece in solid edge and then used carbide create to create the g-code. Carbide forces me to use a positive value for max depth and I set 0 as both the top and bottom of the stock. In both cases, the sled moved to the starting point with the bit just above the stock, but then it raised up to around 15mm. I tried to follow the advice in this tutorialhttps://forums.maslowcnc.com/t/coreldraw-carbide-create-basic-workflow-png-gcode/15006 but I can’t figure out why the z-axis is so far off.

Did you review the Carbide Create video tutorials?

Hi I watched a couple on youtube, but I couldn’t find anything maslow specific. Is there a series you recommend?

Fwiw, I didn’t find this anywhere, but I switched the machine in the setup from one of the shapeokos to the Nomad 883, and that seems to have fixed my problem.

The official videos are here.

Carbide3D recently said the only thing machine selection changes is the size of the first workpiece (after that it remembers what you last set), although before they started using postprocessors it supposedly also made some gcode header changes. Did you set the size of your stock large and thick enough to include your work?

Yes, I was able to set the size and thickness of my workspace/stock. For whatever reason, changing the machine selection changes the direction of motion for the z axis. That was the only thing I changed, and it solved my problem.

Sometimes my Z axis randomly “looses calibration”. I’ve found every time that checking the z axis cable and seating it securely (Either at the router connection, or motor shield connection) fixes the problem.

the build instructions encourage you to zip tie the cable to the motor as strain relief, so the plug isn’t supporting the cable weight. Have you tried that?

Yes indeed, but sometimes it loosens on the other end at the motor shield. And that is in a printed box.

The side plug board looks like a good idea but I think it is more prone to separation. Can you sink a screw nearby and ziptie the cable to it such that it presses into the plug all the time?

Mine wiggled out inside my box too so I used some compressable foam above it so that the lid of the box wedges it down and it has no way to wiggle out now :slight_smile:

You are talking about the boards separating inside the enclosure?

Nope, the long wire going to the Z-axis motor from the top board (motor driver board), detaching from the socket on the motor-driver board PCB.

tack down the wire to the frame near the controller board so it won’t pull loose as it moves.

1 Like

Agreed :slight_smile: I’ve done that too. It’s just that I’m a fiddler. Always in and out of the case fiddling with things and manage to knock the wire inside the case and knock the plug half out - all just part of a DIY machine! So double-securing the connectors in all locations has become a necessity.

1 Like

I had a similar problem with the z axis. I found that when you start a new project the software will often set the zero point at the bottom of the workpiece instead of the top. If you have a project unselected and go to design, you should see the gear setup icon. It has the global settings for the software. Make sure the zero point is set to top. I would not use 0 for top and bottom because the tool would have no depth to plunge to.

1 Like

Set z zero on top of the workpiece in setup, I’ve been using CC on a 3018 for a couple years and never had it move any origin requests. What version are you using,the current version is in the 530s? CC is in another major update cycle, darned good image tracing and layers have been recently added, along with pocketing and retract improvements that I have yet to try, distracted by diode lasering lately.