Closed: [Beta] Makerverse (previously known as "CNCjs") Support for **All Maslow Editions** w/ Non-Destructive Edge Calibration

Absolutely. I’m working on the “real” instructions now for Calibration (i.e., in-app).

That’s exactly what I’m working on now. This “Beta” release is, intentionally, rough around those edges so I can suss out problems.

I made zero changes to the Mega firmware. Holey v51.28 is not even the latest. I only updated the Due firmware. All the translation happens at the software (Makerverse backend) side.

1 Like

Since you already have Holey firmware on a Classic, all you need is to install Makerverse. The instructions are in the README of the github repo. tl;dr it should be something like this:

git clone
cd makerverse
npm run

That’ll get the software up and running on port 8000 on your Raspberry Pi. Then follow my instructions re: .cncrc and calibration.

1 Like

Let’s work together on this. This is evolving quickly, and like @Madgrizzle said I want the on-boarding experience to be in-app as much as possible.

1 Like

Thanks for this, I’ll give it a try tonight and see how far I can get.

“evolving quickly” is an understatement. You singlehandedly deprecated webontrol and groundcontrol and created a virtual holey calibration in one swoop. I don’t know I can use enough cliche phrases to proclaim how transformative this will be. I look forward to participating in this new direction. There is a lot here: where to start…


Speaking of which… Calibration UI is now 1000x better. I’ve updated the original post with screenshots, as well as some answers that were asked in this thread. About to merge this into master now.

I’ll be out of town for ~48 hours, but I’m excited to hear how it goes for everybody.

1 Like

Is it reasonable to think I could run this beta on the same RPi as WebControl and jump back and forth between the two? Since they run on separate ports, I’m guessing so but I don’t know if the Arduino will get confused with different controllers talking to it at the same time.

Only one process can open the USB serial port at a time(I think) so I think it will be one or the other, but both can coexist on the same rasperry pi but not run at the same time. I just finished installation of makerverse and npm failed installation a couple times. After successful install, it wouldn’t start because webcontrol was running. I’ll get back to it again later today.

@zaneclaes:. I was just about to add the z axis auto zero plate on webcontrol, so I want that, rpi buttons for start pause stop and shutdown so a pendant and local text display like I have set up on webcontrol. All existing features in the previous software that would be used with makerverse. I’m wondering if these buttons should be rpi level or controller / firmware level instead and wire to the Arduino?

Yes, I did that for a while while developing. Just be aware that both cannot have the same port open at the same time, so disconnect one before connecting the other.

FYI, the app already has “commands.” I defined custom commands for things like restarting the server, turning on the shopvac, etc. It also has “events.” This lets me automatically turn things on and off, for example.

This will probably require another firmware upgrade on the Due. But the classic obviously supports it, and there’s already a “probe” widget. I’ll work on making it compatible with both Maslow versions soon, since I definitely want this.

Screen Shot 2020-08-20 at 10.58.22 AM


You are a rockstar.

1 Like

Nothing node related ever works for me.

I don’t think the Readme is super helpful. If I follow it to the letter, I can get cncjs running, but not makerverse as this npm install -g cncjs pulls from the published modules.

I found this page on the cncjs wiki, which suggests a means to install from source.

But every time I try and run makerverse I get the following error:

    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:965:15)
    at Function.Module._load (internal/modules/cjs/loader.js:841:27)
    at Module.require (internal/modules/cjs/loader.js:1025:19)
    at require (internal/modules/cjs/helpers.js:72:18)
    at Object.<anonymous> (/home/krkeegan/projects/makerverse/bin/makerverse:7:7)
    at Module._compile (internal/modules/cjs/loader.js:1137:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1157:10)
    at Module.load (internal/modules/cjs/loader.js:985:32)
    at Function.Module._load (internal/modules/cjs/loader.js:878:14)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:71:12) {
  requireStack: [ '/home/krkeegan/projects/makerverse/bin/makerverse' ]

I also tried npm run since that is recommended a few times, and that doesn’t seem to be a complete command for me. npm run start gets me the same error as above.

This is similar to what I saw but I got a version warning that 10.22 was super old. On the rpi, apt-get install nodejs gets version 10.22 and the current version is 14.x so I was going down that trail first. I uninstalled and I’m trying to reinstall nodejs (correction. command was “sudo apt-get install npm”), but it looks like there are some dependencies missing. Good call trying the cncjs version… did you edit the .cncrc file yet?

I did:

npm start

I have been using the node version manager. I can try 14, I think I am at 12 now. Yeah I did the cncrc file. Where you able to get it to run?

no. nodejs or npm auto install version 10.21 and I need a newer version to proceed.

Tried to install it on Ubuntu, also no luck. Have the RPi ready, but hesitant.

node --version
npm --version
Ubuntu 18.04.5 LTS bionic

The ‘/home/username/Maslow/makerverse/npm-debug.log’ is not written

hmm, you can follow the instructions for installing nvm (node version manager) and get all the way up to at least 14 for Node on the raspberry pi.

I am trying 14 now, I will let you know if I have any luck. This is a blank pi with a fresh install of raspberrypi os. Even if I can get this to work, I am tempted to dump and reinstall as I have a ton of cached and other node files piling up.

>sudo curl -sL | sudo -E bash -
>sudo apt-get install nodejs

that got it up to speed. now to get makerverse to run

pi@Maslow-G:~/mv1 $ npm start

makerverse@1.1.0 start /home/pi/mv1
throw err;
Error: Cannot find module ‘@babel/polyfill’
Require stack:

  • /home/pi/mv1/bin/makerverse
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:1080:15)
    at Function.Module._load (internal/modules/cjs/loader.js:923:27)
    at Module.require (internal/modules/cjs/loader.js:1140:19)
    at require (internal/modules/cjs/helpers.js:75:18)
    at Object. (/home/pi/mv1/bin/makerverse:3:1)
    at Module._compile (internal/modules/cjs/loader.js:1251:30)
    at Object.Module._extensions…js (internal/modules/cjs/loader.js:1272:10)
    at Module.load (internal/modules/cjs/loader.js:1100:32)
    at Function.Module._load (internal/modules/cjs/loader.js:962:14)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:72:12) {
    code: ‘MODULE_NOT_FOUND’,
    requireStack: [ ‘/home/pi/mv1/bin/makerverse’ ]
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! makerverse@1.1.0 start: ./bin/makerverse
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the makerverse@1.1.0 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
    npm WARN Local package.json exists, but node_modules missing, did you mean to install?
    npm ERR! A complete log of this run can be found in:
    npm ERR! /home/pi/.npm/_logs/2020-08-20T21_25_56_497Z-debug.log

let me guess: it is a path issue.?

I have been running npm install first. After that I get a different error Error: Cannot find module '../dist/makerverse/server-cli'

I am seeing some errors on install that suggest that a serialport bindings module can’t be compiled for ARM on the raspberrypi??

I dunno, I have wasted 2-3 hours on this today and have reached my frustration point with node, which I seem to be predisposed to. So I am calling it quits.

If anyone gets it working I would appreciate a list of commands and what environment you are in.

I’m reading the cncjs readme on github… it’s a book about a spanish guy named Manual. I highly recommend it.

EDIT: after installing node 14x, I did the install and it failed and I got the I went back to nvm and installed it as directed in the readme with it using version 10 and I did the install again and it it gave warnings, but it appears to have finished. then tried editing the file and still get the

Error: Cannot find module ‘…/dist/makerverse/server-cli’

>npm clean
Usage: npm

the command is

>npm clean-install

but it does not work:

npm start

makerverse@1.1.0 start /home/pi/mv1

throw err;

Error: Cannot find module ‘…/dist/makerverse/server-cli’
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
at Function.Module._load (internal/modules/cjs/loader.js:562:25)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object. (/home/pi/mv1/bin/makerverse:7:7)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)

i liked webcontrol because it was python and I had way more experience with that. I’m not sure where to go from here at the moment.