Closed: [Beta] Makerverse (previously known as "CNCjs") Support for **All Maslow Editions** w/ Non-Destructive Edge Calibration

Try running NPM Clean before npm install.

1 Like

Removed to avoid confusion.

3 Likes

Done part one, was about to give up and go to bed. Now i’m trying again :joy:

1 Like

OK, sad update. I can’t select my port once I am up and running. I can connect to the serial port from the command line, so that works. But nothing in the Makerverse App.

1 Like

OK, editing the .cncrc file to have my correct port and baud rate at least allows me to connect under the My CNC section of the app.

image

Note, I had to open the port. and then in the console I typed Ctrl-X to cause it to trigger the device detection. Pressing reset on the Arduino Due would probably also do it.

1 Like

I followed until npm run clean on my own. skipped that part and still get the same error. I found the build command and tried to run clean, but no go. I’m going to start all over again.

EDIT. krkeegan’s instructions above work
npm run start

> makerverse@1.1.0 start /home/pi/makerverse
> ./bin/makerverse

2020-08-21T01:07:59.877Z - info init Loading configuration from “/home/pi/.cncrc”
2020-08-21T01:08:00.993Z - info init Starting the server at http://127.0.1.1:8000

Since we have been tinkering so much, I blew away the makerverse directory too and recloned it just to be sure. I am not sure how important npm run clean is but it was part of the steps that cncjs used so I used it as well (I did skip all of their linter checks and unit tests and that seems to be fine).

1 Like

@zaneclaes This is pretty cool and very impressive how far along you are. It seems like the Add a Workspace screen that the App loads initially maybe isn’t working or isn’t quite ready yet?

Otherwise, the rest of it looks like a great start. I will do my best to try and learn how all of this works so that I can contribute, but as demonstrated above I have a genetic allergy to node and javascript.

One Calibration Concern
I love how simple this is. But I am a little worried that if a user is off by even a 1/8 inch when initially setting their home position, that this error will be carried through the calibration process as the two chains will not be identical in length. This will mostly cause errors in the ChainSag calculation. I can run some numbers on this to figure out how much of an error this would be if people don’t agree with the concern.
I see two solutions:

  1. Dole out the chains like we did before (not ideal, this is a slow and boring process, but is very accurate and once set, can be reset by marking the chains).
  2. Attempt to calculate the chain lengths in the holey calibration step. (this would add some uncertainty to the other calibrated numbers and may make them less accurate, but it would likely produce better final results than ignoring the uneven chains.)

Feature Request
Not now, but in the future, I would like the ability to do a Holey-like calibration with a user defined list of points. I think with some time and a good tape measure I could locate 12 points on the work surface and further refine the calibration. Maybe this is overkill. Certainly not a priority.

1 Like

I have enjoyed 1. 7. 10. 12. and half a bottle later I am here.


Although the port selection clicking on the “House” button shows no ports to select, this looks like it would actually run. Am I good to put this RPi in the workshop?

2 Likes

I guess soda and carrots aren’t the same because I am still here:


why makerverse and not maslowverse? Google makerverse and a robotic software simulator comes up.

1 Like

Forget the house button, I have no ports to select there as well. Try [Beta] CNCjs (Makerverse) Support for **All Maslow Editions** w/ Non-Destructive Edge Calibration
It did work for me.
Edit:

“port”: “/dev/ttyACM0”,
“baudRate”: 57600,

for a arduino mega in the .cncrc that you place in the {user folder}.

Edit2: Just saw from the pic you are missing that ‘middle’ button that is labelled " My CNC Machine:"

It is worth noting that this is currently in Alpha and will require some additional work before cutting a production build. @zaneclaes has done a ton of amazing work and wanted to get it in front of the community for feedback. In the future, the software will be delivered in a much easier to install deb packages for the Pi and app store releases on Mac and Windows.

@Orob Maslowverse would definitely be a cool name, but Maker Made does not own that branding. We have just picked up where @bar left off when he stopped making the kits himself. Plus, the application has the ability to control many other CNC machines that are not Maslows. The idea is to create a single application that one can use to control as many pieces of computer aided machinery as possible.

1 Like

You need to copy the ‘.cncrc’ file from the forest post. Edit it to have the correct port and baud. Then reload, and in the left side there should be a My CNC Machine tab that you can click on.

thanks everybody for the help. the issue was not the contents of the .cncrc file, but its location:


Once it was copied up a folder, it loaded.

@MakerMadeCNC - > makerverse is a good name for it. we need to get google on board with finding it now.

I was running a development version of firmware and it picked up on it, so that is good. EDIT: The latest holey firmware is 51.28 from github. in my laziness, I cloned the repo on my windows machine, pressed the verify checkbox in arduino ide, found the hex file, renamed it to holey-51.28.hex, copied it to the raspberry pi webcontrol/firmware/holey folder and then pressed the actions->upgrade button so it flashed it for me and I didn’t have to go get the arduino out of the controller and connect it to my laptop. For me, I don’t think webcontrol will ever really go away and i’m ok with that.

FYI: I feel it is my duty to do everything wrong to see how robust the process is.

2 Likes

While that is true, why not leave it as cncjs then? There are still many calls within for cncjs that will all need to change.

We have additional features we are implementing that are not part of the CNCjs roadmap. Also, because we are pushing to app stores we have to replace all of the CNCjs registered certificates with our own certs that are registered to our deployment accounts.

I think the plan will eventually be to publish widgets for those that want to continue using CNCjs and maintain Makerverse with the expanded features and machine support that is not on the CNCjs roadmap or development strategy.

if exact measurements are needed will supplying class 1 tape measures with each kit be a good idea? They are $2 if you buy 1000 at a time. by the time taxes and shipping fees are paid still only $4. I dont’ really want to have that many tape measures in inventory, maybe the other kit sellers want to split an order?

1 Like

Wow, sorry so many had troubles installing! I just got back to town. I thought the readme covered all the nvm installation stuff well enough but perhaps not… looks like y’all figured it out though.

Yep. I fixed it a while back and it’s built by the CI. Works on amd64 and arm64 and armv7. Pull from skilescm/Makerverse:latest

quick question. I’ve read about jogging and having things go nuts. Does this occur with the mega setup? right now, the system says it has a position, so I assume it knows where home is.

Node 14 won’t work. IIRC from the README, 12 and 10 are supported (I use 12).

There are a lot of redundant (and unused) steps in there. I just tested this on a fresh Raspberry Pi install and had it up and running in ~20 minutes:

curl -sL https://deb.nodesource.com/setup_12.x | sudo bash -
sudo apt-get install -y nodejs
git clone https://github.com/makermadecnc/makerverse.git
cd makerverse
npm install
npm run dev

That said, this node app (CNCjs) had some pretty bad practices. It’s not NodeJS’s fault; the original CNCjs sadly had a poorly architected project file (it was a major pain while developing, because it doesn’t even support hot reloading).

Sorry if that was not clear. This is why I harped on “make sure to edit the cncrc” file several times in the thread, but I really should have made that more explicit :slight_smile: Please see my note at the end of this post.

I think that’s a great idea. Calibration becomes way easier!

I’ve not seen it happen with my Mega. However, the fact that it “has a position” is not sufficient. If you freshly flash a Due with the new firmware, it can happen.

@Orob @krkeegan the idea right now is that when you use the “New Workspace”, it will set up the workspace for you and send you into calibration / onboarding right away. This way, nothing gets missed :slight_smile: I’m starting on that now…

1 Like