Connection problem with z axis motor

Hi, I just constructed the temp frame for the Maslow cnc. It’s taken me a while to build it because of space to build it and time I had to put into it.

It works great I am very happy with it. But the z axis does not move, I turned on the setting in ground control using the .87 version of firmware and ground control plus I have it plugged into port 2.

I feel that the motor is not getting current, so I don’t know if the problem is the motor, wire, or control board. I have made successful cuts manually moving the z axis.

I am running .87 ground control and firmware

Bar suggested I run a motor test and it worked. So every thing works. But still won’t move or make noise like it’s trying to move when trying to move z axis in ground control. Which makes me think it’s software, or a setting I’m not turning on. I did turn it on in the settings of ground control.

I’ll try to update the firmware and ground control.

1 Like

So you see the z motor turn when doing the motor test, but no movement when using the z-axis pop-up to run it out or in?

Blurfl, yes

I have updated the firmware and ground control from .87 to .88 that did the trick. I can now move z axis with ground control. Next step is to use the z axis in a cut.

Thank you every one for your advise.


Do I need to recalibrate machine dimension after updating ground control and firmware?

not always, but in this case, probably.

If you mark the chain links where they should be when calibrated, you can do a
manual calibration and put in the proper numbers. This is significantly faster
to do.

If your sled moves to the correct location when you use the Action/Return-to-Center, you’re probably OK as is. Painting those ‘king links’ is a real timesaver, though :smile:

1 Like