Crazy Maybe Stupid Issue

Ok, so I’m trying to set up my machine and I’ve gotten to the step where I install Ground Control. Everything seems to be working fine until I actually launch the program. My computer goes through all the motions of opening an application but the icon doesn’t show up in the dock and the program doesn’t actually launch. My details are as follows:
OSX 10.8.5
2.6ghz intel i7
8GB of Ram
Trying to run GC 1.00, (also tried GC.99, same result)

Can anyone tell me what I’m doing wrong? Is my system too old? Am I drinking the wrong beer? (Great South Bay, Blonde Ambition)

Thanks for any help you can lend.


It’s not the beer, at znyb rate :smile:!
Are you using the .dmg version? If so, did you run the ‘MakeSymlinks’ after copying the groundconbtrol app to the Applications folder (right-click, ‘Open’, answer ‘yes’…)?

I’m on the road. Let me take a look when I get home. Have another beer. Then I’ll report back.

Where are you located?

Thank you

I am using the .dmg version. When I run the MakeSymlinks, i get a window with this-

2017-12-30 17:25:17.085 osascript[709:707] Error loading /Library/ScriptingAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QXPScriptingAdditions: dlopen(/Library/ScriptingAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QXPScriptingAdditions, 262): no suitable image found. Did find:
/Library/ScriptingAdditions/QXPScriptingAdditions.osax/Contents/MacOS/QXPScriptingAdditions: no matching architecture in universal wrapper
osascript: OpenScripting.framework - scripting addition “/Library/ScriptingAdditions/QXPScriptingAdditions.osax” declares no loadable handlers.
0:20: syntax error: A identifier can’t go after this identifier. (-2740)

I’m located in New York. Long Island to be more specific. Oh I’ll have another beer… ya know if I must.

It looks like Kivy isn’t supported on OSX 10.8; they require 10.9 :neutral_face:. What are your options?

OK my oldest desktop is on 10.9. I have some mac minis in storage that are older I think. I suspect your video drivers and Kivy are playing well with each other. Obvious question have you run all the updates on the mac? Can you provide me with the model number under apple menu about this mac? Do you have access to another PC in the mean time.

For Windows I have a page for 1.00 portable here:

Thank you

Sorry I just got to send my reply it actually was sent 2 hours ago but apparently failed.

I will test as soon as I can.

Thank you

Here is an option -

You could use bootcamp to run Windows 10.

See the information in the wiki on Windows.

I was hoping you were in Southern California as I transversed a lot of it yesterday an would have loaned you a Pi.

Oh, and if you use Bootcamp to set up Windows you will need a few beers.

Thank you

Is Virtualbox available for Mac? Then you could also run an ubuntu flavour

Thanks for all the suggestions. I’ve battled with boot camp and parallels in the past. The both suffer from the same fatal flaw, Windows. I’ve got an iMac that I can update and use. I’m hesitant to update my laptop because I run a lot of odd/ old applications and plug ins for work and in my experience the updates don’t always play well them. If the old iMac doesn’t work I will begrudgingly update my OS.


I use Bootcamp when I have to. I don’t use parallels anymore. There are ways running Parallels running a Bootcamp image can corrupt the Bootcamp partition. Also it is supposed to make things easier but often launched a file it thought was Windows taking resources and focus from a program doing real work.

You are correct on the updating issue - If you have a application running productively in a specific OS, don’t update but replace. This is why I have hardware going back to 10.2 I can test on.

I’m glad you have a solution.

Thank you