Ground Control Won't Run on Mac Mini

I was planning on using an old Mac Mini as a dedicated Maslow Machine to save my Macbook pro all the dust in the shop.

When I launch GroundControl, a python icon breifly shows up in the dock, dissappears, and then nothing. I’ve tried the “Make Symlinks” option, installed Homebrew and Python in terminal, and… nothing.

Any troubleshooting steps I should try?

I did upgrade the computer with more RAM and an SSD. I could have sworn I had Ground Control 1.00 running successfully on it before I did the upgrade (just once to test it out).

Video of behavior:

What version of the Mac OS are you on? What model of Mac Mini . - Apple menu, about this Mac?

Thank you

Bee- I’m on the latest version of MacOS (10.13.2). It’s a Mac Mini 5,1.

I have a Mac Mini 2012 (same MacOS), but no time tonight. If by tomorrow this is not solved, I will go through the steps and see what happens on mine.
Edit: could not wait and stole a few minutes. Downloaded the .dmg from github groundcontrol1.02.dmg, clicked it.
A window opened from where I pulled GrounControl to “Aplications”. Trying to open it resulted in a message that it is not trusted. Went to “setting” and clicked under “privacy” -> open it any way and there it is. Only one message from GC that no .nc file is loaded, but it seem well and alive. Not connected a to it yet though.

1 Like

Thanks @Gero and @Bee!

For the record, this is a fresh install of MacOS, so almost no other software installed.

Blunt question, do people get notified if a post is edited? See the edit if not :slight_smile:

Hi Gero, I checked out your edit! I did get the “not trusted” message at first, and took the same steps you did to approve GC. On my machine, No GC though :confused:

1 Like

That sad, thought is worth a try. I did not do the symlinks and have a couple of thing installed since 2012. The geeks will hopefully come up witj some questions how to compare a running vs. non running system :pensive:

1 Like

@Gero, had you been through the OSX setup steps on the GroundControl instruction page previously on the Mac Mini?

I believe the problem is Gatekeeper it is a “security feature”. As things go forward apple is getting more aggressive about software from outside their apps store. In Sierra there was a setting allowing you to set “allow” telling the OS you know what you are doing. This was taken away in High Sierra. If an app is blocked you can go to the security settings in preferences and there is an option to run it. This is a pain as each time you will have 3 steps to launch a program.

I’m adding a tutorial from Sierra - I remember I used a CLI command to fix it, but the was the 2nd day High Sierra came out. I did some derivative of the tutorial with some google search.

Let me know if this resolves the problem.

Thank you

1 Like

Sadly, this had no effect on the issue. I still get that Python dock icon that appears briefly and then disappears, and then… nothing.

Try this -

Create a new user on the mac and install GC after log in in as the new user, make sure they are an administrative user.

Thank you

1 Like

@blurfl Yesterday night I downloaded and installed and started GC (total 7 minutes). I followed this page GroundControl/wiki/Mac. The security complaint is missing in the wiki.

1 Like

Wait, so the issue happens also when running the program from the source? What happens after you launch Ground Control from the terminal? Are there no warnings that appear?

I haven’t been able to install it from source either, it seems. Following the steps at, when I get to step 3 for installing Cython, I get the error message:

-bash: pip: command not found

I think I ran into that issue too

This post recommends the command sudo easy_install pip

Does that work?

1 Like

Yes! That seems to have done something! I then moved on to try step 3 again (cython) and got these errors:

1 Like


what if you do sudo pip install...

The “sudo” at the front stands for “super user do” which will give your command more permissions

Yes! On to installing Kivy. I went ahead and used sudo USE_OSX_FRAMEWORKS=0 pip install kivy, and it got all the way to the end and then said:

1 Like