Maslow Home Maslow Community Garden Newsletter

Cutting G-Code Issue

I don’t know what I’m doing wrong. I have this loaded. It looks correct in ground control. I hit go, it runs the first few lines, ignores some “not supported” stuff, and then doesn’t do anything. Here’s a snippit and the full file is attached below.

I should say, I’ve tried a number of files. They all do this.

It runs fine, but when it gets to the first G1 line, it stops and doesn’t do anything. Help!!

(Exported by FreeCAD)
(Post Processor: linuxcnc_post)
(Output Time:2020-04-24 11:38:53.790255)
(begin preamble)
G17 G54 G40 G49 G80 G90
G20
(begin operation: T1: 1/4" Upcut)
(machine: not set, in/min)
(T1: 1/4" Upcut)
M6 T1
M3 S0
(finish operation: T1: 1/4" Upcut)
(begin operation: MillFace)
(machine: not set, in/min)
(MillFace)
G0 Z0.2500
G0 X-0.1250 Y28.0000
G1 X-0.1250 Y28.0000 Z-0.1250
G1 X-9.8127 Y28.0000 Z-0.1250
G1 X-9.7973 Y27.8750 Z-0.1250
G1 X-0.5000 Y27.8750 Z-0.1250
G2 X-0.3750 Y27.7500 Z-0.1250 I-0.0000 J-0.1250
G1 X-0.3750 Y0.7500 Z-0.1250
G2 X-0.5000 Y0.6250 Z-0.1250 I-0.1250 J0.0000
G1 X-6.4508 Y0.6250 Z-0.1250
G1 X-6.4355 Y0.5000 Z-0.1250
G1 X-0.1250 Y0.5000 Z-0.1250

BackboxLeft.nc (7.8 KB)

I also tried this with the grbl post processor. It does the same thing. :frowning:

plese post the gcode that the grbl post processor created. The fact that your
first attempt was generating unsupported code pretty much invalidates it.

David Lang

After banging my head against the wall for a little longer, I think that the issue was that there was no “f” codes in those files. I guess you have to say it in 2places in freecad to get it to work. After I added that info, it started working like a champ. I’m cutting now!

Thanks. Sorry for my confusion. :slight_smile:

2 Likes

Yeah, that’s what I thought when you mentioned it stopping on G1. G0 runs at maxfeed and G1 at whatever the current feedrate is set to… which probably is 0 if not initialized.

Should we set that to a higher value by default? I think it was set to 0 by default for safety, but maybe that is the wrong choice?

I can think of two schools of thought. One. You shouldn’t be using it if you don’t know what you’re doing. I’m figuring this out as I go along and that was a mistake that was easy to fix…I just didn’t know it at the time. Two. If it has zero velocity with the bit plunged, it could just sit there and start burning if you’re not watching it.

Maybe something in the middle? Maybe something that checks what you import and a warning message that says, “Hey, man, this has zero velocity. You gonna start a fire if you’re not careful. Check your G-Code.”

1 Like

a default feedrate of 0 is wrong. I would default the feedrate to max if it’s
not specified any other way since the last time the arduino started.

David Lang

1 Like

Interestingly I went into change it and it looks like someone else beat me to the punch:

sys.feedrate = sysSettings.maxFeed / 2.0;

Apparently the default value is already half of the max federate which feels pretty good to me