Design palcement outside working area in Ground Control

Wondering if anyone else is having issues with the G-code files randomly opening where the design layout is outside of the working area.

I had a design open, performed a successful cut, tried to open another file and it was completely off the screen. Assumed there was an issue with that gcode file so went back to the one that previously had successful cut, and it too was way off the working area to the top. Any thoughts or experience with this problem??

Thinking about G90 vs. G91 right now, but might be off there. Are they defined at the top of the gcode?
Do you have a chance to share the gcode? is the screenshot from the first cut opened a second time?
Did you try to move the sled to the centre a click -> Define Home?

1 Like

I have seen this happen too. I did not do any troubleshooting as I am still not at the cutting stage. The next file I opened was centered though. I am on GC 1.02 and FW 1.02

I will be watching this to see what the resolution is.

1 Like

That photo is actually just an example. The second time I opened that file the design was much, much further off screen. It was so high, it was many scrolls up off of the screen, that I thought it didn’t even open because I couldn’t find it… I don’t have access to gcode at this time, but can get it later today. Thank you!!!

1 Like

For the interest of others digging into this, I could disprove this thought with several files set to G91, removing all G90/G91, putting G91 on a Macro Button, and could create a lot of funny and interesting results, but not a increasing displacement of the cut.

@Mom5 Could you post your GC and FW version?

1 Like

This looks like it could be a G-Code issue. To me, this looks like the paths were programmed way off the origin. How were these drawn? What program did you use to make the G-Code?

You should be able to go back to your CAD and center the geometry on the drawing origin

1 Like

I had this with .dxf imported to non autocad programs, but the displacement will remain always the same in the gcode. Need to find at least one person to be able to replicate what is going on. I noticed I could catapult the sled to outer space on the simulate by changing the units during a cut :-). Think that should be deactivated during a cut, because it is to close to pause and stop. Likely off-topic.


One thing that I can think is that each gcode file will have a (0,0) point programed into the file from the program which generates the gcode. That (0,0) point will line up with the “home” position in Ground Control. Pressing “Define Home” will move the file to the current position of the machine. Where that home position is defined is remembered by Ground Control so that if it crashes or you close it accidentally, the file will re-load in the same spot. I can imagine an issue where if the home position is defined off to one side it could cause the behavior you are seeing, but I wouldn’t expect it to reload further and further away.

Another option that I can think is if the home position is defined in mm and then a file in inches is loaded I could imagine strange behavior. I would expect clicking the “define home” button to always fix the issue.

If there is a file and a set of steps that always cause the behavior your are seeing that would help me to track down exactly what’s happening

1 Like

Thank you all for the advice. I will acquire the files and try a couple of things and update the post.