Maslow Home Maslow Community Garden

Ground Control not show my design


#1

HI

I am new and I am sure I did something wrong. I am using QCAD/CAM to make my design, it is a 10
inch square with four holes.

Then it converted to Gcode. The first time I put it into ground control my design was the But I had to make some changes to the cut. The Z axis was topping out so I had to readjust it in the program.

After making changes when i load it to ground control I see this

It is a tiny square.

My Gcode file is Square test 1.nc (12.3 KB)

I am using windows 10
Ground control 1.21
Qcam/cad

Any help would be great

Doug


#2

I’m not sure why it’s not showing up in Ground Control, but when look at your gcode on https://ncviewer.com/ it looks like your gcode isn’t quite right. The bottom right circle is all messed up. I’m assuming all of the "T"s in your screenshot are tabs, but the gcode has no tabs in the circles and it’s missing the tab on the bottom of the square.


#3

Hi

Thanks for looking at it, I will start over. I tried to open the sled on ground control and I don’t see the sled either.
Is it possible that I turned something off.

Doug


#4

There shouldn’t be anything that you can turn off to make files not show up. Pressing the “define home” button might be a good idea to make sure the home position isn’t off screen or something


#5

Hi Bar,

I di that and it did work thanks.

Doug


#6

If it is inch I would try to add a

G20 ( imperial mode )
G90 (absolute mode)

before your code. It shows then.

You might be able to edit a template or add this in preferences to your CAD program.

Edit: Sorry for the short answer. Bed time for me. Feel free to ask details.


#7

Hi Gero,

I will try that. Its a steep learning curve, wish someone lived close by that could show me the basics.

Doug