Does the Maslow not actually support work offsets?

I was getting some bizarre behaviour while trying to get an original Maslow (with Z axis) working with Makerverse. When I ran a program it would completely ignore the work offset, instead using the machine home as 0,0. Even more odd, if I typed a movement command in the console it worked exactly as I expected. That’s when I noticed that the g code generated by V-Carve Pro didn’t have any spaces. If I run “G0 X0 Y0” it goes to the work home, but “G0X0Y0” goes to the machine home.

Either this is some bizarre firmware bug, or the Maslow literally doesn’t support work offsets and (for whatever reason) Maker Made decided to implement that in software rather than using GRBL’s existing capabilities.

yes, the maslow firmware does not dupport the G54 family of work offsets. It was
initially implemented in Ground Control and nobody has taken the time to
implement it in firmware.

David Lang


Does the M2?

don’t know, but since it’s derived from grbl, odds are good that it does.

David Lang