DUE board died, AGAIN!

I’m on my second DUE board and just flashed some firmware and was issuing some commands when it stopped responding correctly. I issued a $H then G91 X0 Y10 and the sled goes down! Tried a up and sled runs away to top, had to unplug the USB to stop.
Reconnected and missed $H followed by a G91 X0 Y-10 and sled runs away again. By this time the sled is all the way up and touching the top beam. I was able to get sled off and tried again to lower chains, no dice.

I reflashed the same firmware and now am greeted with only an e and no prompt.

Anyone want to buy some Maslow M2 parts?

Maybe reach out to Makermade. Since this is your 2nd due board maybe they would honor a replacement warranty?

1 Like

You could get a mega off Amazon for ~$20… Not sure if your due shield would work with it, but I may have a spare shield and we could work out a deal on it. Need to check. Everything you have will work with the classic mega controller.

board died would be that it doesn’t respond to the system, it sounds like you
have a different issue (one with calibration and/or the system knowing where it

the fact that you were able to flash the DUE says that it’s not dead.

David Lang

Yes, that is an interesting point. Indeed when flashing the RX/Tx LED flash but nothing happens on cpu reset, just an e' shows up in the terminal.

Also @Orob, I don’t think the motor shield daughter board will work on the Mega will it? I have a Mega laying around but thought the the daughter board with motor drivers was made for the DUE.