Maslow Home Maslow Community Garden Newsletter

Y axis has gone crazy

I have really had nothing but trouble with this M2 I seem to get is working close and then the next cut is all scewed. Most of my current cuts seem to lean to the right looking at the board. I put a sharp bit in and slowed down the speed and did a more shallow depth cut. It did a fair job on my last cut but when I was finished and went to move the sled out of the way, as I was jogging, about 5 in at a time, the sled just started heading the the floor. I unplugged from my machine and ran to cut the power. It hit the floor and ripped the chain out of the header board before I could get it stopped. I let is sit for a week and hooked it all back up. When I try to jog up a about 1mm at a time,it goes about an inch. When it reaches a spot about 20 inches up, it will not go any further. If I keep trying to hit the up button, it starts to go down instead of up. The process is then reversed. If I try to go down it goes up. After a few more clicks, it will reverse and up goes up and down goes down. X and z seem to be fine.

any help would be appreciate.

Where to start… sounds like it is confused as to where the sled is. Need to put the sled at center and rehome. Optionally you can reset the memory on the controller and completely start over. If you want to try that, then I would recommend downloading the newest beta release of makerverse and use the reset button provided to wipe everything and then go through the higher precision calibration.

Is there a version later than 1.0.6?

The development version is 1.1.1 build 241 and is much better/different. Get it here. in the release section on the right of that page you can find the latest version for your platform. To get the bleeding edge, you check the box for beta in the general settings and then restart it.

@Orob Are you running a M2 GRBL shield?

Thank you

I have one of each.

Sweet!

I don’t know what that is.

@hooper1 I don’t mean to hijack your thread. Bee was asking about my hardware. It almost sounds like your left and right motor cables got switched OR your $3 setting is incorrect. If you have not made any major changes, you might try this console command $3=4 that sets the axis directions. (type that in the black background widget window). It will wait a few minutes and then return with OK.

@Bee: With respect to the settings I was going to make a video about the differences between the grbl (M2 or due) and the classic (mega), but makerverse has been changing so much lately that it would be outdated in a couple days, so I have not done so. I like the smooth start/stop of the sled movement in the GRBL (due) firmware, but I’m not convinced that upgrading to a Due controller really gets you much since the main upgrade is the Z axis. What really was surprising to me in trying to get the mega to run that software was that GRBL was originally made to run on the Arduino UNO! It was ported to the Mega more recently and last year was put on the Due.

Fww - in a serial connection to a GRBL controller you can get s full settings dump issuing $$ in MDI or Terminal. I would say that is a good starting point going forward on M2 support.

Thank you

1 Like

I had a similar problem when I set up my system at the beginning of the year. It turned out to be a large error correction value (not close to my machine right now so I’m not sure of the exact name for the field or which menu it’s in, sorry) for either x or y in the settings. I reset the value to zero and recalibrated. Haven’t had that problem since.

I’m super new to all of this and I’m having the same issue. I got the original maslow and ordered the M2 kit and set it up from the start with this.

Everything is hooked up, measured and inputted.

The sled will move left and right and the z will raise and lower fine but the Up and down controls for the sled are inverted. Can’t seem to figure out what all the $$ options do.

$0=10 (Step pulse time, microseconds) $1=25 (Step idle delay, milliseconds) $2=0 (Step pulse invert, mask) $3=4 (Step direction invert, mask) $4=0 (Invert step enable pin, boolean) $5=0 (Invert limit pins, boolean) $6=0 (Invert probe pin, boolean) $10=1 (Status report options, mask) $11=0.010 (Junction deviation, millimeters) $12=0.002 (Arc tolerance, millimeters) $13=0 (Report in inches, boolean) $20=0 (Soft limits enable, boolean) $21=0 (Hard limits enable, boolean) $22=1 (Homing cycle enable, boolean) $23=0 (Homing direction invert, mask) $24=250.000 (Homing locate feed rate, mm/min) $25=500.000 (Homing search seek rate, mm/min) $26=250 (Homing switch debounce delay, milliseconds) $27=1.000 (Homing switch pull-off distance, millimeters) $30=24000 (Maximum spindle speed, RPM) $31=4000 (Minimum spindle speed, RPM) $32=0 (Laser-mode enable, boolean) $40=22528 $41=17408 $42=20480 $43=5000 $50=22528 $51=17408 $52=20480 $53=5000 $60=20480 $61=17408 $62=18432 $63=5000 $80=0 $81=2438.400 $82=1219.200 $83=3400.000 $84=427.000 $85=1.004 $86=1.003 $100=127.775 (X-axis travel resolution, step/mm) $101=127.775 (Y-axis travel resolution, step/mm) $102=472.500 (Z-axis travel resolution, step/mm) $110=1000.000 (X-axis maximum rate, mm/min) $111=1000.000 (Y-axis maximum rate, mm/min) $112=250.000 (Z-axis maximum rate, mm/min) $120=25.000 (X-axis acceleration, mm/sec^2) $121=25.000 (Y-axis acceleration, mm/sec^2) $122=10.000 (Z-axis acceleration, mm/sec^2) $130=2500.000 (X-axis maximum travel, millimeters) $131=1250.000 (Y-axis maximum travel, millimeters) $132=25.000 (Z-axis maximum travel, millimeters) ok

And on a side note, when I unlock it to enter my offset, the terminal will show the updated settings but not the GUI. Maybe it’s just cosmetic.

I get this screen when I start up the newest makerverse.

I went to the update firmware link and have tried several things but can’t seem to figure out how to update my firmware

Tried setting the $3 and it didn’t work, ended up setting $3 back to the recommended “4” and switched the motor cables around and it’s working like a champ.

2 Likes