Error Compiling

I followed the directions and tried to upload to the board and I was returned the following error message: Error compiling Arduino/Genuino Mega or Mega 2560

Please help I am new and new to coding and this arduino stuff. Did I do something wrong?



Can you point to the instructions you are following? What Operating system is on the computer you are using? Do you have the Maslow Kit?

Thank you

yes I have the maslow kit: I used the instructions here:

What type of Computer is this? Mac, Windows , Lunix? When the Mega is connected with the USB cable do you see a red light on it? What port is showing on your system?


I’m sorry for the trouble!

To help us figure out what is going on can you tell us full text of the error you see in the lower window like this:


it is a lenovo 100s running windows

Thank you each OS handles USB in somewhat different ways. Is the Mega plugged into the computer before you open the Arduino IDE? If so what port or ports are shown in the list of ports?

Hi it was plugged in when I opened the ide
where do I find my com port info please.

it’s in step 6 -

Your screen shot shows Com3

Let me do a little more looking into this.

Thank you

Did you extract/unzip the files before opening them?

I just clicked on the file and it was in my arduino ide

Ok, I think I know what is going on are all of the files downloaded still in the same folder. It looks like the arduino IDE cannot find the file “CNC_Functions.h” which should be in the same folder. Is there any chance something went wrong with that file? It might be worth doing the download and unzipping the files again

1 Like

ok thank you I’ll try that again.

1 Like

I agree with Bar. You want to redownload the file. Locate it, right click and Extract all. Then from the IDE use file open to locate the file. My guess as to what happened is, you clicked on the file showing you the contents of the compressed file. You clicked on the file you needed and it is associated to the IDE so it opened. The files it is dependent on are still compressed so the IDE cannot correctly access them. I hope this helps to explain why you are seeing this error. Let us know if you are still having an issue after using extract all.

Thank you

1 Like

Thanks! it worked!!! I totally appreciate your help!! the toast I did is for you too! thank you!!!


Excellent - glad it’s working

1 Like

thank you for your help!!!


The feedback is greatly appreciated!

1 Like