Maslow Home Maslow Community Garden

Error message during uploading Arduino


#21

The distance from the centre of the cutting-bit to where the chains attach to the sled.

image


#22

Rotation radius is (generally speaking) the distance from the router bit to the point on the ring/linkage kit where the chain is attached.


#23

In GroundControl I have follow all the required steps to measure the chain several times.
Every time the distance is -12.7mm, so I have changed manually to 3030mm.
I have the following message:
(the sled is not keeping up with the expected position and has halted. Click stop button to clear the alarm. More information at https:// github.com/MaslowCNC/Firmware/wiki/keeping.up)
I have tried the Right Motor also after changing the distance to -12.7mm but still receiving the same message.
I hope nothing happened to Motors.
Kindly help.


#24

My suggestion is to first figure out why you are getting a -12.7 mm distance between motors… I really, really think that you aren’t following the steps correctly because a -12.7 mm distance makes absolutely perfect sense if you are just manually laying the chains across the sprockets rather than using the left motor to feed out the required amount of chain. Watch this video, starting around the 3:20 mark… it gets blurry from time to time, but the author is doing it correctly.


#25

I have follow all the mentioned steps as above and still the distance between the Motors is -12.7mm.
However I continue and during the adjusting of the left chain the motor continue to work until the string start to be close to the motor (different from the film above) so I have to stop the machine.
In addition, is the value mentioned in the film ( 3050mm) generated automatically?
Please help.


#26

I don’t understand how it gives a value of -12.7 mm. If you set the sprockets to 12 o’clock and hit define zero in the previous step, then extended the chain from left sprocket to right sprocket by the method shown in the video, when you press measure, it should give you a number close to what you measure by hand.


#27

I have follow all the mentioned steps as mentioned in DIY Homesmith Step 5 part 3 and still the distance between the Motors as mentioned in the summary is -12.7mm.
However I continue and during the adjusting of the left chain the motor continue to work until the string start to be close to the motor (different from the film above) so I have to stop the machine.
In addition, is the value mentioned in the film ( 3050mm) generated automatically? Please not that I have only the value which I entered for rectract.
Please help.


#28

Never seen a minus in the motor distance, for now just go to settings and change to what you measure by hand. Close GC and reboot.
What is the behaviour now if you move the sled with the arrow keys in GC?
Is direction correct?
Please also upload a copy of your ->groundcontrol.ini<- here. In widows it’s found in the user folder I think. Don’t worry, we will crack this nut way before christmas :wink:


#29

[Computed Settings]
distperrot = 63.5
kpposmain = 1300
kiposmain = 0
kdposmain = 34
propweightmain = 1
kpposz = 1300
kiposz = 0
kdposz = 34
propweightz = 1
kpvmain = 5
kivmain = 0
kdvmain = 0.28
kpvz = 5
kivz = 0
kdvz = 0.28
chainoversprocketcomputed = 2
fpwmcomputed = 3
kinematicstypecomputed = 2

[Maslow Settings]
bedheight = 1219.2
openfile =
motoroffsety = 430.0
sledwidth = 310
zaxissafeheight = 5
bufferon = 0
bedwidth = 2438.4
comport = COM6
macro1_title = Macro 1
sledheight = 139
macro2 =
macro1 =
zaxis = 0
sledcg = 79
macro2_title = Macro 2
colorscheme = Light
zdistperrot = 3.17
motorspacingx = -12.7

[Advanced Settings]
rotationradius = 150.0
chainextendlength = 1650
kiv = 0
gearteeth = 10
spindleautomate = None
kdvz = 0.28
chainsagcorrection = 0
chainpitch = 6.35
chainlength = 3360
propweightz = 1
zencodersteps = 7560.0
maxfeedrate = 800
enablepospidvalues = 0
rightchaintolerance = 0
enablevpidvalues = 0
maxtouchprobeplungedistance = 0.0
kpvz = 5
kdposz = 34
chainoversprocket = Bottom
kpposz = 1300
fpwm = 490Hz
kdpos = 34
encodersteps = 8113.73
truncate = 0
homex = 0.0
homey = 0.0
kinematicstype = Triangular
kipos = 0
kdv = 0.28
kiposz = 0
digits = 4
kppos = 1300
kpv = 5
propweight = 1
positionerrorlimit = 2.0
kivz = 0
leftchaintolerance = 0

[Ground Control Settings]
zoomout = pagedown
centercanvasonresize = 0
viewscale = .45
zoomin = pageup
validextensions = .nc, .ngc, .text, .gcode

[Background Settings]
backgroundfile =
manualreg = []


#30

With reference to the behavior, I am checking and will come to you soon.


#31

The arrow does not make any movement.
After reboot and open the GC received this message:
(Unable to find valid machine position for chain lengths 0.00, 0.00. Please set the chains to a known length.


#32

Try what happens if you set the chain length manually:
->Actions ->Advanced -> Set chain length…


#33

I follow your instructions the I go to action-calibrate and do all the steps without " pull the chain and measure" and the result is still -12.7mm.
I have tried again and this time I have the same above message but 0,0 became 1650,1650 ( this reflected in GrooudControl.In) but the result is same.


#34

Did you change that setting before you restarted?
Can you post a picture of your frame?

Edit: Don’t know if it will help, but maybe worth a try:

  • wipe Eeprom
  • rename groundcontrol.ini to .old
  • upload an older firmware like 1.23 (assuming you are on 1.24)
    and see if a ‘clean start’ gives the same results.

#35

If you don’t “pull the chain and measure”, it won’t measure the distance between motors and so the original value you had (-12.7mm) will remain as the value.


#36
  • I renamed groundcontrol fil
  • i dont know how to wipe Eeprom
  • I can take photo for the frame but I dont know how to uploaded with the message.
  • Below the steps I did in details:
  • Open GC.
  • Setting - I write distance between motors = 3030mm
  • Action - Manual Calibration
    - I write distance between motors = 3030mm
    - I write rotation radius = 150mm
    - Distance from top of work space to motor - I consider = 430mm
    - Triangular
    - Chain feed - Bottom.
    *Calibration - I have skip the screen ( use the chain to measure the distance…)
    We reach the screen asked to adjust the Left Chain, when press the button,
    motor halted.

I have reboot and follow the normal instruction ( not manual) and everything go smoothly until pressing the tight the chain and measure and as before the chain became tight for a second and make sound and has a slack.
Upon checking the Groundcontrol.ini the distance between motors show -12.7mm.
I really dont know what to do next.
Thanks


#37

Are you setting the sprockets to 12 o’clock and then pressing define zero?


#38

When you reply to a post you can use the ‘upload button’.
The reason I’m asking for the picture of your setup is that I want to compare with the settings in the gc.ini file
image


#39

As Requested.Photo%201 Photo%202


#40

Yes.
Thank you