First Cuts & Notes from the field

Notes from the field:

So this past week I’ve had the opportunity to make some first cuts with my Maslow M4!

My local makerspace, offers consulting services and they were contacted by a local escape room company ( about helping them get set up to use an M1 and M2 to make some set piecess for an upcoming project. My name came up because I’ve been talking about my Maslow M4 whenever I get the chance!

I stopped by their space, and decided we should try out the M4 first since I knew it better and then see about the M2/M1. I sent them a link to the default frame which they built over the weekend. I overwrote my UI tweaked custom build with the latest firmware and files and arrived Monday morning.

I calibrated once or twice on the spoil board, then loaded a full sheet of 5/8” particle board and ran the calibration again. I didn’t pay attention to the numbers, but it seemed like it was in the right place.

Next was installing the router bit. I had them print the updated button pusher - thanks @Frank_Wiebenga - it worked great! I had installed my router a millimeter off angle a bit so it wouldn’t go in until I loosened the top and bottom router clamp and rotated the router motor a bit in each direction until I was able to pop it in. Then I tightened the clamps back up.
=> If you had one of these printed before assembly you could make sure it fit and worked during assembly.

The project is creating walls for an escape room that resemble the stone work of the Incas, as seen at Machu Picchu in Cusco:

The walls will be 12 feet high, using two vertical sheets and a horizontal one above it. So 3 sheets to make a wall segment 8’ wide by 12’ high. The idea is to route within a few inches of the edge of each panel, install them on the walls and then connect the lines by manually routing with a trim router.

The bit of choice is Whiteside 1574

So Monday was about assessing overall feasibility.

I looked at the nice speeds/feeds document posted by @Puddly , but decided to just start slow and make a few trial cuts. We did a full board at 200mm feed rate, 100mm z-axis and 9.5mm cutting depth.

Success! It seemed to know its way around the 4x8 sheet. With a freshly printed 2.5” dust shroud which just fit inside the flex hose on the dust collector. We added some zip ties later.
=> Cut was too shallow, probably due to z-axis not being fully dialed in to zero, and not knowing exact depth needed.
=> Cutting speed seemed too slow, but probably on par with human router doing same thing (around an hour I think).
=> Dust collector running kept the dust smell out of air, but left the grooves filled with dust, which we kind of manually followed behind with a shop vac. More on that later.
=> Cutting to within 6” of edge seemed totally fine.
=> The original file had lots of individual line segments, so we worked on tweaking that a bit so not so many up / move / down / cut cycles.
=> I didn’t realize it at the time, but the preview in the Maslow UI is cut off on Safari - it has an extra margin on top so it is cut off on the bottom. Probably some CSS issue. I just thought it was “Open source” / growing pains until I saw someone else load it on chrome and it looked fine…

Day 2 - Tuesday

This was mostly about dialing in the cutting speeds and depth. I re-zeroed the bit depth using 0.1mm steps until it cleared a straight-edge held across the sled then set that to z-home:

I didn’t have @md8n maintenance stand printed yet but will be using it soon.

With z-axis re-calibrated, we ran cuts at 8.5mm, 9, 9.5, 10 and 10.5mm depth. 9.5 was not enough, 10.0 was too much. 9.7mm seemed just right.

Due to some errors we had a few tests cut in two passes (pass depth set less than desired cutting depth) and that worked great in that they seemed perfectly co-incident.

Next we moved on to cutting speed (feed rate). From 200mm we went to 400, then 600 and then 800. At 800 the sound changed a bit so we decided to back off to 700.

We also experimented with moving the cuts to within 3” of the edges with success.

So 9.7mm depth, 700mm/m cut speed, single pass. The goal is to figure out how long this will take per board.
=> Does anyone know if you can set move speed different from cut speed? I didn’t see a facility to do that in Easel, but wasn’t clear if the firmware supported it anyway.

Wi-Fi Woes
I had set the Maslow up to be a client of the local network at the end of the previous day and that had worked fine. However, when I came in on Tuesday, it wouldn’t connect to the network. Moving the wifi extender a bit closer seemed to resolve that and I was able to connect again. This was really handy for the test files, since I am not generating them.

We started cutting and that’s when the Maslow drove off the edge of the board mid cut. At first I thought it was g-code and it missed a move, or the file was off, etc. You can see in the picture below, the left middle edge is where it drove off first you can see the cut depth decrease as it tips up. I think I picked it up then and disconnected the power so it cut at the very edge a bit more.
=> It would be nice to ‘jog’ through the g-code rather than just move arbitrarily before engaging the z-axis to pick up on something like this rather than starting over, I don’t know if that’s possible…
=> Instead, we just deleted the completed portions of the cut and re-exported a new g-code post failure point and started again.

And it ran of the edge of the board again. This time I think it was upper right cut that tapers off to the edge.

That’s when I realized it was possibly the sus wi-fi… switched Maslow back to AP mode and did another cut. This time the full cut completed without issue.
=> If your Maslow is ignoring G-code and charting it’s own path into the forbidden zone and you are running it as wifi client, try running it in AP mode.

Work Flow Notes
Their designer using Illustrator to create and edit the patterns. Export to DXF (SVG seemed to have classic SVG scaling issues with Easel, I had same problem loading SVG into carbide create and decided to use DXF. I’ve spent too much time dealing with SVG PPI vagaries to sort that out in the moment and DXF worked fine.)

Generate G-code in Easel, upload to google drive, download to Maslow, load and go.
=> Its really nice to be on the same network so you don’t have to connect and re-connect. More than once we’ve had the machine ready to go, then realized we didn’t have the latest file and the changing wifi networks connection/re-connection process seems to lose the ‘state’ so its retract all / extend all process a few extra times.

=>The designer has been experimenting with optimizing the file in Illustrator by changing the ‘direction’ of the lines so that any cuts that go to the edge, start at the outside and move in towards the center of the sheet.
=>Making the cuts going to the edge start at the outside and go inwards helps a bit with the quality of the cut. Going outward when the Maslow starts to tip a bit, it raises the bit and you don’t get the full cut depth. Going inward from the edge, the Maslow starts to pull and the bit diggs in and the start of the cut is more consistent. If you look at the cuts ending at the edge in the image above, you can see the difference in some of them (not the drive-offs noted above) where the cut tapers a bit as the Maslow tilts when cutting towards the outside edge, and others where it started outside and moved in.

In this scenario, the designer has also created one long continuous path that winds from one end of the sheet to the other, and then fills in the edge cuts and various other cuts to form the entire design.
=> Cutting time is down to ~31 minutes per board, with about half of that in the first continuous cut. Trying to reduce the extraneous moves and z-axis up/down movements.
=> I think he has done some work with sorting the order of the ‘layers’ of the different segments, which is picked up by Easel - or done in Easel - so that the finishing edge cuts go around the board in order, etc. I imagine different software handles this in different ways but I think we’re closing in on diminishing returns for now.

=> Cutting close to the edge works fine. However, the upper left corner is challenging due to that corresponding motor being the highest so the belt angle is the steepest. So it really tilts off in that corner. See bottom left in picture above. Solution to that would be to have some sled supports at the top right matching the material thickness. Or, before it starts moving, push down on the sled to level it out!

Day 3 - Thursday

Dust Collection
So we have several successful full sheet cuts behind us. I’m bothered by the fact that the dust collector doesn’t seem to be collecting all the dust. Basically, if the dust collector isn’t running, you can smell particle board dust in the air == bad. With the dust collector running, the smell is gone, but the cut ends up completely full of dust. So we had been shop-vacuuming the dust out before moving the panel.

We also tried the shop-vac connected directly with similar results. It did sound a bit anemic like the filter was likely clogged from previous exposure to particle board dust…

So I brought in my Festool dust extractor. It did a better job, leaving a very clean cut:
See photos above where cuts that haven’t been vacuumed are filled with wood dust.

So how to solve the problem of their dust collector having higher volume but likely lower suction. I measured the air-gap between the router base and acrylic shield when the bit is in it’s zero position. Knowing the that for this job the bit and base would drop down about 1cm to perform the cut, I cut a piece off the end of their dust collector hose slightly taller than the router base to acrylic amount, raised the z-axis all the way and popped the chunk of hose into the gap. Voilá - Pressure fit to hold it in place at Z= zero, and slightly compressed during cut.

And perfectly clean cuts with the dust extractor. They are using with a 2.5” clear flex hose.

Did I mention that there are >115 sheets to cut?

=> Maslow M4 working great for this application! They have already ordered their own, so at least one sale so far. Thanks @bar and @anna for getting it shipped out to them, it arrived within the week.
=> Wi-fi issues described above seem to be resolved for now by running M4 as Access Point.
=> Dust collection of particle board dust improved significantly with addition of compressible section of hose around the router bit.

And some thoughts/observations that I have no idea about what is or isn’t possible, or if I’ve missed something, etc.
=> @bar I really wish that you could “Release Tension”, unhook the Maslow, change out the material, and “Apply Tension” and be able to start a new cut. That’s what I expected to be able to do. But it seems the state machine wants you to retract all and extend all before applying tension. Just curious if that would be possible. I imagine there is some risk of accumulating error over time, but it would be a time-saver.
=> It would be handy to be able to run the g-code but ignore any z-axis commands.
=> It would also be handy to be able to jog along the path of the g-code.


This is EXCELLENT information. I’m going to dig into why that is happening and fix it. Knowing that its a wifi issue is going to save me a huge amount of time trying to figure out why that is happening because you aren’t the only person to see that. The more specific instructions that you can give us for how to make an issue happen, the faster we can fix it.

This is GENIUS. Absolutely genius. So cool.

I’ll look into that. It seems like a reasonable way for things to work.


Re: Release Tension then Apply Tension

I will have to test again when I’m in the shop, but I am pretty sure I’ve called Release Tension and Apply Tension without a remount and then been able to jog and cut right away.

Odds are you could jog ‘up’ away from center and release tension, get the lower cables out of the way, mount a workpiece, and then rehook to the anchors and apply tension.

I’ve just been jogging as far ‘up’ as I can go and then mounting my workpieces with everything attached, tbh. I could see issues with a big sheet, but I’m not seeing issues overall just lifting the sled up and sliding wood under it, even using it to hold it still on my vertical frame while I lock it down with screws.


That’s interesting - I just haven’t had the chance to try it again, but will do at some point.

I haven’t used jog at all yet as I’m cutting whole sheets only and have set up home on the cuts to be machine home.

I’m running the frame flat, but I imagine the “re-hang dance” is potentially more annoying than the floor based “battle belt” exercises. I like to pretend I’m doing Kristin Wiig tiny-hands cross-fit “battle rope” when extending belts - makes it go faster.


Many have found that the belts are a bit slack after jogging. I would recommend using Apply Tension again if you’ve been jogging around, before you cut. I haven’t noticed the same ‘suddenly slightly slack’ issue when cutting or using the return-to-home command.

1 Like

Apply tension does not have any lasting impact. It just applies tension which will be relased again as soon as you start jogging.

To get tighter belts in general you want to increase the current threshold setting before running calibration

I’ve had mine at 1700 for awhile because any lower and it wouldn’t pull my belts all the way in during a retraction.

Good to know that setting is for more than just calibration.

1 Like

My smooth brain keeps realizing that my mental model of how Maslow + FluidNC works is probably flawed.

  • First it’s like “Oh, maybe g-code is getting dropped/corrupted when being ‘sent’ to the Maslow” => But G-code is already on the machine stored locally so it would have had to have been corrupted during upload, which seems likely more robust protocol than web
  • It almost seems like if there is a network-related hiccup in the ESP32 that it must interfere with underlying FluidNC updating motor commands?
  • Is it just some other connection loss? Like, what are the symptoms if during a cut, network hiccups and another browser instance happens to re-connect? I think I went through and killed every other connection, but with multiple people, PCs, phones, etc. potentially connecting, there is more likelihood on same network (i.e. client mode).
  • or, just wifi-signal loss and re-connection- how does that affect something mid-cut? Or just periods of poor signal strength or throughput.
  • not clear how much the WebUI is a “representation” of what’s happening on the controller board, vs. the appeance. For example, pressing pause. Does that just pause whatever motor commands are currently being processed, or does it pause the processing of G-code as well?
1 Like

I think that what is going on is that when the connection is lost (especially maybe if it can’t reconnect again?) FluidNC is going into some sort of “hold” state which is not sending any commands to the motors and since they are servo motors they will continue to rotate at whatever the last command speed is.

To fix it I think that we need to:

  1. Make sure we stop the motors from moving if fluidNC goes into that state
  2. Make sure fluidNC doesn’t go into that state just because the wifi connection drops

I vaguely remember seeing that fluidNC intentionally stops running if the connection is lost (even if just the browser is closed, not even on a wifi drop) and I’m not so sure that’s the behavior that we want

I’m gonna go with “That’s probably not desirable”

1 Like

wifi connections in high EMF may cause inconsistent crashing and resetting according the thread above

1 Like

It seems that adding a connection to earth ground for everything including the vacuume hose, router and Maslow’s mainboard would help, no?


I suspect that my issue I ran into last weekend is the same issue being discussed here where the Maslow just begins moving in one direction without stopping. The cut it made was generally straight, but not like the machine was doing it on purpose, there is plenty of waviness.

That seems to match @bar 's hunch:

FluidNC is going into some sort of “hold” state which is not sending any commands to the motors and since they are servo motors they will continue to rotate at whatever the last command speed is.

If the servos were moving at their last rate, but were not being controlled by new commands, that is what I might expect to see it cut.

Mine was running in AP mode at the time, but the laptop went to sleep and disconnected. However, I also saw behavior like this in some earlier test cuts where it would drop from my wifi and then just stop.

If this is a situation where there is a lot of EMI that is triggering the issue, I wonder if the router speed is a contributing factor. I have a 611 and I have been running it around speed 5, but is it possible that lower speeds would be “safer”? I am far from an expert, so this could be the wrong question to be asking.

1 Like


Probably don’t need to have it that high to get good cuts.

I’ve noticed that I’m scorching bits when I’m above 4, as well as making dust instead of chips/shavings, neither of which are ideal.


That kinda depends on if you consider my 1/8" bit to be a small diameter bit :slight_smile:. I was cutting baltic birch.
I am certainly going to vary the speed and see what I get.

1 Like

Just something to keep in mind. I was scorching 1/8" bits in multiple different materials during my first few tests. I bought a bunch so I could trial and error into faster cuts.


We have been running ours at 1 - 1.5 as the bit is specified to max out at 17k (it’s >12mm diameter). So I don’t think lowering your speed will make a difference -we keep running into it.

I’m going to try shortening and shielding the DC portion of the power cord and see if that does anything.

1 Like