Maslow Home Maslow Community Garden Newsletter

Flashing yellow light on the board

So I’m feeling a little over my head but we just bought a second hand set up. We put it together, followed all the setup directions (which was quite a headache as neither of us are particularly computer savvy) and got to the calibration part…at which point none of the motors work. Ran a test and they all failed.

Noticed that there is a solid green light on the board, and on the opposite side a flashing yellow light. I suppose that indicates our problem but I don’t know what it means or how to fix it. Any guidance is SO appreciated!

UPDATE: So I read some more and discovered that the power was plugged into the Arduino. Then I ran a test and they worked! Yay! Then I go into calibration and now the left motor won’t turn. Ever few tests it will turn a little bit counter clockwise and then stop, now it is consistently failing both directions. No idea what to do—I’ve unplugged and reseated everything, didn’t seem to help. I also swapped the cables between motors and the left one will now turn but it makes a clunk noise and you have to assist it to get it going again, so maybe the gearing?

There is a plastic gear in the motor gearbox that may have given up on you, though some have reported success after cleaning and lubing the gears. You might try that.

2 Likes

If you have a working cable feeding one motor just fine (RHS), but then it fails when connected to the other motor, I think you’ve pretty conclusively proven that the fault lies within the non-functioning motor.

Time to crack out the screwdriver for a look.

When I received my motors new the gearbox was not fastened securely to the motor body, necessitating a full gearbox teardown to get the required access to tighten the case screws before rebuilding everything again! Thank goodness I have a well worn collection of tweezers and other fine tools for such work.

These kits are true DIY so prepare for some more battles. But it will be so worth it :slight_smile:

2 Likes

We replaced the motor and it will now turn in calibration, but ONLY 360 degrees—both motors do this, they make noise but don’t move for 1 or 5 deg.

Do they pass the motor test now? As in is the encoder good?

What computer are you using to run them and what software and version are you using?

1 Like