Calibration step, connect to motor fail; my board isn't the same as in instructions; two power inputs

Thanks in advance.

  1. First off, my board has two power inputs, which do I use?

  2. My board has three, not four, cable connections so which do I use as the instructions do not match my board.

  3. The bottom board is flashing yellow, what does this mean? The top board is solid blue BTW.

  4. Cannot connect to motors when I Test Motors/Encoders I’m guessing rectifying the above might fix this but wanted to throw it out if this helps.

You want the power connector in the green board which says “Maslow” on it. When you plug in the power a light next to the connector should come on indicating that you have power

I really need to update those pictures. You want to use the same connectors indicated in the picture and ignore the 4th one

The bottom board flashes when it is active, that is normal and good.

This is probably related to the above, but if you haven’t done so already it is important to install the firmware and then connect Ground Control to the Arduino by clicking Actions -> Ports and choosing the same port you used when installing the firmware

1 Like

And make sure you close the Arduino IDE when done updating firmware (it will interfere with GC)

2 Likes

Thanks everyone. I did have it connected properly, based on your comments. I ended up starting from the beginning and it worked. I with I could write what the issue was, but it magically worked.

Thanks again!

2 Likes