Maslow Home Maslow Community Garden Newsletter

Fusion 360 CAM 1st try GCODE assistance appreciated

Jumped in the water thanks to a push from @dlang, if anyone would like to look at this gcode and offer their thoughts or opinions, I would appreciate it. The file is too big for the forum, here is the link to file in my Box folder. https://app.box.com/s/dyuisxxt261k1gkdqb8h9niflqm3fao6

Thanks.

I’ve been attempting to write up a response for the last few days, but I kept getting side-tracked. Even during lock-down, I’m still way too busy :slightly_frowning_face:

Was this generated with the Maslow Post-processor? It looks like it was, but I want to confirm that.

Everything in this file looks like it will run, but it may run a bit slow. While those helical lead ins would work in an ideal world, I would worry that the machine would cut them a little slow. So many short G1 commands might overwhelm the Arduino’s buffer. I prefer zig-zag myself, as it moves in much longer straight lines so the feedrates all work out pretty well.

What is your depth of cut? It looks like your cuts are very conservative, which isn’t necessarily a bad thing. It will just take longer. I typically cut with a 1/4" single flute cutter around 0.25" (6.35mm) each pass and it works great. I run it 600 mm/min at 15,000 rpm. I prefer to run mine conventional, though, as I get a bit more drifting with climb milling.

All that said, again, the program looks like it will run as is and get the job done.

Thanks, I should have inspected the GCode more closely, I wanted the pockets cut at 10mm but it is cutting everything to the stock bottom. I am guessing that is a feature of the 2D Pocket.

I ran the file last night and decided to pause it at 4am this morning and pick it up after getting some sleep. I could not resume the file (webcontrol), I could not use the goto command either which was my backup plan. The only thing it would do is restart the cut, so it is cutting air right now. Even though it is cutting the full depth of the panel the piece will still be usable so I want to finish the cut.

Your input is immensly helpful, I appreciate you taking the time.

that stinks you couldn’t get it to restart. my z axis belt broke 2 passes into a 3 pass cut and so I shut it down for the night and had a dream about how to fix it. I woke up and fixed it without the belt… went from -24 pitch to -8 (way slower) and guessed which line it was on. It duplicated part of the second pass, but finished the cut. You might need to upgrade your webcontrol to get the functionality, but the restart features work. The new belt will be here next week. hopefully. I hope you don’t end up wasting too much time running in the air to catch up. you might consider copying gcode file and erasing the lines that are already cut to get to the last z axis change before your last cut position.

Oh I can’t believe I didn’t think of that. I have been sidetracked and PO’ed because I made a network folder on the RPI and can’t remember the address, so getting the Gcode into the controller was more of a hassle than it should have been, grrrrrr.

if you can’t remember the address and you have a windows machine, just open a windows explorer box and type in the ip address: “\IPADDRESS” with the double backslash and it will show you the folders. unless it is the IP address you forgot. Additionally you canadd the raspberry pi as a host to your system so you just need to type its name and windows will “know” it.
Add this line with your IP address and your device name separated by a space

IPaddress devicename

in the \windows\system32\devices\etc\hosts file. This was much easier to do in previous versions of windows, but it is still possible. Once set up, you can add the shared folder as a network drive. Good luck!