Maslow Home Maslow Community Garden Newsletter

Gcode from Carbide Create won't follow Work Position

Hi!
When I set the work position in MakerVerse to another point, the gcode start in the same zero (home) as when exported from Carbide Create.
I have to physically move the plywood to match the home/work position.

are you zeroing the work position?

1 Like

Yes, I zeroed the indicator point on both X and Y work position, but still it moves to home position when I run the program. Perhaps its something I’m missing when generating the gcode?

Zeroing the X and Y work position should be redefining the home position to be where the machine is now. Hmmm

1 Like

That’s what I’d expect! My guess is that some command in the gcode won’t let it go to where I define as the work position…
What CAM software / gcode generator are you guys using?

1 Like

I have used Carbide Create for some projects, and would really like to keep using it as I figure out what else to cut with it. As for the “Home” issue, I think a few pics of what you are describing might help some of us figure out what is going on. A pick of where in CC you are designating “home/zero” and where you have “homed” it on the actual machine, and then how far off it is saying that the work is being started/Work Position.

Something to check, in CC, when you set up your work piece (I.e. dimensions, how thick, units of measure, etc), you have the option to set where “Home/zero” would be. I think the default is to set it to the center of the work piece, so if you are thinking you want home to be the lower left, and setting that on the Machine, but CC is still set to center, then that could describe what is happening.

You are talking about Makerverse though, and I will say that I don’t have a clue about that and setting the zero position. I hope some others may be able to help you on that. I am just thinking from the CC side as I have knowledge and experience with that.

2 Likes

Did you try reloading the gcode after zeroing the work position? Does the image of where the cut will be in makerverse look correct after you zero the x and y position?

2 Likes

No and yes.
The image follows the set work position but, when i start program, the cut is way offset…
I’ll try to reload after zeroing.
It’s a CC issue, when the gcode is created in Easel, it works…

I use estlcam. Does CC have the option of moving the home position? You might try that.

1 Like

I found a solution to get around this problem: I measure the distance of the cut from the home position on the frame and from there I determine the work position in CC itself.