Ground Control Launches but no graphics

That is really strange, I haven’t encountered that before.

I second @blurfl’s suggestion to try to resize the window if you have not already

If I move or resize the window, it becomes black with a large white block in the middle. I’m using the Launch Ground Control file.

Darn, that doesn’t sound right

Edit: What GC is doing doesn’t sound right, what you are doing sounds good

Is it possible to get a screen shot of the black block? Maybe I will recognize something

It started with just a white box but then I dragged to resize the window and that’s where all the jagged part came from.

There is a link in this post to a test version v1.10 of the Windows portable file. Would you have the time and the inclination to try that one?

Got it. That doesn’t look good at all.

It looks like some graphics library is probably missing.

How tech savy are you feeling? Would you be willing to try to run Ground Control from the python code? The setup process might install the missing library. There are instructions for how set up GC from the source here

1 Like

@mechengrkj

Is there more than 1 video card in this computer?

Thank you

When I was having issues with the portable version, I installed the permanent version. This is the error I get when I try to run main.py.
Also, Your list goes Step 3 to Step 5 and skips Step 4 FYI.
Capture3

No. It’s just an old laptop.

1 Like

Hmm that looks like and issue I would expect to see if you are using python three instead of python 2. What happens if you type “python --version”?

On boot if you go to the Bios of the laptop do you have a option to boot from USB?

Thank you

I am using version 3.6.4

I think so. I’ll double check and let you know if not.

Ground Control needs Python 2

If this continues to be a problem you can build a workaround USB stick if you can boot from it.

That DL has been tested and comes from a different server.

https://www.disciplesofcnc.com/wiki/pmwiki.php?n=Site.LinuxOnUSB

Thank you

1 Like

Well I don’t understand why this fixed the issue but uninstalling Python v3 and installing 2.7 worked. The strange thing is that I tried running the portable before I installed Python at all and had the same issue.

Thanks for the help!

3 Likes

As long as your working :slight_smile:

Thank you

It probably had to do with some library being missing. I’m glad it worked! Tracking down issues like that where there is no error message to explain what is going wrong can be tough!

2 Likes

Hi, I seem to be experiencing the same issue as OP, I have Python 2.7 installed though. I’m getting the exact same results when opening GC from the “Launch Ground Control Shortcut” (black box, white box in the middle. Any suggestions?

image .
image