Ground Control Loads G Code tiny/small

When I load my G Code into GC the file comes incredibly small compared to the size that I created it in VCarve Pro, roughly 1/10 scale. I have used Vcarve and GC in the past successfully without the miniaturization. I used a couple different post processors and I ended up with the same result. I have tried using GC 1.17 and 1.18 and the same result.

Can you post the Gcode?

Thank you

2 Likes (68.9 KB)

It’s not clear what prtogram was used to create the gcode file, but it doesn’t have any lines at the beginning to declare whether the measurements in are metric or inches. If they were supposed to be large circles in inches, add this at the beginnoing of the file using a text editor (Notepad, TextEdit, etc):

G90 G20

Here’s what I get with that change:


Thanks, that seemed to work. Not sure why Vcarve is not adding that line at the beginning of the file. Appreciate the help.


I believe it was Vcarve Pro - Vectric, as in Vectric LTD a UK company, it has post processing in Inches and MM but they instruct many to us MM only. The fact it’s “off” by a factor of 10 sort of says metric system. Nice work @blurfl too.

Thank you