Ground Control message continually toggles from "Connected" to "Not Connected"

Gary,

You have the Firmware installed? It’s just loading GC that is an issue?

Thank you

yes, now I’m trying to load gc

Can I call you?

Thank you

sure if you don’t mind

go here:

https://www.disciplesofcnc.com/wiki/pmwiki.php

please

All,

I helped him using the single file installer from my website. He is now up on 1.09 - Connected on com3.

@garru2 Has to finish his build to be ready to make the test cuts.

We will get him up to V 1.10 shortly.

He was running into file name length errors for his user directory. Because my installer uses c:\maslow we bypassed the issue.

You can read about it here:

https://www.disciplesofcnc.com/wiki/pmwiki.php?n=Site.WinMaslowSetup

Thank you

1 Like

Dude, I am having same problem. Pulling out my hair after going thru all the work to assemble. Comforted that ur system now works. Did u delete old progs and start over? What versions of software did u use? I am using Win 10 laptop.

This usually means that either the firmware didn’t upload successfully or the COM port is not right. Did the firmware upload process go smoothly?

Thank you so much for responding! Finally got it to work!!! Problem was (hard to explain) Arduino exe? was not the same one as in the firmware 1.18 file. when I first downloaded it it was not blue or exe. so a friend sent me a copy of his which worked but apparently not with new updates?? so redownloaded the whole file again and now the Arduino file was blue and exe able. Used that one to upload Arduino with success, closed prog, opened ground cntrl and bam! it worked!!! now for the painful calibration process. Plus router needs fix now. When I released the chain the weight of sled and bricks was more than expected and it swung out, crashed into wall and busted. Haha. Good times!

1 Like

Update: Calibration went well! Now i’m cutting amazing things!!!

5 Likes

I am having same problem with connection to GC, it worked great yesterday on my first day

please look over this thread -

Thank you

1 Like

Hello there.

I am having the same issue for a couple of days now.

Initially it worked but it was getting disconnected and loosing calibration all the time.

Now it will not work at all.

Some help would be greatly appreciated. thnx

The very first thing to try is a shorter USB cable, that can solve the issue for a lot of folks. If that doesn’t work then I would look into adjusting where the USB cable is routed and try to determine what is causing the disconnect. Is there something else in the shop near to the USB cable like a vacuum which could be causing trouble?

I’m having the same or a similar issue. The cut gets interrupted and the message tells me that the arduino has lost connection with my computer and that it might be a USB issue. However, everything is connected fine.

How far away are you asking about? I use a sander and another router about twenty feet away on occasion. I’m using the USB cable that the arduino comes with so I’m presuming that isn’t my problem… I’m also presuming the router that I’m using with the Maslow isn’t the problem … is that a fair assumption to make?

Thanks

When Ground Control (or webcontrol for that matter) toggles from Connected to Not Connected, it usually means one of two things…

  1. The com port is wrong and the software is establishing a connection with some other device and then breaking that connection when it realizes it doesn’t respond properly. A few seconds later, it tries to connect again (to the same com port) and the process repeats itself.

  2. The arduino has lost its programming… The computer connects to it but the arduino isn’t running the firmware and doesn’t respond properly to ground control so ground control disconnects and tries to reconnect… repeating the process.

I’ve been using the same port on my laptop for weeks, so I don’t think #1 is a problem.

How does the arduino lose its programming - is this a permanent problem or a random problem?

thanks

It’s one of those things which can be pretty magic. I found one corded power drill which if I used it anywhere within about 20 feet the connection would drop, but only with that one drill AND only if Hannah’s computer was controlling the machine, my computer was find. I can’t tell you exactly what the combination of things which is causing the issue is, but knowing the kinds of things to look for could help

  1. The arduino IDE is still open. Forgot about this one. If its open, they could bounce back and forth grabbing the comm port. Close the IDE if it is.

Check and make sure the comm port didn’t get reassigned…

Don’t know, more of a speculation on my part because I’ve seen the connect/disconnect with an unprogrammed arduino.