Can not calibrate machine

The best I have been able to do is test the motors and get the left to rotate when I get a connection timed out error. I am so lost!

1 Like

That sounds very frustrating!

‘Connection timed out’ signals a problem with the USB connection. Here are some things to try:

  • Are the ends securely plugged in? (don’t forget the USB extendsion cable connector)
  • Is it better without the USB extender cable? (this can be troublesome to test, but informative)
  • Is there a different USB connector on the computer to try?
  • Make sure that the Arduino IDE program isn’t running, it can ‘steal’ the USB port…

If these things don’t help, tell us about the computer and the operating system you’re using. Let’s get you up and running!


Which port is the power plugged into? The Shield or the Arduino? Do you have another USB cable you can try?

You want the power plugged into the Shield.

Thank you

1 Like

Thank you guys for your assistance!

So here’s the deal. I was able to get the right motor to turn as z-axis, so I know it works at least. I tried a different USB cable and every USB port on the laptop. I also have the power plug into the motor shield. Ground control only seems to have an issue when it test the left motor and then tries to test the right motor then I get the “connection timed out“ error.

Laptop is an HP that I use at work.

I also have a dell laptop I’m using too, but having the same issues.

1 Like

Quite probably unrelated, but I was suffering repeated Connection Timed Out issues after the latest update to firmware and GC. I ended up redownloading, reinstalling and that resolved the issue.

Try loading the blink sketch to the Arduino then Uploading the firmware again.

Thank you

I uploaded the Blink software and got the blinking amber light as expected. I then uploaded the firmware and continue to get the same “connection timed out“ error. I am using v1.06 of the firmware and GC.

Please try 1.04 -

Let us know if you see the same connection issue

Do you have any previous experience with Arduino?

Thank you

I did a fresh download and install of firmware v1.06. Same issue. I tried it with v1.04. Same issue.

I have no experience with Arduino, this is my first one. Sorry, but you guys have another noob on your hands. :wink:

1 Like

Just so I understand, if you run GroundControl, and without clicking anything you just watch, does it get to ‘connected on port COM3 … ready’ and stay that way, without the ‘connection timed out’ error? Or does the timeout message pop up even if you’ve not done anything?

Windows folks, how does GC behave with the wrong version of pyserial? Maybe that’s not an issue with the Windows GC package?

This is the Windows portable package. It has everything rolled into it. I will try to find a good Arduino demo with a serial console output. This would be a way to test the serial connection. I will a wait answer to “if you run GroundControl, and without clicking anything you just watch, does it get to ‘connected on port COM3 … ready’ and stay that way, without the ‘connection timed out’ error? Or does the timeout message pop up even if you’ve not done anything?”

Thank you

How connected to the motor rotating is the issue? Does it stay connected as long as you don’t try to make the motor turn? Could we be seeing an issue with the board or the Arduino itself? We’re more than happy to send you new ones if that seems like a possibility.

Sorry for the trouble!


Thanks for your patience everyone, it was back to work today for me. I just powered up the board and plugged the USB into the laptop, then I opened ground control and it performed as seen in the picture without me doing anything or touching it. It remained this way as long as I didn’t “mess” with it.

1 Like

After five minutes, GC

was still connected and I went to actions, test motors… And got this.

Oh, It stayed connected this time after the “connection timed out” but often I have to unplug the USB and plug it back in or manually reconnected through actions, connect.

This is for the Arduino uno R3. It is applicable to other Arduinos. Where are you located?

Here is article on the serial Monitor -

There is a program under Examples - Basics -> ReadAnalogVoltage
It should output to the serial monitor.

Thank you

I think there is a chance that something is wrong with one of the motor driver chips. It seems like a long shot but that’s the only thing I can think that would describe this behavior.

If one of the chips was faulty internally it could be shorting or doing something strange when you command the motors to turn which would trip the Arduino’s internal circuit breakers and drop the connection.

Its a long shot, but I think it’s worth investigating. If you send your address to we’ll send you a new shield and Arduino so we can eliminate that possibility


I followed the instructions, on both laptops, for the loop back test and got this. I could not read anything and it scrolled so fast even after I turned autoscroll off I really couldn’t make heads or tails of anything.

One more thing, I had TX0 and RX0 jumpered and ran the serial monitor. But, I also pressed reset and held it as well. This stopped the scrolling and allowed me to type commands which was echoed on the serial monitor screen. As soon as I released the reset button it resumed to scroll manically and would not allow me to type any commands.