GroundControl showing gcode funny

Hey everyone!
So I’m working on creating some tables from OpenDesk for our makerspace, and after spending the time to CAM it properly I’ve noticed that GroundControl doesn’t want to display the gcode properly. Apart from the fact that the CAM’d Gcode is roughly 8mb, there’s something else I can’t put my finger on that’s wrong with it.

While I might be ok, it’s one of those things where’d I’d prefer not to potentially cause damage to a full sheet of plywood (or our maslow) if I can help it.

Anyone have any ideas? I’m including the workspace from LaserWeb as well as a screenshot of GC. Thanks!

PS this is zoomed super far out, such that the actual grid section is at the end of the segment on the right.

@jeffersonbenson Welcome to our group. To better assist you,

What CAM program are you using? What Operating System is on your Computer?

Thank you

Hi! I’m using Laserweb on Ubuntu (definitely should have included that part).

1 Like

Have you tried MakerCAM?

Have you seen the tutorials here on using it?

Thank you

I have. I remember having an issue with how my source files were rendered, and that it was a tad clunky. Is that right now the best option for CAM?

I have zero experience with Laserweb. Anyone else have experience with Laserweb? I have used MakerCam. It’s sort of a default here.

You can test the file outside Ground Control here.

You could try google - g code simulator

Here are the first two results;

What model of PC are you on? What processor?

Thank you

I’ve used NC viewer several times for different projects and it’s been good enough for my needs. Even after running the g-code from Laserweb it looks just fine, but there’s something about importing it into GroundControl that has it mess up.

My only going theory is that because Laserweb has a lot of segments in how it draws a path, GroundControl can only read so many of them (there’s a popup when you launch the program which confirms this), and thus is a bit messed up.

As far as hardware, I’m actually using a Surface 3 (non-pro) which has a Quad-Core Atom processor in it.

I work with many of the atom processors. I believe there are utilities on the web to optimize g-code. That might help. Anyone else have input?

Thank you

There’s a 60,000nline limit to what GroundControl is able to display, though it will cut a bigger file. Is that the pop up you’ve seen?
Consider dividing the work into several pieces with a separate file for each to stay under that limit. If you use the same 0,0 home position for all the files, you can load and cut them sequentially and not lose registration.


Indeed that would be the popup I’m getting. I can try to break it up into different groups. Hopefully that’ll make it behave

1 Like

So doing just a bit doesn’t seem to be working, only changes the shape of the squiggle. Does GroundControl expect inches? All of LaserWeb is in mm.

I thought it sounded like that. :grin:
You’re exploring one of the frontiers of the Maslow, where the limits of cutting speed intersects with the intricate detail that some CAM programs produce. It can take a router a long time to make 60,000+ cuts. It will get there, though.

The .nc file will have a gcode to set the appropriate format. When the file loads, GC should put itself into the format that the file is written in.

How do I go about getting a .nc file? All I get from Laserweb is a .gcode file.

Same thing, different extension. Use a text editor (or less) to look for a G21 gcode near the top, that sets mm mode. G20 does inches.

1 Like

Yep G21 is definitely there, right on line 1 as a matter of fact. So if Ncviewer is reading it fine, and the gcode looks decently ok, what else could there be that would cause GroundControl to not behave properly?

there is no standard extension for g-code, some software uses .gcode, some .nc,
some .NC, some .txt, etc

they are the same.

look in the top of the file for G20 or G21 (IIRC)

1 Like

I get the same funny lines testing the code. I changed the G91 in line 2 to G90 and got this:
Does that look more like what you want to cut?


That definitely looks better. I guess I just assumed since there are no endstops on Maslow that the position would be relative. There appear to be some parts of the cut missing, but that’s more likely the line limitation of GroundControl.

Is there anything special that needs to be done in order to get the rest of the cut to go through? I don’t necessarily need the preview so long as I can see the code flow.

From previous huge files, I heard that Maslow will cut through. Only the display is limited. However, a file as big as your has not been tried as far I can tell. You are exploring untested ground.
I’ll let it run overnight in the GC-simulater and check first in the morning an again when I come back from work :slight_smile:

1 Like