Maslow Home Maslow Community Garden Newsletter

Have not been able to even get through the setup

Arduino: 1.8.9 (Windows 10), Board: “Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)”

Sketch uses 58370 bytes (22%) of program storage space. Maximum is 253952 bytes.
Global variables use 2026 bytes (24%) of dynamic memory, leaving 6166 bytes for local variables. Maximum is 8192 bytes.
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
An error occurred while uploading the sketch

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

This could be an issue with the COM port selection. If you unplug the Arduino do you see the COM port option you are using disappear from the list of options?

No even when i plug the Arduino in it doesn’t show up as connected to my pc at all in device manager or anything. It only has one option that being com port 1

That sounds like the issue to me, I think we should start figuring out what is going on there. Good debugging to check device manager. COM1 is almost always some sort of built in thing which is always there so I wouldn’t expect it to be that one. Do you hear a noise when you plug it in or see an unrecognized device in the device manager? It could be a drivers issue.

No i don’t see anything or hear anything when I plug or unplug the device for my PC. The only thing i see is a light come on from the arduino

1 Like

That’s good, at least we know the arduino is getting power.

Do you by any chance have another computer you could test on?

One of the usual fixes is to try another USB cable, seems common to have a broken wire

No unfortunately not. I have been trying everything to trouble shoot it all night but no luck.

Hi and Welcome,

Reach out to other locals with a computer if possible to test out, and don’t get discouraged, it took me hours to get webcontrol to work and even then I’m still not sure how I did it.

Test other ports, on my Mac for some reason it ground control would only work on one USB port. You migth have tried this already but just in case you haven’t

You will succeed.

1 Like

I have tried 2 other ones same result

The next thing I would try is to uninstall and reinstall the Arduino IDE. Sometimes if the drivers don’t install properly the Arduino might not be recognized. Who did you get your kit from? It might also be worth asking them to send you another Arduino. If we can’t test with two different computers, maybe we can test with two different Arduinos.

I thought that’s what it might be but I have removed all the software and reinstalled all the software more than once. With still no luck. I have tried installing drivers separately no matter what i do or have tried it is like the arduino is powered up but dead.

Can you send a picture of your controller board? How old is it? Where did you get it?

If you open device manager after booting with the Arduino unplugged, when you plug the Arduino in do you see the Device Manager update?

Do you have another computers where you are working on this?

Thank you

Yes i can upload a picture of it, i received it from maker made where i ordered the complete kit from. It is brand new i just received it about 3 weeks ago, this is the first time im setting it up.

Unplug the shield from the Arduino. If you plug the Mega USB in with no shield do you see a comport in Device Manager?

Thank you

Try removing the blue shield from the Arduino and then see if it shows up. A faulty shield can prevent the Arduino from turning on.

If that doesn’t work, I would ask them to send you another Arduino. I’m not sure if the issue is on the Arduino side or the computer side, but having a second Arduino would let us know for sure. You’ve put a lot of time into testing already, and Arduinos aren’t that expensive

When i unplug the shield and plug in the mega usb it still shows up as com1 but still does nothing. I unplug it it still shows up in device manager as com1.

I think I would ask @makermade for a replacement arduino at this point. They sometimes come bad, it’s rare but possible.

I did reach out to him sunday and again yesterday, im still awaiting a reply.

1 Like

If you don’t want to wait for a response something like:

Would be a drop in replacement for $15

1 Like