Please help , problems uploading to arduino

hi ,
I have a problem in groundcontrol were it says connected then connection timeout. tried to upload firmware but get the timeout error in Arduino ide as well. tried to blink the Arduino as well but cant get anything to upload .any ideas?


What OS are you on? What make of PC. Have you tried a diffrent port, diffrent cable, turning it off and back on again?

Thank you

Getting ‘Blink’ to load is a good place to start. In the Arduino IDE, in the Tools menu, find ‘Board - Arduino/Genuino Mega or Mega2560’. That should also cause the ‘Port’ setting in the Tools menu to locate your Mega2560 board. Try uploading the ‘Blink’ sketch. If it works (done uploading), look in the Tools/Ports menu to learn which port your board is connected to, and then upload the firmware and in GC set that same port in Actions/Ports.
There is a more detailed instruction here, if there is a way to improve that, this is a good place to discuss it.


I am using windows 10,with a Toshiba laptop I have tried other ports , and also cutting it on and off several times.

In device manager what do you see under Com&LPT. Can you send a screen shot?

Make sure the Maslow power is plugged in to the shield and not the Arduino.

Thank you

as in device manager in windows?

It says " usb serial device com3 "

Make sure you’ve exited GC before trying to upload. GC will seize the port.

I have exited everything, not able to get anything to upload.

I do know in the past that people have reported problems with their usb cables. Have you tried a different cable?

I have, but at this point I will try again.

I have noticed that I have two leds lit up, a amber one and the green one. is normal for the amber light to stay lit?

Mine are both green (it appears to me). My board is about 1 year old, so not sure if there were any changes made.
Sorry, didn’t read it well enough… I’ll have to check on the amber one… I think its normal to stay lit

I have two green on my shield, and 1 green and 1 amber on my Arduino.

Have you looked at this thread?

I have. not really getting me anywhere.

Is this the first time you’ve tried to use the controller or have you been using it for a while? I’m not sure I can be much more help… Perhaps connect it to a different computer and see if you get the same results?

that was ganna be my next move

Let’s try this -

Down load coolterm -

remove the shield - reboot

Try connecting to com3 with baud rate set to 115200.

Can you connect?

Then try closing coolterm and uploading the blink sketch.

Tell us what happens?

Thank you

Ok after installing cool term still not uploading anything. Still have not been able to try on another console yet to eliminate usb conection will try that this evening.

1 Like