Help with 5 cut calibration

hmmm… I don’t remember getting spacers… but maybe I did and didn’t know what to do with them (was a long time ago). Anyway, assuming they are insulating then that shouldn’t be an issue. If you aren’t giving up completely, can you post some pictures of your frame, cable routing, controller, computer, etc… Maybe we can spot something.


@madgrizzle, I sure can when I get home from work. Yes mine came with 4 little white plastic spacers to mount it away from wood and not push solder on back of board into frame I guess and maybe cooling purpose.


Or try a different Mega. Perhaps something faulty on the board


@Gero, they are both new. The original boards quit working and they sent me new ones. We was hoping that was the issue. I bought a brand new laptop at lunch today, gonna give that a try along with mounting arduino on wall instead of on frame. I still don’t understand why it cut the 5 cut measurement zig zag like it did. 3 time’s in a row. I don’t think laptop would cause that. Like a gc issue is what I’ve been thinking. But I uninstalled it and reinstalled several times along with arduino. The 19 update kept crashing when installed but I started 18 then closed it and opened 19 and it seemed to fix it, doesn’t crash after I did that. I don’t know what more I can do. I’m up for suggestions and gonna try them all.

1 Like

Something strange going on. Did they recently set up a mobile phone antenna on your roof? Do you live close to a radio station broadcasting over the country? Are you living close to a facility experimenting with EMP?
You have ruled out everything else :frowning:

Edit: would a faulty or loose encoder on the motors cause a zig-zag like that?

1 Like

If you are up to it: With a spare Mega with nothing attached (no motor shield), before uploading the firmware, edit the Config.h and remove the // in front of #define FAKE_SERVO. This enables a fake run.
Run a file in GC and see if you still have the connection dropping with nothing else in the workshop running. If not, turn on 1 by 1 router and vac and see if that causes the drops to come back.


@Gero, no nothing like that around me. I live out in the sticks away from everything. Lol I’m not tech savvy enough to edit the files. I’d prolly have it way worse if I tried something like that. Lol


@Gero and I looked at all connections and everything is tight and wires are all in connectors tightly.


So I just read through all of your issues and I am sorry to hear that, it sucks! I have 2 maslows and both have had different issues of their own. Partly/mostly brought on my myself trying to update or make it better.

However, as you were talking about your issues and how long those cuts are. Have you tried to split them up into smaller length cuts? Like, I will do a carve as one and then upload new code to cut out the item I carved, etc. I know at one point I had some kind of problem with too much code I think and it bogged something down somewhere and I about lost my mind. I think in that case I was able to go back, edit the cut and start where it disconnected or at least close.

I also know that occasionally mine will still give me little gremlins and think my home is like 50 feet of of where it is. But once you learn what the nuances are for your machine I hope you can work through them all and make something cool.

Final note, do you have a picture of that first project you did, I am so curious!

1 Like

@ChrisB The only issue i had on it is the bit was too big to cut the center of the a’s. I’ve tried the updating gcode and it’s made my cut go off. I’ve also tried the breaking up the gcode and have had worse issues with it. I kinda stepped away from it and moved on to my X-Carve and have had not one issue with that. I’ve run really really long code and it’s completed project. I can cut simple items on maslow that finish fairly soon. Now I’m having the router pop out and bit dragging, so I’ve done the fix with bushing glued to it but have not tried it since i fixed it. I also bought stuff for auto z-axis, but haven’t installed yet because i can’t get a definite description on how to program it. Im not that savvy to enter numbers in program and i think people on here don’t wanna go into long explanation or pics on how to do. I’ve read all the info on here about it but still kinda lost with it. So as i said i moved on to my X-carve. As i can probe on that and don’t have any issues with bit changes with it either. I would love to get Maslow up and running as good, I just need more help on the auto z and the programming the button to run auto z. Thanks for your reply.


Got the Auto Z wired up and working great and the bushing and washer on the screw is holding it level. Started a project and had a bit drag about half way through!! :thinking::face_with_raised_eyebrow:

That is awesome that you got the Auto Z working, I am looking at doing that very soon for my personal maslow. Just got the new Z axis motor working that will make it faster!! WOOO!

I have had a similar issue a few times when I either did not have a high enough safety height or I had a couple pretty bowed pieces and they scraped there.

Finally, I thought I had responded but man that looks awesome!!

@ChrisB This is one i just finished for a friend. I did it on my X-carve though. Filled it with epoxy with pigments and then clear epoxy over that. You got a link to that z motor upgrade for parts? I’d like to do that as well, it’s so slow and really adds a lot of time to the job. You will like the auto z feature. So much easier, especially with bit changes. My bit drag was a gcode issue i think. It didn’t even try to raise bit, i was watching when it did it and i pulled sled up, but it was too late. Lol :confused:

That looks awesome. Here is the link to the whole forum (If you have some time for reading) Then here is alink of the motor that I purchased off of amazon, I think my first one was just a bad encoder. But I would suggest just cutting off their plug, do not try to do what I did and un-solder from the encoder.