Maslow Home Maslow Community Garden Newsletter

What firmware do I need?

I get this screen when starting up the newest version of Makerverse. Does anyone know firmware update that I would need and how to do it?

classic Maslow with an Arduino Mega? or Arduino Due (like M2)

A summary of the beta thread and a couple others will lead you to the mega firmware or the due firmware to get the latest and greatest firmware required.

I have the due. I found the file I just don’t see any way to download it and install it.

  • click the code button

  • then download the zip

  • extract the zipped file (don’t click into it)

  • open the .ino file with the arduino IDE

  • Plug Due into your computer with the PROGRAM port (the one closer to the middle of the board)

  • install the avr 32 bit boards in arduino IDE
    if you don’t have Arduino ARM as an option, click Boards Manager instead and install Arduino Arm

  • select the board as the due and the programming port

  • Select the proper port where your due shows up

  • press the right arrow at the upper left of the arduino ide to select Upload. It will take several seconds to compile and then upload the new firmware to the due. then try again.

1 Like

Thank you for the very good directions. Everything seems to go well except when I open up makerverse, I get the same screen.
Sorry to be such a pain. I just can’t figure out what is wrong.

I gave the workspace a name and it fired up. I think I may have it fixed. Thanks again for you help.

3 Likes

Glad you got it working!

After having some time to take it back to my shop and hook it up to my machine. I am frustrated beyond measure. I was able to set up a workspace but I am still getting a message that it does not recognize my board firmware. I have updated the firmware as instructed. Here is my workspace:


I can move the sled around with the x and z moving fine. the y travels about 5 times more than selected. When I choose 1mm it moves 5 to 10 mm. I don’t have a homing button anymore nor do I get any machine settings showing up in my console.

do you have the 100 rpm metal maslow motor? if so, I have some settings for you to change.

FYI I just updated my firmware and it says it needs to be upgraded, but it doesn’t so let that one go for now.

How do I know what motor I have?

EDIT: X is left and right and Y is up and down on the plywood sheet. Z is the router bit moving toward and away from the sheet. Which axis isn’t working?

There is no home button anymore.

So I went back to makerverse 1.0.6. I am able to set home and it will find home when I hit the home button. I try to upload a gcode and it show fine on the screen but when I try to run it, the sled just heads straight up. Could there be something wrong with my board? It has not worked right since the day I started it.

There was a guy who had the same issue and his sled ring got all mangled when he didn’t stop it in time. If I remember correctly it happened when his PC when to sleep. Others have said that unplugging and re-plugging all cables helps.

double check your shield is plugged firmly into the controller board (two boards well connected) and all cables are fully seated. If that all works and you can shuttle the sled around, but the gcode doesn’t work, then you need to look at the gcode.

I checked all connections. I can move the sled around and it will find home. I think the math is somehow off. My Y axis is way off. I tried the calibration in the version 1.0.6. I tried an 8 in by 8 in square. It came out tilted about 30 degrees to the left and was 11.25 in by 16.75 in. I put the numbers in the calibration fields and it looked like it did appropriate math for the x axis but the Y increased by a factor of 20 to something like 20.56. When im moving my sled around manually, i can choose 1mm and x goes 1mm. If I choose 1mm and move y it goes more like 15 mm. I updated to 1.1.0 and tried again, and the Y is still screwed there. Not sure where to go with this. I also noticed that If i change to in instead of mm. My y goes crazy and is not even close.

I reset everything. Firmware on board, makerverse, checked connections, and finally got it acting more normal. My cuts are still tilted. If I do one in the middle it is better but still slightly tilted. I tried a 36 inch x 12 in “thankful” sign today , virtual. It did a nice job on several letters (slightly screwed) but nice. When it got to the H it started then stopped and would not move again. I homed it and started again. Perfectly did all the same letters again until it got to the H stopped at exactly same spot. I went to easel and took completed letters out exported guide and tried again. It will not do the remaining letters. Any ideas?

Is it a G02 or G03 command with an R in the line? Any idea what gcode line number is failing? Can you share your gcode?

I went in to easel and took the letters off that already worked and then generated gcode. I homed router and started it again. I went to the H and started again then stopped . I have attached the picture of makerverse and the gcode.

Thanks
chris

thankgcode.txt (44.7 KB)