Maslow Home Maslow Community Garden Newsletter

Holey Triangulation Calibration Error

I was attempting to test the Holey Triangulation Calibration but I’m getting hung up when I click Holey Calibration. By hung up I mean, GC closes. Any Ideas?

Kivy Log
[INFO ] Logger: Record log in C:\Users\patri.kivy\logs\kivy_19-08-18_3.txt
[INFO ] deps: Successfully imported “kivy_deps.glew” 0.1.12
[INFO ] deps: Successfully imported “kivy_deps.sdl2” 0.1.22
[INFO ] Kivy: v1.11.1
[INFO ] Kivy: Installed at “C:\Python27\lib\site-packages\kivy_init_.pyc”
[INFO ] Python: v2.7.10 (default, May 23 2015, 09:44:00) [MSC v.1500 64 bit (AMD64)]
[INFO ] Python: Interpreter at “C:\Python27\python.exe”
[WARNING] Deprecated: Python 2 Kivy support has been deprecated. The Kivy release after 1.11.0 will not support Python 2 anymore
[INFO ] Factory: 184 symbols loaded
[INFO ] Image: Providers: img_tex, img_dds, img_sdl2, img_pil, img_gif (img_ffpyplayer ignored)
[INFO ] Window: Provider: sdl2
[INFO ] GL: Using the “OpenGL” graphics system
[INFO ] GL: GLEW initialization succeeded
[INFO ] GL: Backend used
[INFO ] GL: OpenGL version <4.5.0 - Build 23.20.16.5044>
[INFO ] GL: OpenGL vendor
[INFO ] GL: OpenGL renderer <Intel® UHD Graphics 620>
[INFO ] GL: OpenGL parsed version: 4, 5
[INFO ] GL: Shading version <4.50 - Build 23.20.16.5044>
[INFO ] GL: Texture max size <16384>
[INFO ] GL: Texture max units <32>
[INFO ] Window: auto add sdl2 input provider
[INFO ] Window: virtual keyboard not allowed, single mode, not docked
[INFO ] Text: Provider: sdl2
[INFO ] Base: Start application main loop
[INFO ] GL: NPOT texture support is available
[INFO ] GL: Unpack subimage support is available
[INFO ] Base: Leaving application in progress…
[WARNING] stderr: Traceback (most recent call last):
[WARNING] stderr: File “C:\Users\patri\Desktop\Holey GC\GroundControl-master\main.py”, line 512, in
[WARNING] stderr: GroundControlApp().run()
[WARNING] stderr: File “C:\Python27\lib\site-packages\kivy\app.py”, line 855, in run
[WARNING] stderr: runTouchApp()
[WARNING] stderr: File “C:\Python27\lib\site-packages\kivy\base.py”, line 504, in runTouchApp
[WARNING] stderr: EventLoop.window.mainloop()
[WARNING] stderr: File “C:\Python27\lib\site-packages\kivy\core\window\window_sdl2.py”, line 747, in mainloop
[WARNING] stderr: self._mainloop()
[WARNING] stderr: File “C:\Python27\lib\site-packages\kivy\core\window\window_sdl2.py”, line 479, in _mainloop
[WARNING] stderr: EventLoop.idle()
[WARNING] stderr: File “C:\Python27\lib\site-packages\kivy\base.py”, line 339, in idle
[WARNING] stderr: Clock.tick()
[WARNING] stderr: File “C:\Python27\lib\site-packages\kivy\clock.py”, line 591, in tick
[WARNING] stderr: self._process_events()
[WARNING] stderr: File “kivy_clock.pyx”, line 384, in kivy._clock.CyClockBase._process_events
[WARNING] stderr: File “kivy_clock.pyx”, line 414, in kivy._clock.CyClockBase._process_events
[WARNING] stderr: File “kivy_clock.pyx”, line 412, in kivy._clock.CyClockBase._process_events
[WARNING] stderr: File “kivy_clock.pyx”, line 167, in kivy._clock.ClockEvent.tick
[WARNING] stderr: File “C:\Users\patri\Desktop\Holey GC\GroundControl-master\CalibrationWidgets\computeCalibrationSteps.py”, line 27, in loadNextStep
[WARNING] stderr: self.readyToMoveOn()
[WARNING] stderr: File “C:\Users\patri\Desktop\Holey GC\GroundControl-master\CalibrationWidgets\calibrationFrameWidget.py”, line 376, in loadNextStep
[WARNING] stderr: self.loadStep(self.currentStepNumber)
[WARNING] stderr: File “C:\Users\patri\Desktop\Holey GC\GroundControl-master\CalibrationWidgets\calibrationFrameWidget.py”, line 402, in loadStep
[WARNING] stderr: self.currentWidget.on_Enter()
[WARNING] stderr: File “C:\Users\patri\Desktop\Holey GC\GroundControl-master\CalibrationWidgets\adjustZCalibrationDepth.py”, line 24, in on_Enter
[WARNING] stderr: if int(self.data.config.get(‘Maslow Settings’, ‘zAxis’)) == 1:
[WARNING] stderr: ValueError: invalid literal for int() with base 10: ‘0.0’

1 Like

Well, it’s choking on your setting for Z-Axis. For some reason the value is ‘0.0’ and it’s supposed to be an integer (i.e., ‘0’ or ‘1’). Python int(‘0.0’) fails and stops the program from running.

Do you have a z-axis kit? If so, enable it in settings and see if it clears up the problem. I’m curious as to how you got a 0.0 there though.

1 Like

When you loaded groundcontrol for the first time, it went through and synced ground control settings with the firmware. It gives you an option as to how to sync (either use groundcontrol.ini setting or what’s in the firmware) Is it possible you selected to use what’s in the firmware? If so, that could be how the setting got written with a 0.0.

I think I did select firmware.

Sorry about that, I just enabled zaxis and it’s working now. :roll_eyes:

I went through the settings 10 times looking where zaxis was set to 0.0. Never even noticed z was disabled. Thanks for the help

2 Likes

Well, you found something that needs fixing… great job!

1 Like