Open GL 1.1 error Oh great, wise and powerfull programmers - please help

Can you help make a test version of Ground Control that doesn’t check for open GL 2?

Here is the deal - lots of detail to follow.

Me and @Balls have the same modle laptop, same OS

  • I have found a diffrence - Mine has 2 video cards and High Resolution Display

checking his PC he has open GL 3 , Kivy reports it only sees open GL 1.1

This is only seen in Windows with Kivy

Research links -

Lenovo T420 windows 10 - Intel HD3000 Open GL 3 Direct X12

1366 x 768 32 bit display - no other display modes offered

Latest drivers installed with the Decemder 2018 Windows Creators Update

when launching Windows Portable

An error says you must have Open GL 2.0

Open GL 1.1 detected - Generic driver ending program

in the users directory

edited the .kivy/config.ini

set multisamples = 2 to multisamples = 0

added a system variable KIVY_GL_BACKEND = angle_sdl2

This didn’t work so I installed everything to run form source

Plus this -

pip -m install kivy.deps.angle
set KIVY_GL_BACKEND = angle_sdl2


added 2nd line

Config.set(‘graphics’, ‘multisamples’, ‘0’)

saved as

it returned the following –

[WARNING] [Config ] Older configuration version detected (14 instead of 19)
[WARNING] [Config ] Upgrading configuration in progress.
[INFO ] [Logger ] Record log in C:\Users\aftac.kivy\logs\kivy_18-01-07_10.txt
[INFO ] [Kivy ] v1.10.0
[INFO ] [Python ] v2.7.14 (v2.7.14:84471935ed, Sep 16 2017, 20:19:30) [MSC v.1500 32 bit (Intel)]
[INFO ] [Factory ] 194 symbols loaded
[INFO ] [Image ] Providers: img_tex, img_dds, img_sdl2, img_gif (img_pil, img_ffpyplayer ignored)
[INFO ] [OSC ] using for socket
[INFO ] [Window ] Provider: sdl2
[INFO ] [Window ] Activate GLES2/ANGLE context
[CRITICAL] [Window ] Unable to find any valuable Window provider.
sdl2 - RuntimeError: Could not load EGL library
File “c:\Python27\lib\site-packages\kivy\”, line 67, in core_select_lib
cls = cls()
File “c:\Python27\lib\site-packages\kivy\core\window\”, line 140, in init
super(WindowSDL, self).init()
File “c:\Python27\lib\site-packages\kivy\core\”, line 899, in init
File “c:\Python27\lib\site-packages\kivy\core\window\”, line 269, in create_window
self.fullscreen, resizable, state)
File “kivy\core\window_window_sdl2.pyx”, line 142, in kivy.core.window._window_sdl2._WindowSDL2Storage.setup_window (kivy\core/window_window_sdl2.c:2752)
File “kivy\core\window_window_sdl2.pyx”, line 57, in kivy.core.window._window_sdl2._WindowSDL2Storage.die (kivy\core/window_window_sdl2.c:1868)
[INFO ] [Text ] Provider: sdl2
[CRITICAL] [App ] Unable to get a Window, abort.

attaching (30.2 KB)

I’ll take any input I can get on this.

Thank you


KeeWeeUsr noted you may need to set your env paths.

What you may try with the current distribution before trying a non-virtualenv one is this:
echo %PATH%
if there’s no C:\Windows\System32 (that’s where the `opengl32.dll" and other important libs are) in there, do this:
set PATH=C:\Windows\System32;%PATH%
if there is that path, do this:
to show all env vars and look if anaconda doesn’t use some special path for its libs. Then just run it.


it’s in there -

Path %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\
PSModulePath %ProgramFiles%\WindowsPowerShell\Modules;%SystemRoot%\system32\WindowsPowerShell\v1.0\Modules

MySystemInfo.txt (468.5 KB)

I’m including the system info this came from.

Thank you

@Bee Did you find a solution to this? I have the same graphics card and am getting the same error


  • Tony

In the cases I’ve addressed, using linux on a stick fixed it. See my wiki about it here:

Let me know if you have questions.

Thank you


Hi Bee - I used your linux on a stick approach and got the error “this kernel requires an x86-64 cpu but only detected an i686 cpu. Please us a kernel appropriate for your cpu” - is the computer I’m trying to use too old?


It is 64 bit version. 64 bit CPUs have been in use for over a decade. You can try a 32 bit build from here -

you would need to install the base then the requirements like Kivey. I don’t have a 32 bit only CPU any where in my collection of 200+ computers.

But this is where i started to build the image from - I’m sorry it didn’t work on your PC - I will add notes that it must be a 64 bit CPU.

Thank you

1 Like

Puppy for some reason booted but wasn’t working right. I tried Debian which worked great but running Ground Control gave me an error about missing a Kivy log file. Maybe I use another laptop.

1 Like

@Bee you can probably test on a VM configured as 32-bit. I’m sure at least one of virtualbox, vmware, or xen will still have the option, if not all.

@engin if debian is working for you apart from a log file issue, I wouldn’t give up just yet. Follow instructions for installing the right kivy version on debian, and if it’s still not working, install strace and run ground control using it and the -FF option. That will log all system calls, including ones involving the log file in question, which will help narrow down the exact problem – possibly just a missing directory or bad file permissions.

HOWEVER, it could be that you’re getting LESS far on debian, and hitting this error BEFORE you get to OpenGL errors. So, solving it might not be the last of your problems. Either way, debian is a pretty solid base to configure as needed.

1 Like

Let me be clear on my stance - I don’t intend to support 32 bit.

“In 2003, 64-bit CPUs were introduced to the (formerly 32-bit) mainstream personal computer market in the form of x86-64 processors”

If you are on hardware >14 years old, I suggest buying a new computer. They are in the $50 - $100 range. $50 being some sort of referb or sale.

I could roll an image for 32 bit - I choose not to as it would take longer to do then it would to buy a replacement pc. The experience on a highend PC from 15 years ago would suck by todays standards and likely have another resource error. Plus the amount of energy to run a PC that old makes it counter productive. I’m saving on the CPU but giving it to the electric company.

So it is possible to support but it’s where I draw my line int the sand. This is just my opinion.

Thank you

Yeah, I think that’s a very fair position to take these days :slight_smile: Sorry, didn’t mean to push you into supporting a new platform, you just seemed to be interested in working on it for a moment there :slight_smile:


I love recycling and have a desktop similar age running a china 6040z with linuxcnc.
That thing just refuses to die.
You got pretty close, giving up just before the finish line?
Can’t promise I find the time soon, but am interested to put a debian in a 32 bit virtual box and see how far I get. What is the debian version you tried?



This started out with a report on a windows 10 new laptop where Kivy erroneously reported hardware was no meeting 1989 video specs. I was hoping there was a way to tell Kivy don’t run the check I will verify the hardware myself in that case. Not an option - The second was an older laptop 5 years approximately, it reported a much higher version of open GL maybe 3.0 but Kivy wouldn’t see it. At that point I dove into the coders reported problems and it’s a know thing without a good resolution - So I rolled a puppy linux image.

I have a full time job , business & work on and contribute to 4 projects similar to the Maslow & a family. I only have so much time.

If you get 32 bit to work on a 6040z it will be hard to get a current Arduino compiler to work there. So the ability to run but not update firmware points back to a diffrent PC. I also take the customer experience into account. How satisfying is it to pour 60-80 hrs into getting a partial solution running.

I appreciate everyone here. I just boil it down to what is practical when a $70 Pi3b+ rig is smooth sailing.

If you thought I was taking a dig at you I’m not. I’m just being honest on my opinion. I also know there is a RCA tablet for like $80.

You also might check my thread on “have a Latte” for a premium micro PC for a controller.

There are many ways to skin a rabbit.

& Gero I’m keeping my eye on you … LOL - Have a beer

Thank you

1 Like

Sorry Bee, I’m on whisky today :slight_smile:

Edit: An in a lucky situation running a Maslow without spending $80 that I don’t have.

1 Like

Hey - sorry to get everyone worked up here! I was just trying to re-purpose an old laptop in the garage knowing it would be piled on with saw dust. I used debian-live-9.5.0-i386-mate but honestly, it was the first time I installed Linux so I’m pretty clueless. I thought KIVY was another flavor of Linux but it seems it’s an addon to Linux.


We all started some where with Lunix. Worked up is good. Kivy is “twichy” it has an issue with random hardware. I would state it as, it may be possible to get that old laptop to work. If you have time to hack away at it I will say it’s gratifying to learn a new OS and go somewhere others haven’t yet. Please keep us in the loop.

Thank you

I found the time and can report that the 32 bit Arduino IDE to upload the firmware and GC will run on debian-live-9.5.0-i386-mate in a virtualbox in fake server mode.

I agree on the energy saving aspects and that mainstream should not be focused on 15 year old hardware.
Personally I got hooked to this project because of a spirit of helping, that I assumed to read between the lines. This feeling was supported with the POD for homeless
Because the consumption strategies of first world countries does not include how to deal with lead and mercury, we export our toxic garbage to third world countries.
Making a low cost CNC available to trauma release in areas where children need help is an idea that I will follow.
Running on old hardware should not be a reason for me to stop.