Inkscape templates

I think someone did that! It’s QCAD (QCAD - QCAD: 2D CAD) I’m not sure I read that specifically but enough of the menus are the same that I think there’s some inkscape DNA in there. QCAD will generate gcode too :wink:

1 Like

The release notes say it’s a fork from CAM Expert. That has a site but it redirect errs out on my mobile

1 Like

A newer version of FireFox may help. Or Chrome. I got it to run smoothly in Safari, so I think anything is possible. :smiley:

There is, however with daily build 0.17 from Git (has bugs and crashes) that I use. But you don’t need SVG from FreeCAD as it makes the G-Code direct for the Maslow (I choose LinuxCnc as post processor, it has GBRL as well).

The SVG needs some touch-up in Inkscape and the export is manly used for Tech-Drawings. Like this:

The path workbench will do (with limits) the direct Gcode for you. This is a screenshot of the same part:

This example is not for the Maslow, but soon it can be.
I am cutting prototypes in different materials with my Chinese 6040.

Edit1:

3 Likes

Thanks @Gero.

Looks like I need some patience. I’d like to stay with the more stable release (currently 0.16)
Last week i managed to create some gcode with it, But somehow I have forgotten how I did that…

O wait i did that on another machine… hmmmmm…

And:

Safari that’s Mac right?
Sketchup only has win and mac installers. I thought it was an online application.

@bar
I installed QCAD, it looks about the same as LibreCAD and to me it has the exact same non-intuitive issues, LibreCAD also has an option to export SVG specific for MakerCAM

1 Like

The Sketchup Make application only runs in Windows and OSX as far as I can tell. (I’ve never seen if there’s a Linux package but if there’s a Unix distro (OSX is Unix) then there may be one, I don’t know)

I’m speaking about my.sketchup.com which is a slightly hobbled version of Sketchup Make in an HTML 5 browser.

1 Like

LibreCAD, which I tried a few years back before becoming ensnared by 3D printers, is forked from QCAD. Forgot about it

2 Likes

ah there it is… well hidden from the searchengines :slight_smile:
however this gives me a blank page, firefox seems to be downloading something huge, it swallows up all the bandwidth but never finishes, i’ll try again when i’m on a DSL connection and see what happens there.

i’m still reading up on inkscape templates, still havn’t figured out if there is a way to fix the dpi resolution in the template

It is a fairly massive app. IIRC it took a good 5 minutes or so to load over 4G on my Priv. Still worked though I prefer to use a mouse over a touch screen.

I think DPI is saved with a document but I’m not sure it’s saved in document templates. Enough of us have been frustrated by this particular quirk, I think we would have stumbled on it. Or maybe not:)

Here’s a screenshot of a quick little model I sketched just now on my Blackberry (in Chrome).

The browser does need to be fully HTML5 compliant.

I’ve never tried with Firefox. You should get the Sketchup logo and “warming up the large Haddon collider” on the screen.

1 Like

Ive looked in the svg xml but can’t find anything that defines 72 90 or 96 values
this i why i’m now searching if there is a command of some kind that can be scripted, as it really seems to be an inkscape value outside of the svg,

if there is a command line option to change the dpi, and i stongly suspect there is, then it should be scriptable, and since it is possible to attach a script to a template. then that might solve it…

i still have hope to find a solution, but it also depends on my my limited command line skills. :slight_smile:
Once we have a template then future new users can just UTFT (use the f#ck’n template)

sketchup: i can’t afford to download the entire app once per day, that would cost more then an entire maslow with todays celldata rates, still going to try this option,

i also managed to save an svg from FreeCAD (i had to pad the sketch im part designer workbench to make it work)
chair
makercam.com isn’t loading either today, so i can’t try that step right now

so far so good, getting closer to a workable solution,
thanks for all the input guys!

1 Like

inkscap commandline stuff:

inkscape image.svg -e image.png -d 96 -C -wXXX -hXXX

not sure if this is the actual command i’m looking for

source:

1 Like

I made some progress by communicating with the folks over at Inkscape:

It turns out that it’s not possible to script the DPI stuff. And that most of the pain is caused by the complicated wording that makes up the SVG standard. And from what i understand now is that inkscape actually does things correct, but that other software packages don’t seem to use the actual document data to render the final graphic.

I’m still on the case to make templates that we can use with all the defaults set to be as CAD friendly as possible.

(as a result of all this the Inkscape template CD cover 300dpi is being filed as a bug, as it is simply false in what it pretends to do)

So, not the progress i hoped for but still positive that there will be a solution that will make things a little more easy in the near future.

1 Like

The people over at Inkscape told me that this is actually not the correct way.
This dropdown only sets the unit for the path that you are currently drawing. And NOT for the entire document.
The ONLY setting that sets the unit for the document globally is the one in the ‘Document preferences’
That sets a pointer in the SVG’s XML named: inkscape:document-units

If that unit remains to be set to px (inkscapes default) then document states that the entire document is in px. So this we would want to be in mm or inch. Meaning that i need to make 2 templates, one for Metric and one for Imperial units.
I’m very unfamiliar with the Imperial stuff and i try to stay away from it as much as possible, but in this case i will give it a try. (if it starts to mess with my mind i may reconsider…) :slight_smile:

3 Likes

Thank you for taking the time and doing this research right. Going all the way to talking to the Inkscape community and finding a bug for them is incredible. It’s been fun to follow along, and I’m excited to use the template

Your’e welcome.

It’s annoyances like this that eventually lead to greater things. We can’s all be doing that little extra step but in this case I could. As i was really annoyed by this. Partly due to the inconsistency between other softwares and partly due to myself being utterly confused by what was going on (and i’m still somehat confused as it is not clear why this is DPI stuff is messing with straight forward real world units)

The px setting of inkscapes default template is the first hurdle. And maybe even the biggest one for CNC purposes.

Then there is the default 96DPI
96DPI is now the default setting (this actually doesn’t say anything at all) but Ubuntu still has the ‘old’ 90DPI set as default in the 16.04 LTS release, so in that respect it will still annoy people until april '18 when 18.04 is rolled out, then this confusion will yet again annoy people that are not aware that this then changes for them with a 2 year delay. :smiley: So this will still come back and haunt us.
So hopefully a template can safe us from the straight jacket.

I hope all of this will be usefull for future developments. It seems to be important also when GC might be able to simply open an SVG and cut from there. One day… no pressure. :slight_smile:

1 Like

Yuck…

Today i was tinkering again to try and get my grey mass around it. And there seem to be a few nasty oddities at play. Inkscape seems to have a few bugs that battle with eachother to be the better bug…

At the ground of this is Inkscapes ‘Initial User Unit’ (px) That is a linked to the maddening 90PPI (or 96PPI) Depending on the version of Inkscape that you have installed (if you didn’t change these defaults)

Now i discovered that if you start with a clean page and change the ‘Document Unit’ OR use a default Metric template that most seems to go well.

But when you start drawing in Inkscapes default slightly crazy template with px as default, and then try to change that px to mm then all kinds of bugs start to fight with echother.

From the Inkscape Wiki:
In order to make this change, Inkscape walks through the document changing all length units it finds (or attempt to).

So if it can then it will if it cant then it won’t (the latter will leave you with untranslated values in the document)

Another scenario is when you open a svg that was created in another software that may present inkscape with ‘undefined’ values. Then Inkscape simply does not find in what unit the document was created. So depending on the creator this leads to all kinds of unknown’s that are not caused by inkscape.

This lead me to conclude that for CNC drawings it is best to ALWAYS change the Default Unit IN the Document Preferences to a REAL WORLD unit BEFORE you do start drawing

To make it even more awkward: Inkscape DOES have a Metric mm template, but there appears to be NO Imperial inch template… Thus the people who think they are drawing in real world Imperial, they are NOT! They are drawing in 90 OR 96 ‘pixianiums’ per Inch that will always lead to weird results whenever you open the document in other software.

Dear o dear, This really seems to be a facepalm issue…

300px-Paris_Tuileries_Garden_Facepalm_statue
If only Inkscape used a real world unit as default…

2 Likes

As I understand it Inkscape is a vector drawing program for making pictures with lots of special effects, and not a CAD program. I believe it’s easy to use add-on system is what made it popular for CAD, but it’s really watchmaking with a sledgehammer. Many flattened thumbs have been the result.

1 Like

Yes unfortunately Inkscape is not a CAD program.
But that many people find Inkscape far more intuitive then ‘any’ CAD program that makes the difference.

People new to CNC and new to making machines simply can’t do it all at once, and most CAD programs don’t have a ‘getting started’ mode. So that leads newcomers to resort to … Inky…

And that’s why i try to at least make that a bit less of a headache for the newcomers.

My first weapon of choice is FreeCAD (With its wonderful sketcher) but I still learning how to fly.

And since this px stuff annoys me I try to annoy it back until it fixes itself. :slight_smile:

3 Likes

I know this is an older thread but I just made some instructions on how to use Inkscape with Maslow. Hope it helps!

3 Likes