Maslow Home Maslow Community Garden Newsletter

Inkscape to Ground Control (gcode) with MakerCam Instructions

So I was playing around with Inkscape, a free illustration software, tonight and through some trial and error I was able to convert Inkscape files to gcode with MakerCam. Here is how I did it - if anyone has any different methods for doing this let me know.

  1. Open an Inkscape Document and then go to File --> Document Properties. I set up the document to be 4 by 8 ft (the size of the plywood) with measurements in inches. I find this template easy to visualize cuts.

4_by_8_set_up

  1. Next turn on the grid system (View --> Grids) and then drag guidelines (View–> Guides) to 48 inches and 24 inches to mimic the Ground Control setup. This helps even more with visualization as well. Draw whatever you like. I drew a circle for this demo. Also convert your object to a path by selecting your object and clicking Path --> Object to Path.

4_by_8_grid_and_center

  1. MakerCam doesn’t like inches or 4 by 8 ft files so when you have everything layed out in Inkscape you should resize to just the objects you want to cut and change all dimensions to pixels. Select your objects and go back to File --> Document Properties. This time select resize to selection and change all dimensions back to pixels. Now save your Inkscape drawing as a .svg.

resize_pixels

  1. Now go to MakerCam.com and open the .svg which you just saved. A note about preferences - the SVG Import Default Resolution should be changed to match the DPI settings in Inkscape. Newer versions of Inkscape should be 96 but to check this type shift+ctrl+p to get preferences in Inkscape and then click “bitmap” in the left column. Check out @Jamtek 's comment below for a screen shot.

maker_cam_preferences

  1. Set up your tools paths. Instructions on how to do so can be found here.

maker_cam_cuts

  1. Export to gcode with the instructions above as well.

My circle is north by about a foot for some reason. I’ll figure out why when I have some more time or I’ll just move the home point to compensate. I’m excited to try a cut with this method. Hopefully soon!


I did some testing to verify the the MakerCam importation scaling on Inkscape for my computer. Basically while cutting out a letter “N” just for fun I added a small 2" by 4" box in Inkscape. I imported at 96 px/in and 90 px/in and matched to the inch grid on MakerCam shown below respectively. 90 was the winner! It is an easy verification test for scaling. Note: Jamtek’s comment below is a much easier way to verify this :).

7 Likes

Thanks for taking the time to post this. But, I am curious what version of Inkscape you are running?
I am on the latest stable release 92.3 and it appears to still be defaulted to 96 dpi. Older versions had defaulted to 90 dpi, not sure when the change was made. I’m not refuting your findings but recent posts here and elsewhere give guidance to use 96 dpi.

BTW, version 92.3 also reports it has Bugfix for DXF output and Windows vector print scaling for documents with a custom view box (Bug #1672066)

1 Like

Thanks for sharing this! It appears I am using an older version. This is a much easier way to check resolution! I’ll update the tutorial.

2 Likes

Hey @Scotty thanks for sharing this info! I actually used this just the other day to get some letters from Inkscape to gcode. Just wanted to point out that in this tutorial you don’t include the bit about making sure to use the Path to Object tool before uploading the svg in MakerCAM, although you do in your original post about the N. I found the info but it would be helpful to add that in. Thanks!!

1 Like

Good catch @hannah. Just added it to Step 2. Thanks!

1 Like

I’m working with inkscape and following the directions listed here, but when I move my .svg file to makercam my drawing is coming up a smidge smaller than the dimensions I’m providing.

As an example, a 14 inch section is showing up on makercam as 13.9138 inches, which isn’t huge, but enough to goof up what I’d be building.

Is this something in my .svg, makercam, or just me being on a mac?

How are you measuring in MakerCAM? I’ve never found a way to do that, but have so wanted that feature on so many occasions.

Makercam has an option to check the x/y coordinates of any joint on an object. I’ve been checking length by using that coordinate display and manually subtracting the higher number from the lower number (or adding if there’s a negative).

You can actually input where you want it to be on the grid from there, but it doesn’t save any dimensions or move anything else around. To say makercam isn’t robust is an understatement.

Basically, my SVG’s are displaying on makercam at 99.38xxx% size for some reason.

1 Like

cool… just found that option… never new what that tool did until now; i guess i never moved it over an intersection before when i selected it.

being that your are on a mac; i’m guessing you are running an older version of inkscape? or are you running v0.92?

I’m running on v0.92.2 now. I started on an older version but have gone back through everything since updating.

I did move my .svg’s to a windows PC and try putting them on makercam from there. Same results.