Is Makerverse still alive?

I just tried to build Makerverse (MV) on both Mac and Windows and getting similar results, namely a bunch of i18next-scanner: Unable to parse I18n component .... SyntaxError: Unexpected token.

Is MV being kept up to date?
Can anyone build this?

It has been a while since I have tried to build this. I wonder if the open workshop validation link is no longer working. I was going to remove it for my build but I’m not fluent in nodejs and I don’t use it anymore so it wasn’t worth the time investment. That is still an option.

I found that spot in the code and forced it to true to disable the stupid login. I just can’t get MV or now ground control to compile and run.

 % distsf/main                                                                                                                                          (master)WebControl
Traceback (most recent call last):
  File "", line 2, in <module>
    from app import app, socketio
  File "PyInstaller/loader/", line 499, in exec_module
  File "", line 1, in <module>
    from flask import Flask
ModuleNotFoundError: No module named 'flask'
[67701] Failed to execute script 'main' due to unhandled exception!
davec@air ~/Dropbox/CNC/Software/WebControl
 % pip list                                                                                                                                             (master)WebControl
Package         Version
--------------- -------
app             0.0.1
bidict          0.22.0
click           8.1.3
Flask           2.2.2
Flask-Mobility  1.1.0
Flask-SocketIO  5.3.1
itsdangerous    2.1.2
Jinja2          3.1.2
MarkupSafe      2.1.1
netifaces       0.10.6
numpy           1.23.4
pip             22.3
python-engineio 4.3.4
python-socketio 5.7.2
setuptools      3.3
socketio        0.2.1
Werkzeug        2.2.2
wheel           0.37.1

If you are familiar with this build process, please excuse my basic level explanation. I was surprised initially at the tedious process to build webcontrol and makerverse compared with the ease of compiling the arduino firmware. Building ground control and webcontrol has been challenging in the past due to the dependency requirements that had to be installed. Some of them (opencv for example) had to be built on your machine and not just installed. It looks like you need flask installed. The error you show above is for webcontrol. To start the build process, you need to:

pip install -r requirements.txt

the pip list shown should be from the requirements.txt file.
it is adviseable to install a virtual environment for webcontrol and a separate one for groundcontrol and install the requirements for each and build them within that activated virtual environment to ensure you have the correct dependencies loaded and available.

Again, if you already knew this, I don’t mean to talk down to you. If you are less familiar with how this works as I was when I started, you can google venv and look into how to activate that environment and then run the pip command given above and build your webcontrol.

I dont’ see why you need to build makerverse for the mac though. You should be able to download a built version here and then check the alpha test option and it will pull 1.1.5 version to use.

Thanks for the help, I have been programming since about 1977 but primarily in Forth and assembly. This application seems to be extremely overly complicated and I am not a pro Python programmer.

I discovered most of what you wrote already and indeed setup a venv and modified the requirements and actually have webcontrol running as of an hour ago and now to see if I can actually connect to the controller.

The primary reason for doing this is to try and figure out why calibration is such a bear. I see a bunch of GRBL variables some of which must be associated with calibration. I want to see how the software does the calibration because my M2 doesn’t seem to want to use the values I set in in the edge phase.

Also, I want to disable this login requirement for Makerverse, but still have not gotten MV to compile yet.