Latest firmware and calibration

I loaded the v0.76 firmware but in the console upon startup, it said the engine was at V0.75. My calibration com[pleted without any issues! I did see a message that the calibration could not start because the bands were not fully extended, so I retracted them again, and made sure I put tension on them while they extended until they stopped. This seemed to solve that problem (I didn’t havce to turn to a forum search). I also got a red light but power sequencing the unit corrected the problem.

1 Like

I’m showing the wrong firmware version as well. When I update to the latest version, it displays the previous version number.

For instance, when I updated to 0.75, it displayed 0.74. I thought it just wasn’t updating, but when I tried to update to 0.76 this week, it started displaying 0.75.

I don’t get any errors during the update process.

1 Like

I noticed the same thing when I tried to update to 0.76 yesterday. The log on the console reported v0.75 after successful update to 0.76. I know it can’t be 0.75 because the last firmware update I made was to v0.74.

Another strange thing that is happening is that when I connect to the maslow AP and open my browser window (MacOS using Firefox) sometimes, but not every time, it opens to a strange window that is not the ESP3D dashboard, but some other browser window that has only two options: update firmware, and upload files. No FluidNC settings, no dashboard controls. Sometimes all I have to do is click on the refresh files icon and it opens the dashboard, other times it won’t take me to the dashboard at all. When I try to update the index.html.gz from this screen it stalls at 84% progress and does not finish. I tried multiple times, and physically restarted the Maslow and my laptop multiple times before I was finally able to successfully update the firmware, index.html and maslow.yaml files from the FluidNC tab on the ESP3D page. Next time I have this issue I’ll take a screen grab and share it here. Anyone else seen this?

1 Like

I’m pretty sure the last few releases have been off by one from what is reported on the console vs. what @bar is calling them on the GitHub repository download site. 0.76 reports as 0.75, 0.75 reports as 0.74 + some characters identifying the branch. I think maybe 0.74 reported as 0.74 only. At least, that is what I have seen.


:grimacing: That sounds like that might be my fault…well it’s absolutely my fault. I’ll double check this week and make sure if I’m off by one that I get it right.

1 Like